Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 06-15-2011, 09:01 AM
bonnie27clyde bonnie27clyde is offline
Registered User
Location: MA
 
Join Date: Jun 2011
Posts: 1
Mein Auto: 2006 530xi
'06 530xi NAV glitch

Hi there! This is my first post. I upgraded my NAV disc at least 6 months ago and for the past 2 weeks, it has been quitting in the middle of navigating...I keep getting an error message that there is a problem with the DVD and "pls insert NAV DVD..."etc...sometimes ejecting the DVD and re-inserting it helps, but inevitably, it stops and displays the error. I cleaned the disc with a disc repair kit last night and this morning it worked for a 45 minute drive; however, when I got back in the car it malfunctioned again.

Is there a way to re-set the unit? Or clean the inside?

Any other ideas out there?
Reply With Quote
Advertisement
  #2  
Old 06-15-2011, 08:13 PM
HWF's Avatar
HWF HWF is offline
BMWCCA Member
Location: New Jersey
 
Join Date: Nov 2006
Posts: 682
Mein Auto: ED 2012 535xi TiAg
Send it back and ask for a replacement.
__________________
Prod Date 4/5/12, ED: 4/19/12, Redelivery 6/20/12, 535xi, TiAg on Gray Dakota, Anthracite Wood, Cold Weather, Premium Pkge, Tech Pkge, Side and Top Cameras
ED: 2007 530xi, Monaco Blue on Gray Dakota
Reply With Quote
Reply

Bookmarks

Tags
error message, glitch, nav


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms