Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)

E36 /7 Z3 (1996-2002)
E36/7 Z3 roadster and coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-22-2011, 07:43 AM
EarlyRider EarlyRider is offline
Registered User
Location: Maryland
 
Join Date: May 2010
Posts: 36
Mein Auto: Z4
Z4 Electronic Steering warning light

My wife's 2007 Z4 had a one time (so far) illumination of the Electronic Steering Failure warning light along with no power steering assist for her short drive home. This happened a few days ago and has not happened again, yet. Steering is fine and no light. Has anyone else had this occur and was it a fluke or the beginning of an electronic steering component failure? Appreciate any experience from other owners.
Reply With Quote
Ads by Google
  #2  
Old 06-23-2011, 10:56 AM
Swanicyouth's Avatar
Swanicyouth Swanicyouth is offline
Officially Welcomed to the 'Fest
Location: Limerick PA
 
Join Date: Feb 2011
Posts: 160
Mein Auto: M Roadster
Mine failed one day and never worked again in my 03. Was a 5k $ repair under warranty at the time. Part of the reason I eventually traded it for an M, as they have regular PS.
Reply With Quote
  #3  
Old 06-24-2011, 05:03 AM
pokeybritches pokeybritches is offline
Officially Welcomed to the 'Fest
Location: Gulf Coast
 
Join Date: Jan 2008
Posts: 162
Mein Auto: 06 Z4MR, 03 Z4 3.0i
I had a battery terminal connection come loose and momentarily break contact when I hit a bump, causing the EPS light to illuminate. However, I never lost power steering. The light went away after tightening everything down and restarting the car.

Even though a battery connection probably wasn't the cause of your problem, the light can illuminate under certain electrical surges/interrupts in power supply and then reset itself upon a restart. If it becomes a recurring problem, I wouldn't isolate my troubleshooting to the EPS.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms