Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E46 M3 (2001-2006)

E46 M3 (2001-2006)

Reply
 
Thread Tools Display Modes
  #1  
Old 12-15-2006, 06:44 PM
DINANized3's Avatar
DINANized3 DINANized3 is offline
Under Construction
Location: TeXaS
 
Join Date: Sep 2006
Posts: 247
Mein Auto: 1994 325i saloon
Question EML light came on????

Had an EML light come on last night while driving..when stopped at a light i turned the car off and back on and it went away. Well had the same thing happen today after leaving a friends house..car actually went into limp mode a few miles down the road so i pulled into a parking lot and turner the car off and back on and voila gone again. Car is 2002 SMG with 42500 miles...any ideas what it could be? When searching it seems most peoples EML lights come on in conjuction with the SES light but i only had the EML light? Trying to avoid the dealer screwing me with no KY so any input would be appreciated.

Not sure if its relevant but i have been riding the car kinda hard the past two days...seems that the light would come on some time after pulling to redline in 1st/2nd. But not immideatley (sp) after?!?

Havent been driving it too hard though considering what most people with these cars do P>S this is my brothers E46 M3
__________________
"Float like a Caddy sting like a Bimmer!"
Reply With Quote
Advertisement
  #2  
Old 12-15-2006, 07:04 PM
DINANized3's Avatar
DINANized3 DINANized3 is offline
Under Construction
Location: TeXaS
 
Join Date: Sep 2006
Posts: 247
Mein Auto: 1994 325i saloon
I have someone post that it was there fuel filter that had went out something about a regulator in the fuel filter?
__________________
"Float like a Caddy sting like a Bimmer!"
Reply With Quote
  #3  
Old 12-16-2006, 08:59 AM
DJ_INHALE DJ_INHALE is offline
Banned
Location: phoenix, az
 
Join Date: Mar 2006
Posts: 4,604
Mein Auto: higher mile m3
about 6 months ago same thing happened to me

1. driving eml light comes on. I turn off car, light never came back on. Still hasnt come back on.
Reply With Quote
  #4  
Old 12-24-2006, 09:51 AM
deilenberger deilenberger is offline
Just another bozo..
Location: Spring Lake NJ
 
Join Date: Oct 2003
Posts: 61
Mein Auto: '03 525iTs '02 M3C
Without pulling the codes - all anyone here is doing is GUESSING. It's your brothers M3 you blew up? Whew.. wouldn't want to be there for that conversation.
__________________
Don Eilenberger
'07 R1200R, '02 M3Cic, '03 525iT
Join the BMW-CCA: https://www.bmwcca.org/members/am/te...&ref_id=104316
Reply With Quote
  #5  
Old 12-24-2006, 06:11 PM
DINANized3's Avatar
DINANized3 DINANized3 is offline
Under Construction
Location: TeXaS
 
Join Date: Sep 2006
Posts: 247
Mein Auto: 1994 325i saloon
No I didn't do it just posting to help him out,turns out after going to Moritz BMW that he needs a new tps motor not the sensor the actual motor 390 dollar dealer only part and another 400 dollars in labor wow!
__________________
"Float like a Caddy sting like a Bimmer!"
Reply With Quote
  #6  
Old 01-17-2007, 12:19 PM
greenyweenie greenyweenie is offline
Registered User
Location: Denver, CO
 
Join Date: Mar 2005
Posts: 8
Mein Auto: Not yet
EML light

Same problem last fall on my 01. Light came on then off, then stayed on and the car went into limp mode. It was the ignition coils (theses were a recall item) so no charge.

Not sure if the EML is the same as the SES light...but mine was the SES light.
Reply With Quote
  #7  
Old 01-17-2007, 12:28 PM
lochness lochness is offline
Officially Welcomed to the 'Fest
Location: PA
 
Join Date: Apr 2006
Posts: 210
Mein Auto: e46 M3 Dinan / e70 X5 35
Similar thing in 2002 330xi but light eventually stayed on and wouldn't go off after shutting off and restarting. It turned out to be a sensor covered under warranty and never came back on after replacing.
Reply With Quote
  #8  
Old 01-19-2007, 07:05 PM
DJ_INHALE DJ_INHALE is offline
Banned
Location: phoenix, az
 
Join Date: Mar 2006
Posts: 4,604
Mein Auto: higher mile m3
the good ole

CTRL ALT DEL

on a bmw does seem to work
Reply With Quote
  #9  
Old 02-04-2007, 04:31 PM
DINANized3's Avatar
DINANized3 DINANized3 is offline
Under Construction
Location: TeXaS
 
Join Date: Sep 2006
Posts: 247
Mein Auto: 1994 325i saloon
Heres a quick update sorry I have not been on here in A LONG TIME.My brother took the m3 to Moritz BMW they told him 900 dollars for a throttle motor and all this other crap.Well we were told it was probably just the TPS sensor by another M3 owner.So long story short it was the TPS sensor Moritz screwed up and had to refund my bro 581 dollars and install the right part.Get this thoug some moron ran his car through a auto car wash and tore up two brand new rims they are currently sending them off to be refinished as we speak.They didnt even tell my brother we noticed it and some moron also took the car for a 30 mile joy ride so now my bro writes down his mileage.
__________________
"Float like a Caddy sting like a Bimmer!"
Reply With Quote
  #10  
Old 02-11-2007, 03:08 PM
DJ_INHALE DJ_INHALE is offline
Banned
Location: phoenix, az
 
Join Date: Mar 2006
Posts: 4,604
Mein Auto: higher mile m3
Quote:
Originally Posted by DINANized3 View Post
Heres a quick update sorry I have not been on here in A LONG TIME.My brother took the m3 to Moritz BMW they told him 900 dollars for a throttle motor and all this other crap.Well we were told it was probably just the TPS sensor by another M3 owner.So long story short it was the TPS sensor Moritz screwed up and had to refund my bro 581 dollars and install the right part.Get this thoug some moron ran his car through a auto car wash and tore up two brand new rims they are currently sending them off to be refinished as we speak.They didnt even tell my brother we noticed it and some moron also took the car for a 30 mile joy ride so now my bro writes down his mileage.

I believe their are 2 accounts were bmw techs have totalled M3s from this site
Reply With Quote
  #11  
Old 02-27-2008, 01:54 PM
tlebofsky tlebofsky is offline
Registered User
Location: Newport Delaware
 
Join Date: Feb 2008
Posts: 1
Mein Auto: 1992 535i
I just had the same thing happen to me. So I checked my trans fluid and it was low. I filled it to spec and haven't seen the EML light in weeks. Hope that helps.
Reply With Quote
  #12  
Old 05-21-2011, 06:14 PM
jrosado23 jrosado23 is offline
Registered User
Location: Puerto Rico
 
Join Date: May 2011
Posts: 1
Mein Auto: 523 I
I have a 523I and yesterday i change the PCV. When i turn the car on and i acelerate the car, lights EML comes on. And the light with a triangle and a car inside comes on too and the car won't go over 40mph. If somebody got a clue and can help me i will apreciate.
Reply With Quote
  #13  
Old 07-08-2011, 08:25 AM
///M3_Letty ///M3_Letty is offline
Registered User
Location: California
 
Join Date: Feb 2011
Posts: 9
Mein Auto: BMW E46 M3 Carbon Black
I called BMW with the same problem when they looked at said there was some currosion on the wires and cleaned it up free of charge and i havent had the problem since.
__________________
If it don't fit force it in!
Reply With Quote
  #14  
Old 03-24-2016, 05:58 AM
Schnout Schnout is offline
Registered User
Location: HotLanta
 
Join Date: Nov 2012
Posts: 18
Mein Auto: 04 M3 vert
Problem solved

Old post, but current response. I solved this problem with my 2004 E46 vert.

EML + Brake Light + DSC = TOTAL LIMP MODE.

Temporary fix...shut off the car. Restart...don't do what you did just before going into limp mode.

For me...the permanent fix was replacing the "front" Throttle Position Sensor (TPS) (located directly adjacent to the oil filter); (Part number 13-63-7-840-383). $50 at any of a number of online suppliers.

I "dealt with" this problem for about a year; just making sure not to accelerate too much Who the hell wants to drive an M3 like that???

The reason I dealt with it was that nowhere could I find a definitive solution for the problem. FINALLY...I just decided "WHAT THE HECK. THE CAR IS 12 YEARS OLD...AND...IT'S ONLY 50 BUCKS. CAN'T HURT TO PUT IN A NEW TPS."

So...I spent literally less than 10 minutes to replace the front TPS. When I took out the old one, the rotational "switch"/sensor mechanism (which is connected to the end of the throttle control rod causing the sensor internals to rotate inside its housing) was "sloppy" - jiggling around inside the TPS housing. Clearly this sensor had been mechanically worn through probably MILLIONS of rotational cycles.

I put in the new TPS and HOLY CRAP WOW!!!

Let's not even talk about solving the EML/Limp problem...the IMMEDIATE RESPONSE IN INCREASED POWER...INCREASED THROTTLE RESPONSE...NIMBLENESS...

I've driven this car for SEVEN YEARS...AND NEVER FELT IT RUN LIKE THIS!!!

For years, I'd been wanting to run the Suchez Loop (North Georgia mountains), but never dared...because of the EML problem.

Well...just this week, I ran it with my Porsche 944 buddy...who runs it all the time...In spite of his 800 pound lighter vehicle, his driving experience, and his familiarity with the road (which I have never even seen); I was almost nearly able to stay on his tail most of the way...except in the tightest serpentine sections...but...I was close...and thanks to the new TPS...I was able to regain much of the distance in the (very short and very brief) straight sections.:bump:

and...we ain't talking about any "GRANNY DRIVING" here boys & girls...

It was ONE VERY SERIOUS RUN...hitting speeds of 100mph+ for brief moments...just before braking into the turns...over and over again...

Let's just say that my oil temp was quite high when we were done:hattip:

MORAL OF THE STORY...If you ain't changed out your TPS (there are two of them - identical P/N - one on each end of the throttle system), and your car is "old enough" to have cycled these sensors a few million times...

CHANGE THEM NOW!!! REGARDLESS OF WHETHER OR NOT YOU ARE EXPERIENCING EML PROBLEM (YET).

I bought two...and fortunately the easy one solved "THE PROBLEM," but now I am going to install the second one, which is evidently below the intake manifold...a bit tougher to get to...but it's gonna be WELL WORTH the small extra effort.
Reply With Quote
  #15  
Old 06-25-2016, 03:59 PM
CarterV69 CarterV69 is offline
Registered User
Location: London
 
Join Date: Jun 2016
Posts: 1
Mein Auto: E46
EML - fuel Filter change

Quote:
Originally Posted by DINANized3 View Post
I have someone post that it was there fuel filter that had went out something about a regulator in the fuel filter?
Hi I had EML light issue and read all the horror stories about dealers ripping people off - my local guy new this said its fuel filter - and he changed it (50) it had never had been changed since it was new in 2000. Done a year ago it hasn't come back on - touch wood!
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E46 M3 (2001-2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
'1 Brake Light Failure' Weird Situation hunt1200 E36 (1991 - 1999) 20 05-20-2011 04:54 PM
2000 528i Brake Light Problem via Console rsh E39 (1997 - 2003) 8 09-15-2008 01:15 PM
SES light comes on after cold start and hard acceleration (2001 740i) emmsys 7 Series / 8 Series 7 03-14-2006 06:25 PM
Door Locks, Brake Light, Climate Control - Connected? spentcase X5 E53 (1999 - 2006) 1 02-14-2006 05:15 AM
Tail light replacement shayser E36 (1991 - 1999) 1 03-29-2005 04:30 PM


All times are GMT -7. The time now is 08:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms