Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)

E89 Z4 (2009 - current)

Reply
 
Thread Tools Display Modes
  #1  
Old 07-20-2011, 03:27 PM
Photoflash Photoflash is offline
Registered User
Location: Little Canada, MN
 
Join Date: Mar 2011
Posts: 12
Mein Auto: Mustang
Question Radio Question

I'm feeling rather stupid, asking some of the questions I have, but figure other BMW owners would be the best resourse to talk with.

My 2003 Z4 has the Harmon Kardon radio system. I drove it about two weeks ago, then parked it (outside, as I have no garage) I put a mini top on it. We have had torrential rains, high heat and humidity here in Minnesota. (My friends tell me Florida is where it is hot and humid...don't believe them!!)

Anyway, my battery pit had water in it, maybe 3/4 to an inch deep. The carpets are quite moist, but that is a different question.

My radio comes on, but NO SOUND! The manual says something about high heat and humidity will affect the playing of the radio. There is a message when I scroll through which says REG OFF does this mean anything? I can't find a reference to that in the owner manual.

I love this car, but being a new owner (2003, Dinan, with 22, 300 miles) I'm frustrated.

Anyone have an idea of what is going on?
Reply With Quote
Advertisement
  #2  
Old 07-20-2011, 04:22 PM
marcw's Avatar
marcw marcw is offline
Officially Welcomed to the 'Fest
Location: Portland
 
Join Date: Jun 2008
Posts: 149
Mein Auto: 325i
I don't have an answer for you. Just as a suggestion you should ask your questions in the old Z4 forum. This forum is for E89 Z4 model year 2009 and up. You might have more luck getting an answer here: http://www.bimmerfest.com/forums/forumdisplay.php?f=7
__________________

2010 sDrive35i Sapphire black, beige leather, premium, sport, 19" wheels, premium sound, nav, cold, comfort access, alarm, smartphone, 6 speed manual
2006 530xiT Wagon, Monaco Blue/black, premium, cold, PDC, Logic 7, Comfort Access, rear shades

BMW CCA Member# 164977
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 05:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms