Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 07-23-2011, 10:55 PM
Quizzle23 Quizzle23 is offline
Registered User
Location: Denver, CO
 
Join Date: Apr 2011
Posts: 78
Mein Auto: X5
Angry Stalled and could not drive more then 2 mins, HELP PLEASE!!!!

I have been driving all day, not non stop but running errands and stuff. While on my way to Colorado Springs I stop at a stop light and my car turns off. The battery light and oil light come on. I start it back up and it studders a little bit, I get off the main road and pull over. When I stop it shuts off again, I open the hood and wait. I called my mechanic and she advised me to pull up the back seat and hit where the fuel pump cord is behind the passenger seat and try turning it on while doing so. So I did so and my gf started the car and it worked but I could only drive about 3 blocks before it did it again. The 3rd time I noticed the RPM Gage was stuck at 2. I wait about 30 mins and then drive 2 blocks up the street to get out of the sun while waiting for the tow truck. I was able to start the car 4 or 5 times while waiting for the tow truck but the car did not shut off any of those times. I did noticed the first 2 times that it wanted to shut off because it was acting as if it was gasping for something. After waiting 3 hours the tow arrived and once I got home I was able to drive the car into my garage and park it, while doing this none of the previous symptoms occured. What the hell is going on ?!?!? My mechanic thinks its the fuel pump but I have been reading about the possibility of vapor lock. If it is vapor lock will replacing the fuel pump fix it and if not how do I stop it from vapor locking? Are there any other possibilities it could be and has anyone else had any issues like this?? I bought this car in April and love it but to be completely honest I am absolutely mortified about this situation, any help would be great.

Thanks
__________________

2006 X5- Onyx
2006 X3-Indigo RIP

Last edited by Quizzle23; 07-23-2011 at 10:58 PM.
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms