Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F07 Gran Turismo (2010 - Current)

F07 Gran Turismo (2010 - Current)
The 5 Series Gran Turismo -- now available in the USA as a 535i, 550i and 550i xDrive model.

Reply
 
Thread Tools Display Modes
  #1  
Old 07-31-2011, 05:53 PM
Mikeee Mikeee is offline
Officially Welcomed to the 'Fest
Location: Mesa, Arizona
 
Join Date: Feb 2007
Posts: 125
Mein Auto: 2010 535i, Barbera Red
Dashboard display engine symbol

I have tried several searches but can find nothing on this topic. Clearly I am missing something. A light came on today on my cockpit display/instrument cluster. The light is yellowish (I am color deficient) and is a symbol of a little tiny engine. There is no other hint of any problem. All the system checks say ok. The manual has only a tiny bit of information on this symbol, but it says it applies only to Canadian models. As far as I know mine is not a Canadian model. I bought it new in Arizona. The manual refers to the light as "Exhaust-gas values for Canadian models" and refers to page 216.

On page 216 it mentions two things. The first is possible "excessive misfiring of the engine" going on to say how it can cause engine damage. But the car runs fine.

The second is a possible fuel filler cap not properly tightened. So I took the cap off, put it back on and tightened it. The manual says further if this was the problem the light will go out in a few days. Just to try it I drove it on the freeway for about 50 miles and the light stayed on. So maybe it will shut off in a few days.

Any other ideas out there regarding this light?
__________________

2010 535i, Barbera Red Metallic, Creambeige/black Dakota leather, Sport, Nav
Reply With Quote
Advertisement
  #2  
Old 07-31-2011, 08:29 PM
car-fan's Avatar
car-fan car-fan is offline
Officially Welcomed to the 'Fest
Location: SoFla
 
Join Date: Jan 2010
Posts: 552
Mein Auto: 2012 650cic/ 2012 M3 ZCP
Often times the alert you see is related to emissions. I have also seen the light come on due to bad gas. Mind you I mainly use Shell or Mobil Premium (93 Octane), and never less than premium regardless of the gas brand. I made sure to run the car to slightly less than a quarter tank, and then filled up. After which the light turned off and stayed off.

There is not much information concerning the Engine light. If you do not detect any noticeable changes in performance give it a day or so to go off. The secondary alerts will let you know of any major engine malfunction(s). It is also likely that an error code will be stored as well, so that your SA can diagnose the issue.
__________________
2012 650cic Space Gray/Vermillon Red/Blk.Top/Lux Seating/Heated Seats/Style 356/Apps/Prem. Sound(retired)
2012 M3 AW/FR NDH2/2MK/ZPP/ZCP/ZCW/752/6NR/+ all optionsexcept sunroof/OEM CF splitters/OEM CF mirror caps
2011 MINI CooperS BRGII/Lounge Green/Sport/Prem/Connect/Black Xenon/Black Conical Spokes/ACS springs/ACS exhaust/Alta Shorty
2012 X3 35i Titanium Silver/Black ZAP/ZPP/TECH/APPS/Breyton GTS/Continental Extreme DW (20's)

Last edited by car-fan; 07-31-2011 at 08:31 PM.
Reply With Quote
  #3  
Old 07-31-2011, 08:38 PM
jadnashuanh jadnashuanh is offline
Officially Welcomed to the 'Fest
Location: NH
 
Join Date: Jun 2011
Posts: 733
Mein Auto: 535ix-drive GT
Somebody told me (I don't know if it is true), that it takes a series of separate runs, not a single run, before the computer will say things are okay again. So, if true, that one run isn't enough. See what happens in a couple of days, or take it in and have them check it.
Reply With Quote
  #4  
Old 07-31-2011, 08:49 PM
Mikeee Mikeee is offline
Officially Welcomed to the 'Fest
Location: Mesa, Arizona
 
Join Date: Feb 2007
Posts: 125
Mein Auto: 2010 535i, Barbera Red
Good thoughts. Thanks. I will likely call the dealer in the morning just to double check. But it seems giving it a couple days may solve the problem.
__________________

2010 535i, Barbera Red Metallic, Creambeige/black Dakota leather, Sport, Nav
Reply With Quote
  #5  
Old 08-08-2011, 09:10 PM
Mikeee Mikeee is offline
Officially Welcomed to the 'Fest
Location: Mesa, Arizona
 
Join Date: Feb 2007
Posts: 125
Mein Auto: 2010 535i, Barbera Red
All turned out ok. The next day this light shut off. It appears to have been the fuel cap as thought. NICE.
__________________

2010 535i, Barbera Red Metallic, Creambeige/black Dakota leather, Sport, Nav
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F07 Gran Turismo (2010 - Current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 04:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms