Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)

E36 (1991 - 1999)
The E36 chassis 3-Series BMW was a huge hit among driving enthusiasts from the first moment the car hit the pavement. The E36 won numerous awards over the years it was produced and is still a favorite of many BMW enthusiasts to this day! -- View the E36 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-27-2011, 01:25 AM
puttitat puttitat is offline
Registered User
Location: Denmark
 
Join Date: Jul 2011
Posts: 14
Mein Auto: E36 Coupe
1992 E36 325i - Rough idle at all times. Hesitates when cold.

Hi,

I've got an issue with erratic idle on my E36 325i Coupé Non-VANOS.



It's not really the classic 400-1000 rpm surge, it's just erratic, sounds as if cams are swapped.

Tried disconnecting O2 sensor. No go.
Tried disconnecting TPS sensor. No go.
Tried disconnecting water temperature sensor (blue). No go.
Tried disconnecting MAF. No go.
Tried disconnecting IAT sensor. No go.
Tried another ECU. No go.
Tried another MAF. No go.
Fitted new rubber boot. No go.

Haven't checked the ICV as it's not surging as much as just being erratic.

It idles poorly at all times, when cold it surges a bit from 7-800 rpm in "jumps", and the engine hesitates while driving. Seems "nervous" in its running. After approx. 4 miles, the hesitation disappears as fog to the sun (litterally from one second to another!), and all is well - except for the rough idle as told above.

If I start the engine when it's hot, and drive, the hesitation is not present. It's only when driving for the first few miles after a cold start in the morning.



SOLVED!!!!!! CPS was the culprit.

Last edited by puttitat; 09-27-2011 at 08:23 AM. Reason: SOLVED
Reply With Quote
Advertisement
 

Bookmarks

Tags
325i, e36, hesitate, idle, sensor


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:28 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms