Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #28  
Old 10-13-2011, 05:37 PM
italiano italiano is offline
Registered User
Location: columbus, Oh
 
Join Date: Jun 2007
Posts: 70
Mein Auto: 2007 BMW 745li
Finished the project yesterday replaced both of those diverter metal valves at the rear of the engine replaced the two hoses and the Y connection, broke a hose because it was so brittle the thing fell apart. 2 valves $130 each, had to replace the manifold gaskets when I took off the manifold 2 gaskets at $35 a piece the the hose with the Y connection $60 bucks and the hose I broke is two two separate hoses (Lucky me that bmw revised) now 2 at $50 bucks a rip. Total cost was $533.00. Put the whole thing together after about 2 hours and the cars leaks fuel everywhere. Just great. Find out that when I pulled that fuel rail a couple of my injectors stayed inside. There is an O ring on the bottom part but also the top part of the injector. The top o rings slipped off and stayed in the wire harness part without me knowing. When I put the injectors back in the were a little loose which I though was funny but didn't realize what I did. So after removing everything for the second time fixed 3 injectors with no o rings on the top than put it back together. Ran rough than cleared itself out. Turned off the p0491 code and hope like hell that the valve was the problem. If not im guessing it will be a carbon build up problem and Im screwed. I'll keep the update in a couple weeks see if she turns back on, I can just hear that high pitch ding in the back of my head its the worst sound ever when that check engine light comes back on.
Reply With Quote
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms