Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)

E36/7 Z3 (1996-2002)
E36/7 Z3 Roadster, Z3 coupe, Z3 M Roadster and Z3 M Coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-01-2011, 04:16 PM
tjh54 tjh54 is offline
Registered User
Location: Marietta, Georgia
 
Join Date: Nov 2009
Posts: 44
Mein Auto: bmw 2001 z3
2001 z3 camshaft position sensor

My 2001 z3 3.0i is showing the check engine light. I read it and it gave me the code for intake camshaft position sensor. I changed it and the same code has returned. Does anyone have any ideas?
Reply With Quote
Ads by Google
  #2  
Old 10-01-2011, 07:50 PM
IgotBMW's Avatar
IgotBMW IgotBMW is offline
BE IRIE
Location: So Cal
 
Join Date: Jul 2010
Posts: 769
Mein Auto: 1996 Z3 1.9L M44
DId you clear the code?
__________________

1996 Z3 (M44)
Reply With Quote
  #3  
Old 10-02-2011, 07:39 AM
tjh54 tjh54 is offline
Registered User
Location: Marietta, Georgia
 
Join Date: Nov 2009
Posts: 44
Mein Auto: bmw 2001 z3
I cleared the code and drove it after about 10 miles the check engine came back on with the same code.
Reply With Quote
  #4  
Old 10-02-2011, 08:49 AM
IgotBMW's Avatar
IgotBMW IgotBMW is offline
BE IRIE
Location: So Cal
 
Join Date: Jul 2010
Posts: 769
Mein Auto: 1996 Z3 1.9L M44
Then you should recheck the connection and that you've installed it correctly.
__________________

1996 Z3 (M44)
Reply With Quote
  #5  
Old 10-02-2011, 12:12 PM
tjh54 tjh54 is offline
Registered User
Location: Marietta, Georgia
 
Join Date: Nov 2009
Posts: 44
Mein Auto: bmw 2001 z3
I double checked and reinstalled the intake camshaft sensor. I cleared the code and the same code returned. If anyone has an idea what to do next it would be greatly appreciated.
Reply With Quote
  #6  
Old 10-02-2011, 04:29 PM
tjh54 tjh54 is offline
Registered User
Location: Marietta, Georgia
 
Join Date: Nov 2009
Posts: 44
Mein Auto: bmw 2001 z3
BTW it has 73k miles
Reply With Quote
  #7  
Old 10-03-2011, 02:44 PM
Cobrafixer Cobrafixer is offline
Registered User
Location: Folsom
 
Join Date: Jan 2007
Posts: 33
Mein Auto: 2001 Z3 3.0L Roaster
Mine did that on the exhaust side I think (was the one in front, I didnt have to screw with the VANOS).
It had 70k miles on it!
Reply With Quote
  #8  
Old 10-03-2011, 03:33 PM
tjh54 tjh54 is offline
Registered User
Location: Marietta, Georgia
 
Join Date: Nov 2009
Posts: 44
Mein Auto: bmw 2001 z3
I glad you solved problem but I still have mine.
Reply With Quote
  #9  
Old 10-07-2011, 03:59 AM
Heloman54 Heloman54 is offline
Copterfixer
Location: Pooler, Ga. US
 
Join Date: Oct 2004
Posts: 31
Mein Auto: 2003 325ci
Thumbs up Z3 Camshaft sensor.

If you went thru all that and still have the same problem them I would think you have a bad sersor. Did you buy the original BMW sensor or aftermarket? I prefer original parts when possible, but when it come to electrical components I buy original parts only. You dont have to buy OE parts from the stealerships either. I like BavarianAutosport.com. I never had an issue with any of their parts and yes, they sell OE parts.

Last edited by Heloman54; 10-07-2011 at 05:14 PM.
Reply With Quote
  #10  
Old 10-08-2011, 03:16 AM
stryper1970 stryper1970 is offline
Registered User
Location: Paducah, Ky
 
Join Date: Aug 2011
Posts: 7
Mein Auto: 97 z3
How did you clear the code?

Sent from my DROID X2 using Bimmer
Reply With Quote
  #11  
Old 10-14-2011, 02:34 PM
tjh54 tjh54 is offline
Registered User
Location: Marietta, Georgia
 
Join Date: Nov 2009
Posts: 44
Mein Auto: bmw 2001 z3
I rebuilt the dual vanos and now it's fine. I also have better response and gas mileage.
Reply With Quote
Reply

Bookmarks

Tags
camshaft position sensor


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36/7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms