Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 10-17-2011, 07:19 PM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 805
Mein Auto: 535i 1989
535i dies, then is fine, what the H!!!

Hi, I just bought a 535i 1989 and on the way home it suddenly lost all power and just idled. I turned the car and the turned it back on and it ran fine. The engine light had turned on and then it turned off when I turned the car on.
It did it again today. I would push the gas pedal down and it ran horrible. So I turned it off and it ran fine.

Any ideas?

Andy
Reply With Quote
Advertisement
  #2  
Old 10-17-2011, 08:22 PM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
Hey Andy. With that scenario, it could be so many things. Guessing and buying random parts could get extremely expensive.

The first thing you need to do is get the codes read (I don't think you can do the stomp test on your car). Let us know what codes are stored and we can help you go from there.

Steve
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #3  
Old 10-17-2011, 08:59 PM
luckydog's Avatar
luckydog luckydog is offline
Lucky to drive a BMW
Location: Ca
 
Join Date: Nov 2010
Posts: 1,356
Mein Auto: 2006 M5///
Sounds like a electrical connection loose or failing.First I would check connection of battery. the ECU connections . Then to the supply cables under the main relay area. A bad coil may be it too.
Attached Thumbnails
Click image for larger version

Name:	006.jpg
Views:	30
Size:	144.8 KB
ID:	297554  

Last edited by luckydog; 10-17-2011 at 09:02 PM.
Reply With Quote
  #4  
Old 10-17-2011, 11:07 PM
1995i540's Avatar
1995i540 1995i540 is offline
Founder @ Maintenr
Location: New York
 
Join Date: Apr 2007
Posts: 717
Mein Auto: 1995 540I/6
Check your grounds, check your MAF, check your plugs, check your air filter, check your fuel filter and check your fuel pressure/fuel pump sending volume.
__________________


///////////////////////////////////////////// E34 Addicts


Founder @ Maintenr. Take control of your vehicle maintenance.
Reply With Quote
  #5  
Old 10-18-2011, 01:33 AM
robertobaggio20 robertobaggio20 is offline
Banned
Location: earth
 
Join Date: Oct 2009
Posts: 3,403
Mein Auto: car
The throttle position sensor. I'll bet on it. And really, don't drive this car. The engine could cut on you at any time.

One way you could fix this (if it is the tps) is to remove the tps switch, use contact cleaner on both the tps and the switch, then apply some dielectric grease to the switch and plug it right back. Then take the car out for a drive where you won't run into problems or cause problems if the engine suddenly cuts out on you.

Before doing all this, see if you can recreate the problem with the car being stationary. Maybe if it idles for 10 minutes it will cut off by itself. Or maybe it needs to be revved for 5 minutes consistently, etc. You get the picture.

Please let us know how it goes.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms