Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-27-2010, 05:55 AM
Keif Keif is offline
Master Tinkerer
Location: Houston, TX
 
Join Date: Mar 2008
Posts: 2,201
Mein Auto: 2007 Alpina B7
Post Drive control malfunction / drive moderately - steering angle sensor error - SZL

As we all know, on our E65/E66's the steering angle sensor will occasionally freak out and throw an error, with the supporting evidence being a non-self-canceling turn signal. After a little while (typically car stop/start) it will go back to acting normal.

Well, mine finally freaked out again this morning and I was able to pull the error. You'll notice that it only happened once, and that it was just for a split second.

I'm not soliciting advice on this, just providing a little information back to the community. Attached are some screen shots from pulling the error using INPA.
 
Attached Thumbnails
Click image for larger version

Name:	INPA_SZL_01.jpg
Views:	2028
Size:	131.5 KB
ID:	216345   Click image for larger version

Name:	INPA_SZL_02.jpg
Views:	1476
Size:	118.1 KB
ID:	216346   Click image for larger version

Name:	INPA_SZL_03.jpg
Views:	1442
Size:	100.2 KB
ID:	216347  
__________________
 
Black 2007 Alpina B7
Tension strut bushings
 
White 2007 Alpina B7
Supercharger clutch/bearings, replaced exhaust valve/pulled head, sunroof seal, 6000K angel eyes
 
Black 2002 BMW 745Li (sold)
KW v3's, blue angel eyes, 8000K headlights & HID fogs, rebuilt alternator & mounting bracket gasket, sunroof seal, CCVs, plugs, sway bar bushings, timing & valve cover gaskets, valve stem seals, guibo joint, mechatronic sealing sleeve, trans fluid, sanded headlights...
Reply With Quote
Advertisement
  #2  
Old 01-27-2010, 06:09 AM
gman750 gman750 is offline
G Trues
Location: North Carolina
 
Join Date: May 2009
Posts: 863
Mein Auto: 2007 BMW 750Li
could you maybe explain what some of the info means on those screens for the folks like me who have no clue what that is?
__________________
2007 750Li, Titanium Silver Metallic,Convenience Package, Luxury Seating Package, Comfort Access System, Cold weather package, 19" alloy, SAT/HD

Reply With Quote
  #3  
Old 01-27-2010, 02:36 PM
Keif Keif is offline
Master Tinkerer
Location: Houston, TX
 
Join Date: Mar 2008
Posts: 2,201
Mein Auto: 2007 Alpina B7
Sorry...
  1. The first picture is how to get to the SZL / "Satellite steering column" module from within INPA.
  2. The second picture is just a bunch of crap you'd expect to see when you look under identification for this module.
  3. The third picture has the actual error that I got, and some other stuff.
    • "ECU: SZL" ...SZL is the actual module name
    • There is a line specifying both the error number and description, "94E7 / Steering angle sensor: Relative wiper angle faulty".
    • "Error counter: 1" just says that the issue happened once in this instance.
    • "Error present now and already stored" just means that it still thinks the error is there (I didn't turn off the car before pulling this stuff). Once the car was shut off and turned back on, the module rechecked the sensor and determined that all was okay again (after this it said that the error was no longer present, but was already stored).
__________________
 
Black 2007 Alpina B7
Tension strut bushings
 
White 2007 Alpina B7
Supercharger clutch/bearings, replaced exhaust valve/pulled head, sunroof seal, 6000K angel eyes
 
Black 2002 BMW 745Li (sold)
KW v3's, blue angel eyes, 8000K headlights & HID fogs, rebuilt alternator & mounting bracket gasket, sunroof seal, CCVs, plugs, sway bar bushings, timing & valve cover gaskets, valve stem seals, guibo joint, mechatronic sealing sleeve, trans fluid, sanded headlights...
Reply With Quote
  #4  
Old 02-07-2010, 12:08 PM
kwang0429 kwang0429 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles
 
Join Date: Nov 2002
Posts: 308
Mein Auto: 2006 750i
I got the same problem today, but the good thing is, turn off the engine went for a pick up, came back and restart, it's now gone just like how u described it. thanks!
Reply With Quote
  #5  
Old 02-07-2010, 03:39 PM
haz1's Avatar
haz1 haz1 is offline
Officially Welcomed to the 'Fest
Location: Cal/USA
 
Join Date: Nov 2009
Posts: 560
Mein Auto: 2005 745i
Quote:
Originally Posted by Keif View Post
Sorry...
  1. The first picture is how to get to the SZL / "Satellite steering column" module from within INPA.
  2. The second picture is just a bunch of crap you'd expect to see when you look under identification for this module.
  3. The third picture has the actual error that I got, and some other stuff.
    • "ECU: SZL" ...SZL is the actual module name
    • There is a line specifying both the error number and description, "94E7 / Steering angle sensor: Relative wiper angle faulty".
    • "Error counter: 1" just says that the issue happened once in this instance.
    • "Error present now and already stored" just means that it still thinks the error is there (I didn't turn off the car before pulling this stuff). Once the car was shut off and turned back on, the module rechecked the sensor and determined that all was okay again (after this it said that the error was no longer present, but was already stored).
+1, Keif it looks like the counter tells how many times the error happened, but does the machine tell operators what date it happened and time? Or does the error have to occur while hooked up to the machine when in the shop?
__________________
05 745I 58K
88 735-gone 288K
80 320 gone 300K
76 280Z 2+2 RIP 325K
Reply With Quote
  #6  
Old 02-07-2010, 06:59 PM
Keif Keif is offline
Master Tinkerer
Location: Houston, TX
 
Join Date: Mar 2008
Posts: 2,201
Mein Auto: 2007 Alpina B7
In INPA by default it just shows the mileage (in KM) when it happened. I haven't checked using any of the other tools yet (DIS, etc.).
__________________
 
Black 2007 Alpina B7
Tension strut bushings
 
White 2007 Alpina B7
Supercharger clutch/bearings, replaced exhaust valve/pulled head, sunroof seal, 6000K angel eyes
 
Black 2002 BMW 745Li (sold)
KW v3's, blue angel eyes, 8000K headlights & HID fogs, rebuilt alternator & mounting bracket gasket, sunroof seal, CCVs, plugs, sway bar bushings, timing & valve cover gaskets, valve stem seals, guibo joint, mechatronic sealing sleeve, trans fluid, sanded headlights...
Reply With Quote
  #7  
Old 02-07-2010, 08:24 PM
haz1's Avatar
haz1 haz1 is offline
Officially Welcomed to the 'Fest
Location: Cal/USA
 
Join Date: Nov 2009
Posts: 560
Mein Auto: 2005 745i
Right on.
__________________
05 745I 58K
88 735-gone 288K
80 320 gone 300K
76 280Z 2+2 RIP 325K
Reply With Quote
  #8  
Old 10-20-2011, 08:02 AM
italiano italiano is offline
Registered User
Location: columbus, Oh
 
Join Date: Jun 2007
Posts: 70
Mein Auto: 2007 BMW 745li
Does anyone know how to fix the problem? It goes away after a restart but annoying.
Reply With Quote
  #9  
Old 10-20-2011, 12:33 PM
MOPAULY's Avatar
MOPAULY MOPAULY is offline
Officially Welcomed to the 'Fest
Location: Spring Mount, PA
 
Join Date: Sep 2010
Posts: 1,638
Mein Auto: Many things
Quote:
Originally Posted by italiano View Post
Does anyone know how to fix the problem? It goes away after a restart but annoying.
Lol yes you need to replace the sensor. I had the same issue taken care of under warranty. Mine would only trip after turning the wheels close to or full lock, such as backing out of my driveway.
__________________

Last edited by MOPAULY; 10-20-2011 at 12:35 PM.
Reply With Quote
  #10  
Old 10-20-2011, 04:40 PM
quarterto8's Avatar
quarterto8 quarterto8 is offline
Officially Welcomed to the 'Fest
Location: Houston,Tx
 
Join Date: Mar 2009
Posts: 1,968
Send a message via MSN to quarterto8 Send a message via Yahoo to quarterto8
Mein Auto: 04 E65 15 Escalade
Lmao at gman750 reply! Bro I've known keif for a long time now and when he starts talking bmw he goes into a zone and pretty much no one really knows what he is saying!
__________________
Reply With Quote
  #11  
Old 01-19-2012, 07:54 PM
los2much's Avatar
los2much los2much is offline
Officially Welcomed to the 'Fest
Location: south carolina
 
Join Date: Jan 2011
Posts: 297
Mein Auto: 745li
same problem how to replace it ?
__________________
Reply With Quote
  #12  
Old 01-20-2012, 07:04 AM
wjjklj's Avatar
wjjklj wjjklj is offline
Officially Welcomed to the 'Fest
Location: Louisville, Kentucky USA
 
Join Date: Dec 2008
Posts: 1,586
Mein Auto: 2009 750i
Quote:
Originally Posted by Keif View Post
As we all know, on our E65/E66's the steering angle sensor will occasionally freak out and throw an error, with the supporting evidence being a non-self-canceling turn signal. After a little while (typically car stop/start) it will go back to acting normal.

Well, mine finally freaked out again this morning and I was able to pull the error. You'll notice that it only happened once, and that it was just for a split second.

I'm not soliciting advice on this, just providing a little information back to the community. Attached are some screen shots from pulling the error using INPA.
*
Keif,

The third screenshot says on the last line that this would not cause a warning light to come on.

Every time I have had this happen (maybe 3 times in 3 years) I have received a warning light saying to drive moderately. Why does INPA say it will not show a warning light?
__________________
Reply With Quote
  #13  
Old 01-20-2012, 08:33 AM
USALEXUSBMW750's Avatar
USALEXUSBMW750 USALEXUSBMW750 is offline
Little Odessa
Location: Bergen County, NJ
 
Join Date: Oct 2009
Posts: 1,275
Mein Auto: bmw
I have this twice, once a year, when i put on my winter tires, but not happened this year thanx God
Reply With Quote
  #14  
Old 01-20-2012, 10:07 PM
Keif Keif is offline
Master Tinkerer
Location: Houston, TX
 
Join Date: Mar 2008
Posts: 2,201
Mein Auto: 2007 Alpina B7
Quote:
Originally Posted by wjjklj View Post
Keif,

The third screenshot says on the last line that this would not cause a warning light to come on.

Every time I have had this happen (maybe 3 times in 3 years) I have received a warning light saying to drive moderately. Why does INPA say it will not show a warning light?
Good question... The best I can figure is that the steering angle sensor itself doesn't cause a warning, but the failed state of the ARS/DSC system does.

Sent from my ADR6425LVW using Bimmer
__________________
 
Black 2007 Alpina B7
Tension strut bushings
 
White 2007 Alpina B7
Supercharger clutch/bearings, replaced exhaust valve/pulled head, sunroof seal, 6000K angel eyes
 
Black 2002 BMW 745Li (sold)
KW v3's, blue angel eyes, 8000K headlights & HID fogs, rebuilt alternator & mounting bracket gasket, sunroof seal, CCVs, plugs, sway bar bushings, timing & valve cover gaskets, valve stem seals, guibo joint, mechatronic sealing sleeve, trans fluid, sanded headlights...
Reply With Quote
  #15  
Old 01-21-2012, 08:57 AM
Nikki1169 Nikki1169 is offline
Registered User
Location: jax
 
Join Date: Jun 2011
Posts: 4
Mein Auto: 745li
catalytic converter

my catalytic converter is stopped up on my bmw 745 li. any suggestions
Reply With Quote
  #16  
Old 01-22-2012, 07:10 PM
AceFX AceFX is offline
Banned
Location: I come from the land down under
 
Join Date: Mar 2011
Posts: 1,338
Mein Auto: BMW 760Li BMW X5 4.8iS
Have you checked the ZGM (gateway module)


As far as the Cat goes..... can they be cleaned? They sure are expensive to buy.....

Last edited by AceFX; 01-22-2012 at 07:11 PM.
Reply With Quote
  #17  
Old 01-22-2012, 08:31 PM
Nikki1169 Nikki1169 is offline
Registered User
Location: jax
 
Join Date: Jun 2011
Posts: 4
Mein Auto: 745li
What is that?
Reply With Quote
  #18  
Old 01-22-2012, 08:57 PM
AceFX AceFX is offline
Banned
Location: I come from the land down under
 
Join Date: Mar 2011
Posts: 1,338
Mein Auto: BMW 760Li BMW X5 4.8iS
What is what?
Reply With Quote
  #19  
Old 10-29-2012, 02:01 PM
vernon3rdw vernon3rdw is offline
Vito
Location: Philly
 
Join Date: Mar 2012
Posts: 81
Mein Auto: 7 series
Do u have any idea how much without the warranty it costs

Sent from my SAMSUNG-SGH-I727 using Bimmer App
Reply With Quote
  #20  
Old 11-18-2012, 06:35 AM
seannypoo seannypoo is offline
Registered User
Location: florida
 
Join Date: Mar 2011
Posts: 3
Mein Auto: 2004 745li
i have this problem as well, and i cannot reactive my DTC
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms