Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 F25 (2011 - current)

X3 F25 (2011 - current)
The latest X3 brings some added style and some new features to the BMW SUV family. Talk about the new F25 now!

Reply
 
Thread Tools Display Modes
  #76  
Old 11-17-2011, 11:16 AM
mencomenx mencomenx is offline
Registered User
Location: New Jersey
 
Join Date: Feb 2011
Posts: 23
Mein Auto: X3
It was ok for a week then the problem came back. I brought it in again and they contacted bmw spartanburg about the problem and they mailed another software to fix the problem. So after 2 days I went back. they instralled the software and it work for only 3 days. Until they gave up and they said that the most logical way to do is just to replace the sensors. and it worked.
Reply With Quote
  #77  
Old 11-24-2011, 04:09 AM
Hawkshaw Hawkshaw is offline
Registered User
Location: Halifax, NS, Canada
 
Join Date: Apr 2006
Posts: 1
Mein Auto: 2006 330i
I just got the oil sensor malfunction warning. First snowfall was last night, maybe that's a coincidence. I'll check in with the dealer. Vehicle is 7 months old and <7000 kms.
Reply With Quote
  #78  
Old 11-24-2011, 01:59 PM
Shaw's Avatar
Shaw Shaw is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2011
Posts: 262
Mein Auto: 2011 X3 28i & 2013 328iX
Latest update:
letter I received from BMW Canada (Corporate): Although certain early production X3 vehicles experienced some calibration glitches that resulted in incorrect oil level readings, the problem was identified and promptly remedied as of May 2011 production. A simple recalibration via updated software will remedy this issue. Any BMW Retailer will be happy to update the software level of your vehicle at no cost, so you can continue to enjoy your great new X3. Take care.
Reply With Quote
  #79  
Old 11-24-2011, 02:12 PM
Shaw's Avatar
Shaw Shaw is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2011
Posts: 262
Mein Auto: 2011 X3 28i & 2013 328iX
Quote:
Originally Posted by Hawkshaw View Post
I just got the oil sensor malfunction warning. First snowfall was last night, maybe that's a coincidence. I'll check in with the dealer. Vehicle is 7 months old and <7000 kms.
Now it is getting weird:
The Oil Level Sensor Malfunction is now gone!!! After a week of cold weather, we had some higher temps... so I am thinking the same as you... it has to do with cold weather I think!!! The warning hasn't led up since then!

Anyways, I have an appointment two weeks from now to have the software upgraded. We'll see what excuse they have next.
Reply With Quote
  #80  
Old 12-23-2011, 07:47 PM
Cactus Cactus is offline
Officially Welcomed to the 'Fest
Location: Tacoma, WA
 
Join Date: Nov 2007
Posts: 323
Send a message via ICQ to Cactus
Mein Auto: 2011 X3 2.8i
I had the oil level malfunction Monday and Tuesday. Wednesday it was gone but I took my X3 to the dealer this morning. They checked it and it was OK but there is a tech bulletin released this month addressing this. I've had the vehicle since April and this is the first time I've had any issue.

They updated the software so we'll see how it goes!
Reply With Quote
  #81  
Old 03-03-2012, 01:03 PM
mechmac mechmac is offline
Registered User
Location: Canada
 
Join Date: Jun 2011
Posts: 4
Mein Auto: 2011 X3 28i
oil level sensor malfunction

Hi Bimmers,

Same problem here but surprisingly only after i washed my motor. I live up in Quebec, Canada and decided to wash off all the salt that was entering the engine compartment and voila the minute i drove it out of the garage it came on with that warning.

After driving for a few days it finally disappeared.

Now it is back and you can see why just by looking outside, the roads are sloppy and wet, slush splashing everywhere. It's been on for about two days and finally has returned to normal. I am assuming with enough driving that the engine heat dries out the moisture and corrects the problem.

I have a 2011 28i and 18,000kms.
Reply With Quote
  #82  
Old 08-08-2013, 03:36 PM
Teemo Panda's Avatar
Teemo Panda Teemo Panda is offline
Bimmefest Plasti-Dip Guru
Location: New Jersey
 
Join Date: Dec 2011
Posts: 851
Send a message via Skype™ to Teemo Panda
Mein Auto: E53, E46-M3, E70, F25-X3
I had my car in for service for about a week now, because i brought up that the Oil level indicator keeps reading 30% above min level.

Added half a quart going to bimmerfest, when i got there same level, no changes.
after i left bimmerfest, about 1hr into the drive back, it gave me a low oil warning,
Pulled off to the side and added a quart.

after 3hours finally got home, the indicator still read the same level as the original 30% above min.

So yeah, been a week now still at the shop. Hopefully it will be a Lemon soon

Not complaining about the convertible loaner they gave me thou
__________________
Reply With Quote
Reply

Bookmarks

Tags
x3.


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 F25 (2011 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms