Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)

E36 (1991 - 1999)
The E36 chassis 3-Series BMW was a huge hit among driving enthusiasts from the first moment the car hit the pavement. The E36 won numerous awards over the years it was produced and is still a favorite of many BMW enthusiasts to this day! -- View the E36 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11-29-2011, 10:40 PM
Hellrot_318is Hellrot_318is is offline
Registered User
Location: Las Vegas
 
Join Date: Aug 2010
Posts: 13
Mein Auto: E36 318is
318is dies while idling/driving and bucks

So I replaced the engine in my 97 318is with a stock M44 engine (1.9) about 3 months ago, and this problem just started happening.

The other day I was on my home from work going about 35MPH and the car started bucking. I pulled into the parking lot, shut it off, and started it back up. I drove around the parking lot and it was bucking again. I checked my battery and my positive cable is connected via a stereo terminal and it was a bit loose. I tightened it back up and disconnected the negative so the ECU can "recalibrate" hoping that was it.

The car still did it in the parking lot after that, but I gambled and drove home. It was totally fine. I thought it was a hiccup and then I remembered I usually fill it with 89 (which is what the sticker recommends), but the last time I put in a half a tank of 87. That gas was just about burned off and I filled it halfway with premium fuel.

The fuel filter is probably 3 years old (and over a year and a half the car sat while I put in the engine, long time I know). I replaced it today and started it up, and let it idle for a bit. It was totally fine, but then it just randomly died about 5-10 minutes later. It always starts back up without any problem though.

I took it for a spin around the block and it seemed fine, but then it started to buck and the throttle was unresponsive, and then it kicked back in and drove normal again.

When it idles or stalls out, it always starts back up fine.

I'm thinking:

-My o2 sensor is damaged slightly ( I think I had it still connected while removing the exhaust by accident, but it's been working for 3 months) Maybe it just gave out?
-Bad fuel pump? Do bad fuel pumps give "blips" or when they go bad, they are done for?
-MAF sensor?



Can someone point me in the right direction? Money is very tight right now and I cant afford to be throwing parts on it hoping to fix the problem.

Note: While revving it in neutral, idle to about 3K RPMS seems to be a bit rough. It's not a smooth rev.

Thanks
Reply With Quote
Advertisement
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms