Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)

E28 (1982 - 1988)

Reply
 
Thread Tools Display Modes
  #1  
Old 12-15-2011, 02:57 PM
mrbbchevy mrbbchevy is offline
Registered User
Location: NY
 
Join Date: Nov 2011
Posts: 4
Mein Auto: 528e
528e fuel pressure issue

I am almost there with this craigslist car but I've encountered something kinda funkie. I discovered an issue with the transfer pump in the tank and replaced it. fuel volume is almost double the minimum requirement now and fuel pressure will go as high as 80 psi w3hen the return is pinched off.....but.....fuel pressure is only about 32to 34 psi depending on whether the fuel pressure regulator vacuum line is on or off. Replaced the regulator and have the same results.....$80 later....I read something about the external fuel pump having a sort of noise baffle that could cause regulating issues...but that doesn't sewem to make sense here because the pressure shoots right up when you pinch the return after the regulator on the fuel rail....car runs perfect with the line pinched incidentally
Reply With Quote
Ads by Google
  #2  
Old 01-04-2012, 12:09 PM
jimoreno jimoreno is offline
Officially Welcomed to the 'Fest
Location: Parsippany, NJ
 
Join Date: Jul 2006
Posts: 487
Mein Auto: 2006 X3
I think you might have dirty injectors that flow more when the pressure is higher (expected). Are your gas lines connected properly, feed in the rear of the fuel rail and return out of the FPR? Make sure that they haven't been reversed.
__________________
Jimmy Moreno
1995 530i
1986 535i
Reply With Quote
  #3  
Old 01-06-2012, 02:03 PM
mrbbchevy mrbbchevy is offline
Registered User
Location: NY
 
Join Date: Nov 2011
Posts: 4
Mein Auto: 528e
finally

thanks for the help....I pulled the screens off of the injectors and it runs perfect....kinda high idle...but it runs great....looking at the idle now....ICM is free and functioning...rpms are bout 1500....pull the oil fill cap and drops to normal....ICM seems to be functioning to adjust to vacuum leaks and has smooth full range of motion...cleaned it anyway...same issue....any ideas?
Reply With Quote
  #4  
Old 01-09-2012, 11:03 AM
jimoreno jimoreno is offline
Officially Welcomed to the 'Fest
Location: Parsippany, NJ
 
Join Date: Jul 2006
Posts: 487
Mein Auto: 2006 X3
Are you sure the ICV is functioning? The lower RPM's when pulling the oil dipstick is expected so that is ok. Have you cleaned and adjusted the Throttle Position Switch? It needs to be properly set so the ECU sees the engine at idle. I have attached the page from the Bentley that shows how to test it.
Attached Files
File Type: pdf Throttle position switch test_M30B35.pdf (171.1 KB, 137 views)
__________________
Jimmy Moreno
1995 530i
1986 535i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 03:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms