Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 convertible and E86 Z4 coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-07-2012, 07:55 AM
Lagwagon1345 Lagwagon1345 is offline
Registered User
Location: ft walton beach fl
 
Join Date: Jan 2012
Posts: 1
Mein Auto: 2003 Z4 2.5I
Question 2003 z4 2.5I top problems

I saw another tread about top problems on here and it fixed one of my problems which was the switch in the boot . But it hadn't touched on the rest of the problem . Maybe you all have some information on this.

The automatic release on my BMW works intermittently if at all sometimes . When I try to put the top down the motor doesn't continuously turn to release the locks it kind of twitches I guess you could say . Eventually it will let loose and the top goes back and latches. Upon putting the top up sometimes it works fine and other times it has the same twitch and take forever to lock.

Any info or how to fix it will be greatly appreciated .. thanks
Reply With Quote
Ads by Google
  #2  
Old 01-09-2012, 04:10 PM
jmanscotch's Avatar
jmanscotch jmanscotch is offline
is a Texan
Location: Colorado Springs
 
Join Date: Aug 2009
Posts: 1,282
Mein Auto: '09 135 - 6MT - TwinTs
If I'm understanding you correct, I'd recommend cleaning out and lubricating the areas where the latchs lock down (along the top of the windshield). It could simple be a lubrication issue.
__________________
-Jake

2004 325Ci - 5MT - SOLD & MISSED
2003 3.0 Z4 - 6MT - SOLD
1967 1602 - 4MT - STOLEN
2008 328XI - 6MT - EX STOLE
1995 325i - RUSTED AWAY
2009 135i - COPS IMPOUNDING
Reply With Quote
  #3  
Old 01-10-2012, 07:10 AM
Cvaria's Avatar
Cvaria Cvaria is online now
Officially Welcomed to the 'Fest
Location: Tallahassee, Florida
 
Join Date: Sep 2011
Posts: 367
Mein Auto: 2003 Z4 ; 2002 Wrangler;
Quote:
Originally Posted by jmanscotch View Post
If I'm understanding you correct, I'd recommend cleaning out and lubricating the areas where the latchs lock down (along the top of the windshield). It could simple be a lubrication issue.
What are the lube points? I'm have this issue as well. I tried 3m 3-in-1 with not luck and it's messy. Motorweek is saying use white lithium grease. but i'm not sure where to apply it...

is the a e85 top diagram somewhere?

__________________
I like my 2003 Z4 2.5i... but love my smelly old 2002 Wrangler SE and evil 2007 HD Sportster 883/1200 conv!


Last edited by Cvaria; 01-10-2012 at 07:39 AM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms