Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 12-21-2011, 10:12 AM
bmw5683 bmw5683 is offline
Registered User
Location: homer glen il
 
Join Date: Dec 2011
Posts: 26
Mein Auto: 1998 bmw 5281
brake sensor light FIXED

HELP!! recently changed rotors, pads, and sensors on the rear only and the (o) light wont go away. work was done by a shop, front brakes not worked on. when should the light go away? thanks

Last edited by bmw5683; 01-10-2012 at 11:11 AM.
Reply With Quote
Advertisement
  #2  
Old 12-21-2011, 10:51 AM
bobdmac bobdmac is online now
Officially Welcomed to the 'Fest
Location: Back in Oaktown, Yay Area
 
Join Date: Feb 2011
Posts: 2,694
Mein Auto: 2001 540i/6, '90 BMW k75s
You might find this thread helpful. Read Q'Silvers post, #4.
__________________
BMW--giving new meaning to the phrase "disposable income."

Last edited by bobdmac; 12-21-2011 at 10:53 AM.
Reply With Quote
  #3  
Old 12-21-2011, 12:18 PM
bmw5683 bmw5683 is offline
Registered User
Location: homer glen il
 
Join Date: Dec 2011
Posts: 26
Mein Auto: 1998 bmw 5281
thanks i will try that tonite!
Reply With Quote
  #4  
Old 12-21-2011, 12:57 PM
bobdmac bobdmac is online now
Officially Welcomed to the 'Fest
Location: Back in Oaktown, Yay Area
 
Join Date: Feb 2011
Posts: 2,694
Mein Auto: 2001 540i/6, '90 BMW k75s
Quote:
Originally Posted by bmw5683 View Post
thanks i will try that tonite!
Do us a favor and post the outcome.
__________________
BMW--giving new meaning to the phrase "disposable income."
Reply With Quote
  #5  
Old 12-21-2011, 08:10 PM
bmw5683 bmw5683 is offline
Registered User
Location: homer glen il
 
Join Date: Dec 2011
Posts: 26
Mein Auto: 1998 bmw 5281
just tried to reset brake sensor light with the help of all the posts with no luck! i will be taking it back where i had the work done, it has to be a bad sensor or installed wrong! will post outcome
Reply With Quote
  #6  
Old 12-21-2011, 08:14 PM
pleiades pleiades is offline
Officially Welcomed to the 'Fest
Location: Oregon
 
Join Date: Jun 2010
Posts: 2,222
Mein Auto: '99 528i, M52TU w/stick
Did you check that there's a sensor back there? (And that it's not the old one....)
Reply With Quote
  #7  
Old 12-21-2011, 08:21 PM
bmw5683 bmw5683 is offline
Registered User
Location: homer glen il
 
Join Date: Dec 2011
Posts: 26
Mein Auto: 1998 bmw 5281
i was charged for new sensors on the invoice taking it back to have it checked
Reply With Quote
  #8  
Old 12-21-2011, 08:28 PM
JimLev JimLev is offline
Officially Welcomed to the 'Fest
Location: MA
 
Join Date: Dec 2003
Posts: 3,699
Mein Auto: 540/6, S60 Volvo, Tribeca
Position 2 for 30+ seconds didn't work?
If that doesn't work maybe they didn't put in a new sensors or they lost the little metal clip in the sensor.

Last edited by JimLev; 12-21-2011 at 08:29 PM.
Reply With Quote
  #9  
Old 12-21-2011, 09:16 PM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,977
Mein Auto: 1997 740iL / 2006 X5 4.4
Just for grins & giggles...try turning the ignition to POSITION 1 for 30 seconds instead of position 2.
__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg
Reply With Quote
  #10  
Old 12-21-2011, 09:22 PM
bmw5683 bmw5683 is offline
Registered User
Location: homer glen il
 
Join Date: Dec 2011
Posts: 26
Mein Auto: 1998 bmw 5281
i tried that also the darn light is still on thanks guys
Reply With Quote
  #11  
Old 12-22-2011, 09:18 AM
vclifford vclifford is offline
Officially Welcomed to the 'Fest
Location: CT
 
Join Date: Mar 2011
Posts: 194
Mein Auto: 530i
Quote:
Originally Posted by QSilver7 View Post
Just for grins & giggles...try turning the ignition to POSITION 1 for 30 seconds instead of position 2.
Try this , I think this worked for me

1. Position 1 for 30-35 seconds then
2. Position 2 for 20-30 seconds. for me it went away at the point

So when I started it went away normally

Regards,
Reply With Quote
  #12  
Old 12-22-2011, 11:58 AM
Trebbia's Avatar
Trebbia Trebbia is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Aug 2011
Posts: 201
Mein Auto: BMW E39 I6
If all else fails short the sensor wires.
Reply With Quote
  #13  
Old 12-22-2011, 12:42 PM
bmw5683 bmw5683 is offline
Registered User
Location: homer glen il
 
Join Date: Dec 2011
Posts: 26
Mein Auto: 1998 bmw 5281
tried all posts no luck gotta be the sensors will see next week
Reply With Quote
  #14  
Old 12-22-2011, 12:44 PM
bmw5683 bmw5683 is offline
Registered User
Location: homer glen il
 
Join Date: Dec 2011
Posts: 26
Mein Auto: 1998 bmw 5281
thanks for posts i'll short out to know more
Reply With Quote
  #15  
Old 01-10-2012, 11:08 AM
bmw5683 bmw5683 is offline
Registered User
Location: homer glen il
 
Join Date: Dec 2011
Posts: 26
Mein Auto: 1998 bmw 5281
found that the front driver side sensor had cracked plastic connector and was taped. made secure connection, retaped, ignition in pos. wait 30 seconds key out them start no more light.thanks guys
Reply With Quote
  #16  
Old 01-10-2012, 11:58 AM
bobdmac bobdmac is online now
Officially Welcomed to the 'Fest
Location: Back in Oaktown, Yay Area
 
Join Date: Feb 2011
Posts: 2,694
Mein Auto: 2001 540i/6, '90 BMW k75s
Thanks for the update. That kind of coincidence (front sensor going out after the rear was worked on) makes diagnosis difficult.
__________________
BMW--giving new meaning to the phrase "disposable income."
Reply With Quote
Reply

Bookmarks

Tags
brakes, brakes light, sensor


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms