Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #951  
Old 03-30-2012, 05:20 PM
Garticus Garticus is offline
A -n- P
Location: Fla
 
Join Date: Mar 2012
Posts: 18
Mein Auto: E90
Quote:
Originally Posted by Oceans10 View Post
No, but i just bought the Mobridge iPod unit. Haven't installed yet but will post later.
http://www.mobridge.us/products/most-ipod-aux
Supposedly the best solution on the market. Not cheap, but neither is the Dension.
May I ask how much you paid for the MoBridge module? I've searched their site and their 'where to buy' link but I still have not found a price for the unit.

My ex-wife has a 2009 E60 w\o Nav and she would like to have her iPod intergrated into her stereo for ease of control. (She does not fancy the aux input jack in the armrest)
__________________
G14 Classified Tech
Reply With Quote
  #952  
Old 03-30-2012, 05:58 PM
Oceans10's Avatar
Oceans10 Oceans10 is offline
Officially Welcomed to the 'Fest
Location: CT
 
Join Date: Jul 2011
Posts: 1,499
Mein Auto: BMW 535i + 535XI wagon
Around $450 or so. From Unexpected Creations in Edison, NJ. PM me if you have trouble locating.
__________________
Audio: Jehnert Flatline speakers, Mobridge M1000 DA2 prepro, Helix P-DSP, Zapco Z-150.6 amp, iDock on dash
Performance: Protuned Cobb, AR Downpipes, ER FMIC/CP, DCI, RB turbos, KW V2 coilovers, AEM 320E LPFP/ported fuel rail
Reply With Quote
  #953  
Old 03-30-2012, 06:19 PM
Garticus Garticus is offline
A -n- P
Location: Fla
 
Join Date: Mar 2012
Posts: 18
Mein Auto: E90
Quote:
Originally Posted by Oceans10 View Post
Around $450 or so. From Unexpected Creations in Edison, NJ. PM me if you have trouble locating.
Ohh, thank you for the reply & info......I'm currently working in Lakehurst on a project for a couple of months......although I work 7 days a week til' 17:30. I will find their number and contact them tomorrow or Monday.


It seems like this system work well with the iDrive E60 system.
__________________
G14 Classified Tech
Reply With Quote
  #954  
Old 04-10-2012, 07:57 AM
Oceans10's Avatar
Oceans10 Oceans10 is offline
Officially Welcomed to the 'Fest
Location: CT
 
Join Date: Jul 2011
Posts: 1,499
Mein Auto: BMW 535i + 535XI wagon
Quote:
Originally Posted by Garticus View Post
Ohh, thank you for the reply & info......I'm currently working in Lakehurst on a project for a couple of months......although I work 7 days a week til' 17:30. I will find their number and contact them tomorrow or Monday.


It seems like this system work well with the iDrive E60 system.
Yes, it gets programmed to work with BMW iDrive.
The number to call is 732 572-1969. These guys can install it too.
__________________
Audio: Jehnert Flatline speakers, Mobridge M1000 DA2 prepro, Helix P-DSP, Zapco Z-150.6 amp, iDock on dash
Performance: Protuned Cobb, AR Downpipes, ER FMIC/CP, DCI, RB turbos, KW V2 coilovers, AEM 320E LPFP/ported fuel rail
Reply With Quote
  #955  
Old 05-06-2012, 07:05 AM
Oceans10's Avatar
Oceans10 Oceans10 is offline
Officially Welcomed to the 'Fest
Location: CT
 
Join Date: Jul 2011
Posts: 1,499
Mein Auto: BMW 535i + 535XI wagon
iDock

Progress on my iDock install. You can see the tray between the instrument cluster and the iDrive screen. I took the iPhone out to take the picture.
Have another dock with better support in back, but requires some new cables I am waiting for. Will post pics later when it is all done.

i did not like the location of the SpecDock below the ashtray. This is more in line of sight and lets me see who is calling, mailing etc. I use BlueTooth, so the iDock is strictly for iTunes via Mobridge.
Attached Thumbnails
Click image for larger version

Name:	004.jpg
Views:	414
Size:	96.9 KB
ID:	323849  
__________________
Audio: Jehnert Flatline speakers, Mobridge M1000 DA2 prepro, Helix P-DSP, Zapco Z-150.6 amp, iDock on dash
Performance: Protuned Cobb, AR Downpipes, ER FMIC/CP, DCI, RB turbos, KW V2 coilovers, AEM 320E LPFP/ported fuel rail
Reply With Quote
  #956  
Old 05-14-2012, 09:19 AM
pmm21 pmm21 is offline
Someday it'll be an M5
Location: Los Angeles
 
Join Date: Apr 2012
Posts: 18
Mein Auto: 2010 528i - M Sport pkg
I've got a strange problem - hoping to find the answer.

So far I have tried 6 different iPod interface cables ( the Y cables) with my 2010 e60. 4 of the have not worked at all (cannot be recognized by the idrive,) and the 2 that work have a common problem - The audio quality is downright TERRIBLE.

When i listen to music using either my 4th gen ipod touch, or 4th gen nano it's as if I'm listening to music through blown speakers. Buzzing and static completely ruins the experience.

I've tested the aux jack (center console) independently - playing pandora via my Android phone - it works and sounds great.

So here's my question: Could it be the USB jack thats causing this (I didn't think that it would have anything to do with the audio considering the use of the aux jack?) Or could it be that I've just hit the lottery and can't seem to get a proper working cable?

If anyone has experienced this - and fixed it, I'd love to hear it. I've got a 2100 mile road trip coming up in 2 weeks, and I'd really like to have my ipod.

Thanks!
Reply With Quote
  #957  
Old 05-14-2012, 09:29 AM
Larry Cable Larry Cable is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 160
Mein Auto: '10 535i xDrive Wagon
I dont know if this is relevant, but i had a problem (from the factory) with the cable that runs from the arm rest compartment to the iDrive on my 2010 535ix Sport Wagon, the symptom was that the iDrive could not detect the presence of the iPod,
while this is not the same as the symptoms you are experiencing you may want the dealer to examine and consider replacing this connector ... since it was the USB at fault.

One suggestion, why not try connecting the iPod via the USB in the glove box (and use a longer audio cable M/F to connect the analog audio jack to the one in the ctr console. If the quality is different (better) I would suggest that the connection from the
ctr console to the iDrive is at fault!

Last edited by Larry Cable; 05-14-2012 at 09:39 AM.
Reply With Quote
  #958  
Old 05-14-2012, 09:34 AM
pmm21 pmm21 is offline
Someday it'll be an M5
Location: Los Angeles
 
Join Date: Apr 2012
Posts: 18
Mein Auto: 2010 528i - M Sport pkg
Good idea! Gonna try that now. I'll post progress.
Reply With Quote
  #959  
Old 05-14-2012, 09:38 AM
Larry Cable Larry Cable is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 160
Mein Auto: '10 535i xDrive Wagon
Quote:
Originally Posted by pmm21 View Post
Good idea! Gonna try that now. I'll post progress.
I *think* it should work, although the USB in the glove box does have different function(s) ...

at least it will tell you if the connection is bad or not ...

good luck!
Reply With Quote
  #960  
Old 05-14-2012, 09:54 AM
Oceans10's Avatar
Oceans10 Oceans10 is offline
Officially Welcomed to the 'Fest
Location: CT
 
Join Date: Jul 2011
Posts: 1,499
Mein Auto: BMW 535i + 535XI wagon
Quote:
Originally Posted by pmm21 View Post
I've got a strange problem - hoping to find the answer.

So far I have tried 6 different iPod interface cables ( the Y cables) with my 2010 e60. 4 of the have not worked at all (cannot be recognized by the idrive,) and the 2 that work have a common problem - The audio quality is downright TERRIBLE.

When i listen to music using either my 4th gen ipod touch, or 4th gen nano it's as if I'm listening to music through blown speakers. Buzzing and static completely ruins the experience.

I've tested the aux jack (center console) independently - playing pandora via my Android phone - it works and sounds great.

So here's my question: Could it be the USB jack thats causing this (I didn't think that it would have anything to do with the audio considering the use of the aux jack?) Or could it be that I've just hit the lottery and can't seem to get a proper working cable?

If anyone has experienced this - and fixed it, I'd love to hear it. I've got a 2100 mile road trip coming up in 2 weeks, and I'd really like to have my ipod.

Thanks!
I can't play iTunes off my Apple iPhone 4S via aux in either of our 535s. Causes a buzzing noise. I have tried myriad cables. A ground loop isolator kills the buzz, but it also distorts the signal, doesn't sound as crisp. Especially bass suffers.
No problem with an iPod or iPhone 4.

The mobridge is a bust so far. I can't get the car to connect as it came without CD changer. Have even spent 3.5 hrs at BMW and they can't fix it either. Autologic was also a bust. Now trying NCS Expert as last desperate stab at it, then looking elsewhere for solution.
__________________
Audio: Jehnert Flatline speakers, Mobridge M1000 DA2 prepro, Helix P-DSP, Zapco Z-150.6 amp, iDock on dash
Performance: Protuned Cobb, AR Downpipes, ER FMIC/CP, DCI, RB turbos, KW V2 coilovers, AEM 320E LPFP/ported fuel rail
Reply With Quote
  #961  
Old 05-14-2012, 10:07 AM
Larry Cable Larry Cable is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 160
Mein Auto: '10 535i xDrive Wagon
I think there was a problem with the internal cables connecting the iDrive to the iPod adapter in the ctr console on the E60/61's ... you may want to speak to your dealer about it.
Reply With Quote
  #962  
Old 05-22-2012, 12:41 PM
ShackleMeNot ShackleMeNot is offline
Learning as I go
Location: Indy
 
Join Date: May 2012
Posts: 30
Mein Auto: 2009 328ix
I purchased a BMW last week and I'm trying to figure out how the USB system works with an iPOD/iPhone.

I have a 2009 328i with the USB and AUX port in the arm rest. No iDrive system; just the base radio.

When I plug my iphone into the USB using an Apple USB to iphone cable, it doesn't let me control the iphone with the radio or steering wheel controls. I also tried to throw some mp3s on a thumb drive and plug it into the USB port, but it isn't being recognized. It just says "insert" on the radio face when I select USB as the input then after about 10 seconds it times out and goes back to whatever the last input source was (radio, aux).

So, how do I play mp3s through the USB?

How do I get my USB to be able to control my iphone/ipod?
Reply With Quote
  #963  
Old 05-22-2012, 01:13 PM
scriss scriss is offline
Officially Welcomed to the 'Fest
Location: Columbus
 
Join Date: May 2006
Posts: 137
Mein Auto: 2006 530xiT
You don't, as far as I know. Connect your iPod to the aux input.
__________________

Formerly in my garage: 1982 E21 (First car ) * 1995 E34 * 2007 E90 * 2002 E39 * A bunch of other American and Japanese cars I'd rather not mention .
Reply With Quote
  #964  
Old 07-07-2012, 08:58 PM
Lucky#7 Lucky#7 is offline
Registered User
Location: San Jose
 
Join Date: Aug 2010
Posts: 66
Mein Auto: 745 Li
for any of you interested bMW 5 series with the fiber optic platform for your audio I have access to a module made by MoBridge that will allow several different options for you to install yourself, Im sure you have heard of them. They allow you to integrate your Bluetooth/audio, IPOD direct connect through your factory radio, as well as an Auxiliary in if anyone is interested just PM me for the info.
__________________

Lucky#7

Platinum Autoworks
Custom A/V, Security & OEM Integration

authorized mObridge dealer
Reply With Quote
  #965  
Old 07-10-2012, 07:36 PM
umermariner umermariner is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Oct 2008
Posts: 108
Mein Auto: 2000 (E46 )328I
Guys,
I have been searching a lot, however, not been able to find the answer. Any of you have knowledge of Dension VS mObridge VS OEM iPod integration kit (functionality, DIY, and Cost). I was moving towards Dension, however; some people have really bad experience with aftermarket installations.
I have 2006, 530i, with mp3, cd changer, and bluetooth, and without Navi. Different dealers gave me different part numbers for the OEM kit .
Will really appreciate your help.
Thanks.
Reply With Quote
  #966  
Old 07-19-2012, 01:32 PM
HAWKG HAWKG is offline
Registered User
Location: NEW YORK
 
Join Date: Oct 2011
Posts: 21
Mein Auto: BMW 530XI
Go to modmynav.com. It will have exactly what you need for your vehicle.

Sent from my SPH-D710 using Bimmer App
Reply With Quote
  #967  
Old 07-24-2012, 05:02 AM
mfrasca mfrasca is offline
Registered User
Location: Boston
 
Join Date: Jan 2010
Posts: 45
Mein Auto: 550i
idrive knob kicks back?

I just had the ipod interface installed in my 05 545i and the idrive knob kicks back at me when i am trying to scroll through song lists. Is this something I am going to have to live with or is it a programiong issue? It also does the same thing on my contacts list when my iphone is connected to bluetooth. If you force the knob it will scroll but it feels like it is going to screw something up.
Reply With Quote
  #968  
Old 07-24-2012, 05:18 AM
mschuler mschuler is offline
Registered User
Location: Burlington, Ontario
 
Join Date: Jan 2010
Posts: 26
Mein Auto: 2012 BMW 335 is Cabriolet
Same thing on my 2007 550i. I had the OEM interface installed 2 years ago and have not had any problems with it other than it does not charge, in my case, the ipod.
Reply With Quote
  #969  
Old 08-20-2012, 06:39 PM
Wreckless Wreckless is offline
Registered User
Location: MD
 
Join Date: Jan 2008
Posts: 37
Mein Auto: 528ix
So is it absolutely necessary to use that stupid Y-cable to be able to use an ipod with the iDrive? Seems like such a waste of a port. I'd like to be able to have the iPod connected to the USB and have the Aux available for another audio source if i want. I tried the regular white ipod cable and my iDrive recognized my ipod but I couldn't get to any songs. The same cable was used with an iTouch and the iDrive didn't even recognize it. I think maybe my iDrive needs a software update. 2010 528ix btw....
__________________
Reply With Quote
  #970  
Old 09-18-2012, 08:02 PM
gonzo773 gonzo773 is offline
Registered User
Location: Arizona
 
Join Date: Sep 2011
Posts: 4
Mein Auto: 2005 545i
This is awesome. Thanks!
Reply With Quote
  #971  
Old 10-04-2012, 05:34 PM
843bobo 843bobo is offline
Registered User
Location: South Carolina
 
Join Date: Jun 2011
Posts: 1
Mein Auto: 525I
I know this is an older post but my 2007 5 series has an aux jack in the rear console and sounds amazing actually better then a cd quality. So if you have a o7 or later e 60 look on the rear console its right there with the power outlets i jut use my iphone and leve it lay on the set to skip past the songs im tired of listening to
Reply With Quote
  #972  
Old 10-11-2012, 09:29 PM
88irocvert 88irocvert is offline
Registered User
Location: San Juan
 
Join Date: May 2012
Posts: 18
Mein Auto: G35
So I read through the latter third of this thread because my car is a 2008 so anything before then seemed irrelevant but I came to some conclusions and still have an unanswered question. My car is a 2008 535i with iDrive, no NAV, no CD changer. I wanted to add the 6FL option to it but I found out the following:
1. The 6FL retrofit parts I need are now discontinued. Is this correct?
2. Even if I did find the correct parts, I need NAV in order for the iDrive to control the iPod through 6FL. Is this correct?
Thanks.
Reply With Quote
  #973  
Old 10-12-2012, 12:26 PM
88irocvert 88irocvert is offline
Registered User
Location: San Juan
 
Join Date: May 2012
Posts: 18
Mein Auto: G35
Quote:
Originally Posted by 88irocvert View Post
So I read through the latter third of this thread because my car is a 2008 so anything before then seemed irrelevant but I came to some conclusions and still have an unanswered question. My car is a 2008 535i with iDrive, no NAV, no CD changer. I wanted to add the 6FL option to it but I found out the following:
1. The 6FL retrofit parts I need are now discontinued. Is this correct?
2. Even if I did find the correct parts, I need NAV in order for the iDrive to control the iPod through 6FL. Is this correct?
Thanks.
So...I may have answered my own question or rather, Patryk did. I contacted him about getting the 6FL retrofit for my car. He assured me he has it available for $699 + 3.5% Paypal fee and a $300 reimbursable deposit for the programming cable. He mentioned it would work with my non-nav setup and be compatible with my iPhone 4S. I'll be ordering in the next few days and reporting back.
Reply With Quote
  #974  
Old 10-26-2012, 11:11 AM
eRandall38 eRandall38 is offline
Registered User
Location: Here
 
Join Date: Oct 2012
Posts: 2
Mein Auto: BMW
Sorry if this has been answered through one of the other 973 post.

I just picked up a CPO 2010 BMW 535. No Nav package in it.

I see in the console there are USB/AUX ports. Currently I use a AUX cable to connect my iPhone to play music. And connect a USB cable to charge. I've read about this Y cable. Basically the Y cable lets you do both charge and play at the same time with one cable correct?

Also, the Y cable will allow you to control the music controls on iPhone on your iDrive? (even without nav package?). Correct?

I have an iPhone 5, so the typical Y cable will not work right now due to the new 8 pin dock. I see there are adapters out there that connect a 30 pin cable (all other iPhones) to a 8 pin cable so you can plug in the iPhone 5. If I purchase the adapter, can I use the Y cable still on the iPhone 5? Will I be able to control music controls via my car controls?


Can you control pandora via car controls with Y cable?
Reply With Quote
  #975  
Old 11-13-2012, 12:30 PM
kiwi89 kiwi89 is offline
Registered User
Location: Massachusetts
 
Join Date: Aug 2012
Posts: 5
Mein Auto: BMW 525XI
Simple question!

Everthing seems to be clear but the issue that I am having is how you get to the place and how to put the cable for the AUX. I have the cable now but I dont know where I can find the other panel the I am going to plug the cable in?? Can anyone help me please? with simple steps...
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bentley E46 Repair Manual (Tips, tricks and general info) Thread LilEccentricJ General BMW 12 12-18-2010 03:28 PM
iPod in X3 (BMW Business CD) simoncpw Car Navigation, Audio & Electronics sponsored by BimmerTech 6 07-05-2005 03:06 PM
Apple to Introduce a Cheaper iPod Spiderm0n Off-Topic 19 01-06-2004 05:09 PM


All times are GMT -7. The time now is 04:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms