Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-31-2012, 05:46 PM
bmwFIG bmwFIG is offline
Registered User
Location: modesto ca
 
Join Date: May 2012
Posts: 2
Mein Auto: 745li
AC Not blowing cold air

I recently had the crossover pipe seal on my 2004 BMW 745li replaced. Took them about a month and a whole lot of giving me the "running around." I got over it. Here's the problem. When I picked it up the "water coolant light" was coming on and mechanic said that it would be on but not to worry because the reservoir was adequate coolant. I said, okay.....didn't think that was a big deal so I decided to fix that later.

As I was driving home I decided to turn on the AC and come to find out NO COLD AIR was blowing. When I called the shop they told me that they didn't mess with anything related to the AC system. Basically they're not being responsible for those items. Even though, when I dropped off my car, no coolant lights were on and my AC was working adequately.

Does anyone here know what could have happened? Is there a wire or sensor that they could have disconnected or bumped or maybe messed with the compressor and didn't connect it back. The compressor seems to be turning on but no cold air. The auxillary fan turns on but not when AC is on.

Any kind of help I would greatly appreciate

Thank you.
Reply With Quote
Advertisement
  #2  
Old 05-31-2012, 06:31 PM
Catanzaro Catanzaro is offline
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Feb 2012
Posts: 197
Mein Auto: 2004 BMW 745Li
Lawyer up. They definitely messed something up. Coolant pipe with no ac and lights. Call an attorney

Sent from my DROID BIONIC using Bimmer App
Reply With Quote
  #3  
Old 05-31-2012, 08:44 PM
bmwFIG bmwFIG is offline
Registered User
Location: modesto ca
 
Join Date: May 2012
Posts: 2
Mein Auto: 745li
Yes I definitely thought about that already.... How would I prove that they caused it........that's my dilemma. I'm hoping someone here with those crossover pipe seal replacement repairs can possibly tell me if it is related.
Reply With Quote
Reply

Bookmarks

Tags
745li, ac, ac sensors, crossover pipe, no cold air


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms