Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 12-13-2011, 07:43 PM
italy107 italy107 is offline
Registered User
Location: ny
 
Join Date: Oct 2008
Posts: 9
Mein Auto: x5 4.8is
steering wheel lights not illuminating

suddenly my steering wheel lights are not illuminating on the steering wheel. could it be a fuse of some sort? any ideas?

x5 2006 4.8is
Reply With Quote
Advertisement
  #2  
Old 12-14-2011, 11:23 AM
petriej's Avatar
petriej petriej is offline
Cruising 280 Top Down
Location: San Jose, CA
 
Join Date: Jul 2010
Posts: 6,088
Send a message via Skype™ to petriej
Mein Auto: '99 M3 Cab & '05 X5 4.8is
Most likely a fuse. If the buttons still work then you can rule out the wiring.
__________________

GGC BMW CCA #443004
Join the BMW CCA!

Quote:
Originally Posted by hornhospital View Post
Jared, why don't you just put "It's Giubo" in your sig? Save a lot of typing.
Quote:
Originally Posted by e36 miguel View Post
this jared guy sounds intimidating lol.
2005 X5 4.8is Le Mans/Black/6spd Steptragic
1999 M3 Cabrio TiAg Metallic/Dove Grey/Black 5 Speed Manual
-------------------------------------------------------------------
1997 328iC Schwarz II/K/K 5MT SOLD 5/2012
2004 645Ci Mineral Silver Metallic/Black 6MT RIP 04/2011
Reply With Quote
  #3  
Old 12-14-2011, 02:15 PM
Zulu95's Avatar
Zulu95 Zulu95 is offline
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 848
Mein Auto: 2001 X5 3.0L
Could be a break in the "clock-spring".
Reply With Quote
  #4  
Old 06-22-2012, 05:33 AM
LeMansBeast LeMansBeast is offline
Registered User
Location: MN
 
Join Date: Jan 2012
Posts: 14
Mein Auto: 4.8is
Same thing happened to me last night. Anyone have an update on a fix?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms