Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-15-2012, 11:32 AM
BMWconsumer BMWconsumer is offline
Registered User
Location: New Orleans
 
Join Date: Jun 2012
Posts: 10
Mein Auto: X5
2013 x5

I just bought the 2013 x5. An upgrade from 2008 Nissan Pathfinder.
I am very disappointed with the gas mileage. It seems like I am using the same amount of gas as I did in my Pathfinder.
Another thing which bothers me is the voice command. I think it does not work.
My wife drives 2012 5 series and it works fine but in X5 it never does what it is told.
Any thoughts?

Thanks,
Reply With Quote
Ads by Google
  #2  
Old 06-15-2012, 11:55 AM
georgejm georgejm is offline
Officially Welcomed to the 'Fest
Location: Louisiana
 
Join Date: Apr 2010
Posts: 616
Mein Auto: BMW X5 35d
"My wife drives 2012 5 series and it works fine but in X5 it never does what it is told".

Funny, I have the opposite problem, be careful what you wish for. What is your MPG so far? Whatever it is it may get better after a couple thousand miles or your foot might get lighter.
__________________
2012 X5 35d AW/Black Dark Burl
ZAP ZAV ZCW ZPP ZPS ZRC ZTP HUD AD BMW Apps
Spare Tire-Comfort Access-Running Boards-Roof Rails-335 Wheels-Auto High Beams-Smart Phone Int.
Mods : Clear Bra-Radar Hard-wired
So far so good-made on Wednesday
Reply With Quote
  #3  
Old 06-15-2012, 11:56 AM
georgejm georgejm is offline
Officially Welcomed to the 'Fest
Location: Louisiana
 
Join Date: Apr 2010
Posts: 616
Mein Auto: BMW X5 35d
Howdy from NOLA.
__________________
2012 X5 35d AW/Black Dark Burl
ZAP ZAV ZCW ZPP ZPS ZRC ZTP HUD AD BMW Apps
Spare Tire-Comfort Access-Running Boards-Roof Rails-335 Wheels-Auto High Beams-Smart Phone Int.
Mods : Clear Bra-Radar Hard-wired
So far so good-made on Wednesday
Reply With Quote
  #4  
Old 06-16-2012, 04:26 AM
boostedX5SAV boostedX5SAV is offline
Officially Welcomed to the 'Fest
Location: New York City
 
Join Date: Jan 2012
Posts: 263
Mein Auto: 2012 X5
I was driving a 50 mile stretch on NJ Turnpike at 65 and got 30mpg. In the streets of NYC, I'd be happy to get 10mpg.
Reply With Quote
  #5  
Old 06-16-2012, 04:45 AM
SteVTEC's Avatar
SteVTEC SteVTEC is offline
Officially Welcomed to the 'Fest
Location: DC Burbs
 
Join Date: Feb 2005
Posts: 979
Mein Auto: '11 E93/335i
Brand spanking new cars are never going to get good mileage. Need to let them break in first. At least 5000 miles.
__________________
Steve
2012 E70 X5d (IT'S HERE!) Deep Sea Blue / Sand Beige, Premium, 3rd Row, Multi-Contour
2011 E93 335i Deep Sea Blue / Oyster, Step, Premium, Convenience (PDC & CA), and that's it


more pics here
Reply With Quote
  #6  
Old 06-16-2012, 06:14 AM
Lance Alot Lance Alot is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Sep 2007
Posts: 375
Mein Auto: 2012 BMW X5 35D
Quote:
Originally Posted by stevtec View Post
brand spanking new cars are never going to get good mileage. Need to let them break in first. At least 5000 miles.
+1
Reply With Quote
  #7  
Old 06-16-2012, 07:10 AM
chrisc151 chrisc151 is offline
Registered User
Location: Indiana
 
Join Date: Aug 2005
Posts: 52
Mein Auto: '06 530i
I have a 2013 X5 3.5 and have the same gas mileage issue. Came from a 2010 535 which has the same engine. However, I just hit 1400 miles and the gas mileage appears to be getting MUCH better... Give yours a little more time.
Reply With Quote
  #8  
Old 06-16-2012, 10:38 AM
Talstar Talstar is offline
Registered User
Location: Florida
 
Join Date: Jun 2011
Posts: 67
Mein Auto: '12 X5 35D White
First tank in my d was around 17mpg, went up to 21 on the second. At 1,000 miles I got 27 mpg at 65mph. I'm at 2,200 now and on a trip to Disney World. I tried to stay around 80mph on interstate 75 it is impossible, more like 90. Will post my mpg when I get back.
__________________
2012 white X5 D
Retired: Space grey 2011 335D
Reply With Quote
  #9  
Old 06-16-2012, 06:00 PM
11leven 11leven is offline
Registered User
Location: BAY AREA,CA
 
Join Date: Dec 2011
Posts: 73
Mein Auto: 2012 X5d
I'm at 5500 miles on 12x5d getting close to 27mil doing 70 in bay area. Wait till it breaks in and again be easy on right leg to get better mileage or just forget that mileage and enjoy the drive!
__________________

2012 X5d...with all possible pks & flowers...
Reply With Quote
  #10  
Old 06-17-2012, 08:43 AM
BenF12400 BenF12400 is offline
Officially Welcomed to the 'Fest
Location: Maryland
 
Join Date: Sep 2009
Posts: 284
Mein Auto: 2006 X3; 2010 528;2013 X5
2013 premium,gas - 24.7 mpg on DC beltway
Reply With Quote
  #11  
Old 06-17-2012, 02:31 PM
TN_3's Avatar
TN_3 TN_3 is offline
Officially Welcomed to the 'Fest
Location: Franklin, TN
 
Join Date: Oct 2007
Posts: 290
Mein Auto: 2013 AH3
Am I missing something? I don't believe he stated which engine is in his X5...35i, 35d, 50i...this could help determine if he is seeing unusual MPG for his particular model.
__________________
2013 AH3 F30 l EB2 l BLACK l ALUM l M-SPORT l PREM l TECH l COLD l DHP l DAP l AHB l S-AT l HK l 19" (ED 6/6/13)

2014 X3 xDrive35i F25 l AW l BLACK l ALUM l M-SPORT l PREM l TECH l CW l DAP l DHP l AHB l PREM AUDIO

2011 X3 xDrive35i F25 l SG l OYSTER l ALUM l M-SPORT l PREM l NAV l PREM AUDIO (Retired)

2011 135i E82 l SG l CORAL l GLACIER l DCT l PREM l M-SPORT l NAV l HK (Retired)

2007 335i E90 l AW l BLK L-ETTE l ALUM TRIM l SPORT l 6MT (Retired)
Reply With Quote
  #12  
Old 06-17-2012, 08:02 PM
ard ard is online now
Resident Curmudgeon
Location: CA
 
Join Date: Jul 2009
Posts: 9,163
Mein Auto: '12 X5 35d/E39M5/996TTX50
Quote:
Originally Posted by TN_3 View Post
Am I missing something? I don't believe he stated which engine is in his X5...35i, 35d, 50i...this could help determine if he is seeing unusual MPG for his particular model.
Ding, ding, ding....


was reading with incredulity that everyone was willing to blather about mileage, and assuring the OP, yet nobody bothered to ask what he was driving!

__________________
Keep it as simple as possible...but no simpler.
Reply With Quote
  #13  
Old 06-18-2012, 11:28 AM
BMWconsumer BMWconsumer is offline
Registered User
Location: New Orleans
 
Join Date: Jun 2012
Posts: 10
Mein Auto: X5
X5 xDrive35i Premium

Thanks for the advice guys.
I am driving X5 xDrive35i Premium
Thanks,
Reply With Quote
  #14  
Old 06-27-2012, 12:26 PM
BMWconsumer BMWconsumer is offline
Registered User
Location: New Orleans
 
Join Date: Jun 2012
Posts: 10
Mein Auto: X5
Idrive Screen went out on 2013 x5.

Guys,

I have a frustrating concern.

Yesterday when I started the X5 the idrive screen went red and then blank after 30 sec .
I switched off the car and restarted it and still the screen was out.
I drove the car home anyway. When i got to my destination i switched off the car and then restarted it. the screen came back on!

Any thoughts?

Few other factors which might help.
It was 99 degrees here in New Orleans yesterday and the car was parked out in the sun.
When I opened the door to get in, it was super hot. For a while I thought it might have burned something.....

Thanks!!
Reply With Quote
  #15  
Old 06-28-2012, 08:20 AM
strongarm73 strongarm73 is offline
Registered User
Location: TX
 
Join Date: Jan 2007
Posts: 86
Mein Auto: '12 X5d; '10 335; '09 128
As some have said, first few tanks will not be representative of mpg.
Reply With Quote
  #16  
Old 06-28-2012, 08:32 AM
Kzang's Avatar
Kzang Kzang is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Apr 2006
Posts: 4,702
Mein Auto: 2013 X5 35i Premium
Quote:
Originally Posted by BMWconsumer View Post
Guys,

I have a frustrating concern.

Yesterday when I started the X5 the idrive screen went red and then blank after 30 sec .
I switched off the car and restarted it and still the screen was out.
I drove the car home anyway. When i got to my destination i switched off the car and then restarted it. the screen came back on!

Any thoughts?

Few other factors which might help.
It was 99 degrees here in New Orleans yesterday and the car was parked out in the sun.
When I opened the door to get in, it was super hot. For a while I thought it might have burned something.....

Thanks!!
Its possible that the extreme heat might have done something to the electronics..
I would tint the driver and passenger windows if you haven't already to help with the heat and perhaps tilt the sunroof to vent out some of the heat.
__________________
2013 X5 35i Premium, Space Gray, Cinnamon Brown Leather, Dark Bamboo wood trim, Conv. Pkg, CWP, Multi-contour seats, Running board, BMW App. Space saver tire.
Previous Cars
2010 535i - Deep Sea Blue w/ NBD Leather, Bamboo Anthracite WT, Sport Auto Trans w/ Paddle shifter, Sports Pkg, PP, CWP, Nav, HD Radio, Ipod.
2007 525i - Black Sapphire Metallic, Black Nevada Leather, Premium package, CWP, 6MT.
Reply With Quote
Reply

Bookmarks

Tags
x5


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms