Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)

E28 (1982 - 1988)

Reply
 
Thread Tools Display Modes
  #1  
Old 07-03-2012, 08:26 AM
duke1946 duke1946 is offline
Registered User
Location: New Bern NC
 
Join Date: Jul 2008
Posts: 27
Mein Auto: 84 528
Replacement Alternator Pulley

Do any of you know where I can find a replacement alternator pulley for our 84 528e?

I can find all the alternators I want with and without the pulley but no luck yet on just the pulley.

Maybe someone has bought an aftermarket one that worked?

The belt is going to deep in ours and it will slip and squeal in a heartbeat. The new belt fits correct in the main drive pulley along with the other two belts for the AC and power steering.

Thanks
Reply With Quote
Advertisement
  #2  
Old 07-03-2012, 04:57 PM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 825
Mein Auto: 535i 1989
Could it be the belt? or maybe you not tightening enough. I have an extra alt, but I would only sell it with the pulley. or the bushings might need replaced.


Andy

Last edited by south26; 07-03-2012 at 04:58 PM.
Reply With Quote
  #3  
Old 07-03-2012, 06:41 PM
duke1946 duke1946 is offline
Registered User
Location: New Bern NC
 
Join Date: Jul 2008
Posts: 27
Mein Auto: 84 528
Thumbs up

Quote:
Originally Posted by south26 View Post
Could it be the belt? or maybe you not tightening enough. I have an extra alt, but I would only sell it with the pulley. or the bushings might need replaced.


Andy
Belt is a new Gates. i even tried a size smaller and every time it want go on even with the adjustment all the way down. just wish that belt was the 1st one and not the DAG last one in line.

New bushing might be the ticket. The alt as for as I know is the org and you can see they are not what they used to be. Now to pick the correct ones??? I did go on one site and they listed the OEM ones and then the newer type but heck they showed like 5 or more of the newer ones???

The problem is I have run out of adjustment. And you can look and see that the alt is being pulled out of line so bushing would be the cause. A few years back I did do a red neck fix on the adjustment by adding a bolt and a nut that connected to the pump below. heck it works I decided to tighten the nut up today and got the belt like it should be and then fired it up and no high pitch squeal. But I think I am hearing bearing noise

Might need your alt after all if the price is right??????? I did install a new regulator in this one the first of the year.

PM or contact me through my site on a price and info on your spare alt. I just might need it. The wife Love's this car so much that spare parts is something I try to keep handy and thank goodness I have a shop and tools because I have paid one time to have something fixed at a dealer and NEVER AGAIN $100 for a distributor cap!!!!

Thanks
Reply With Quote
  #4  
Old 07-04-2012, 05:46 AM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 825
Mein Auto: 535i 1989
Hi in the 48 in can do 40 shipped. It is out of a 84 528. Looks good and worked well.

Andy
Reply With Quote
  #5  
Old 07-04-2012, 06:38 AM
duke1946 duke1946 is offline
Registered User
Location: New Bern NC
 
Join Date: Jul 2008
Posts: 27
Mein Auto: 84 528
Smile

Quote:
Originally Posted by south26 View Post
Hi in the 48 in can do 40 shipped. It is out of a 84 528. Looks good and worked well.

Andy

Sounds like a deal to me. I know that one of these days this will fail and might be real soon. Even after I replaced the regulator in it you still might have to hit the gas a few times to get it to charge and sometimes it comes alive like it should.

So consider it SOLD.

Thanks

I have another problem I need to chase down also. So I am going to check all the stuff out the guy told me to check. I had done this before a long time ago. But sure is hard to fix something when it works fine until you get every thing hot for a while and then you have to work on a hot motor
take a look and see if you might have a suggestion.

http://www.bimmerfest.com/forums/sho....php?p=6931741
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 11:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms