Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 07-02-2012, 11:05 PM
Jo Mozone Jo Mozone is offline
Registered User
Location: dubai
 
Join Date: Jun 2012
Posts: 3
Mein Auto: X5 - 2001
air bag light is on

Hi,

i have the airbag light on, after opening one of the doors and replacing the window actuator.

are there any fuses for the airbags ??

mine is a 2001 ,

Thanks,
Reply With Quote
Advertisement
  #2  
Old 07-03-2012, 06:22 AM
Zulu95's Avatar
Zulu95 Zulu95 is offline
Officially Welcomed to the 'Fest
Location: Show Me
 
Join Date: May 2004
Posts: 848
Mein Auto: 2001 X5 3.0L
Sounds like you disconnected a wire in the door airbag. You'll need to have the airbag code read and possible go back in and have a look. I would try and pick up a Peake SRS code reader/reset unit.
Reply With Quote
  #3  
Old 07-05-2012, 03:16 PM
infamous212 infamous212 is offline
Registered User
Location: Austin
 
Join Date: May 2012
Posts: 16
Mein Auto: '04 BMW X5 4.4i, '05 G35
Quote:
Originally Posted by Zulu95 View Post
I would try and pick up a Peake SRS code reader/reset unit.
I've done this several times, only way to clear that light is to buy the srs code reader and clear it...
__________________
'04 4.4i BSM/TB w/ spt & premium pkg, pan roof, navi.
'05 Infiniti G35
'00 e39 M5 (sold)
Reply With Quote
  #4  
Old 07-05-2012, 04:17 PM
scottjoh scottjoh is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: May 2006
Posts: 375
Mein Auto: 1999 323i
If you had the airbag disconnected while the battery was connected you will get the light. It needs to be cleared by a code reader. GT1, INPA, CarSoft, PA Soft, Auto Logic, Bavarian Technic. I don't recommend the Peake tool because it's a one trick pony. $100 and you'll likely only use it once.
Reply With Quote
  #5  
Old 07-06-2012, 05:48 AM
teps9968 teps9968 is offline
Registered User
Location: US Virgin Islands
 
Join Date: May 2012
Posts: 5
Mein Auto: 2006 BMW X5
Smile Coolant Adding Often

I reasonly change my expansion coolant resevior and for some strange reason I have to add coolant every few days. I pressure checked it and I don't see any leaks anywhere. Can someone give me an idea what to do.?
Reply With Quote
  #6  
Old 07-06-2012, 09:42 AM
ECSTuning's Avatar
ECSTuning ECSTuning is online now
Instructor of the Stig™
Location: Wadsworth, Ohio
 
Join Date: Feb 2009
Posts: 4,034
Mein Auto: Hover Car on Wheels
Quote:
Originally Posted by Zulu95 View Post
Sounds like you disconnected a wire in the door airbag. You'll need to have the airbag code read and possible go back in and have a look. I would try and pick up a Peake SRS code reader/reset unit.
Agreed.

The Peake SRS Reader is a simple tool which is a must when dealing with air bag lights. Sine your X is an 01 you can use the Peake SRS Reader found HERE, but just to insure it's the one you need check for 20-pin round port in engine bay.
__________________

Have questions? Need answers? Live Chat us! 8:30am to 12:00am Midnight EST
sales@ecstuning.com | customerservice@ecstuning.com
Customer Service Hours: M - F 8:00am - 8:00pm EST | Saturday: 10:00am - 7:00pm EST
Sales Team Hours: M - F 8:00am - 11:00pm EST | Saturday: 10:00am - 7:00pm EST
800.924.5172 | OEM BMW Part Number Search
Do you love surveys? Click HERE to take our Customer Satisfaction Survey!
Reply With Quote
  #7  
Old 07-06-2012, 11:23 AM
tmvE39/E53/Z32's Avatar
tmvE39/E53/Z32 tmvE39/E53/Z32 is offline
Officially Welcomed to the 'Fest
Location: Seattle --> Atlanta
 
Join Date: Dec 2010
Posts: 1,884
Mein Auto: 03 540, 06 E53 4.8, Z32TT
Quote:
Originally Posted by teps9968 View Post
I reasonly change my expansion coolant resevior and for some strange reason I have to add coolant every few days. I pressure checked it and I don't see any leaks anywhere. Can someone give me an idea what to do.?
Stop hijacking and start your own thread.
Did you bleed the cooling system properly?
__________________

FS 2001 ///M5
http://www.bimmerfest.com/forums/sho...d.php?t=791509
2000 Dinan S1 //M5 (my DD) 06 DINAN E53 4.8iS (wife's DD), 90 Straman Z32TT (my pride & joy ride)

Gone, but not forgotten: 01 E53 3.0i, 01 525i Sport, 03 DINAN 540i MSport and 91 Z32TwinTurbo
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms