Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 07-07-2012, 07:36 PM
Cotwell Cotwell is offline
Registered User
Location: Niagara falls NY
 
Join Date: Mar 2012
Posts: 35
Mein Auto: 2002 330ci
Sudden yellow brake and dsc light

About 10 minutes ago i was just driving minding my own business and suddenly the dsc and yellow brake light along with a beep came on. I havent searched for any clues of the cause since im pretty busy right now. I recently put in new control arms with bushings which made my alignment off a bit. Could the alignment be the cause or maybe wheel speed sensors/dsc failure/abs? Any help would be much appreciated. Thanks in advanced!
Reply With Quote
Ads by Google
  #2  
Old 07-07-2012, 07:50 PM
Fast Bob's Avatar
Fast Bob Fast Bob is offline
Keeping it surreal
Location: Here, there, everywhere....
 
Join Date: Jun 2004
Posts: 34,061
Mein Auto: 2004 330Ci ZHP 3 pedals
You sure you didn`t inadvertently push the DSC button ?
__________________
The road goes ever onward....
(R.I.P. Jever)

*Please support the Wounded Warrior Project*

When faced with choosing between two evils, always go with the one you`ve never tried before....
Reply With Quote
  #3  
Old 07-07-2012, 08:00 PM
smolck's Avatar
smolck smolck is online now
ROLL TIDE!
Location: Birmingham, AL
 
Join Date: Jul 2007
Posts: 22,336
Mein Auto: 2004 ZHP Sedan
Quote:
Originally Posted by Cotwell View Post
About 10 minutes ago i was just driving minding my own business and suddenly the dsc and yellow brake light along with a beep came on. I havent searched for any clues of the cause since im pretty busy right now. I recently put in new control arms with bushings which made my alignment off a bit. Could the alignment be the cause or maybe wheel speed sensors/dsc failure/abs? Any help would be much appreciated. Thanks in advanced!
Your car COULD be out of alignment enough to cause the DSC to activate, it isn't unheard of after a change like yours. It could also be the wheel speed sensor. You really need someone with the proper scanner that can tell you which one is bad, IF they are bad.
__________________

Check out my YouTube Channel for DIY's and other fun stuff HERE
Check out my BMWBLOG!
Quote:
Originally Posted by Fast Bob View Post
now, go burn your Man Card, and buy yourself a Camry....
Reply With Quote
  #4  
Old 07-07-2012, 08:01 PM
Cotwell Cotwell is offline
Registered User
Location: Niagara falls NY
 
Join Date: Mar 2012
Posts: 35
Mein Auto: 2002 330ci
Positive. I pushed the dsc button after the lights came on and nothing happend.
Reply With Quote
  #5  
Old 07-07-2012, 08:18 PM
Cotwell Cotwell is offline
Registered User
Location: Niagara falls NY
 
Join Date: Mar 2012
Posts: 35
Mein Auto: 2002 330ci
Well im doing my alignment at work monday morning so we will see what happens from then on. Thanks for the help!
Reply With Quote
  #6  
Old 07-07-2012, 08:51 PM
sea6speed's Avatar
sea6speed sea6speed is offline
Officially Welcomed to the 'Fest
Location: Seattle WA
 
Join Date: Jun 2010
Posts: 363
Mein Auto: 2011 135i 6MT
In your situation it is probably alignment, but at the age of these cars, wheel speed and steering angle sensor are also possible.
__________________
Reply With Quote
  #7  
Old 07-07-2012, 10:11 PM
dkotanto dkotanto is offline
Officially Welcomed to the 'Fest
Location: Denver, CO
 
Join Date: Jan 2003
Posts: 543
Mein Auto: 2006 BMW 530i sport
I had the same issue. Culprit is the DSC pressure sensor, part#2 in the picture below. There are two of them, read the codes and it will tell you which one:

http://www.realoem.com/bmw/showparts...92&hg=34&fg=25
__________________
2007 530 xi
2004 X3 3.0i
2006 530i
Reply With Quote
  #8  
Old 07-08-2012, 06:50 AM
tdd tdd is offline
Officially Welcomed to the 'Fest
Location: Boca Raton, Florida
 
Join Date: Sep 2002
Posts: 230
Mein Auto: Electric Red '02 330CiC
With me, the culprit was the abs control module.
__________________
'02 330CiC, electric red, sand leather, sp, pp, steptronic, bi-xenon

"Send lawyers, guns and money/The sh*t has hit the fan"
Reply With Quote
  #9  
Old 07-10-2012, 10:55 AM
Cotwell Cotwell is offline
Registered User
Location: Niagara falls NY
 
Join Date: Mar 2012
Posts: 35
Mein Auto: 2002 330ci
Ive just got back from doing my alignment with a buddy at work so now my steering is dead-on straight. Now the dsc and yellow brake light are still on. I've only drove about 1 mile with the lights still on. I'm not sure if I have to keep driving so the computer can learn that the alignment is correct or do I have to get the lights reset at the dealer. (if the alignment was the reason the lights came on) anyone know?
Reply With Quote
  #10  
Old 07-10-2012, 12:00 PM
Fast Bob's Avatar
Fast Bob Fast Bob is offline
Keeping it surreal
Location: Here, there, everywhere....
 
Join Date: Jun 2004
Posts: 34,061
Mein Auto: 2004 330Ci ZHP 3 pedals
Quote:
Originally Posted by Cotwell View Post
Ive just got back from doing my alignment with a buddy at work so now my steering is dead-on straight. Now the dsc and yellow brake light are still on. I've only drove about 1 mile with the lights still on. I'm not sure if I have to keep driving so the computer can learn that the alignment is correct or do I have to get the lights reset at the dealer. (if the alignment was the reason the lights came on) anyone know?
*As was already mentioned*, there`s a good chance it could be a wheel-speed sensor....especially considering your location, where they sand & salt the roads several months out of the year. Sometimes they just get dirty/corroded, and a good cleaning will get them back in proper working order (if you`re lucky).
__________________
The road goes ever onward....
(R.I.P. Jever)

*Please support the Wounded Warrior Project*

When faced with choosing between two evils, always go with the one you`ve never tried before....
Reply With Quote
  #11  
Old 07-16-2012, 08:23 AM
rbaisa rbaisa is offline
Registered User
Location: Indiana
 
Join Date: Apr 2011
Posts: 45
Mein Auto: 330i ZHP
I have a dumb question about these lights. Are these lights that need to be reset or do they just go off when everything is correct? I have seen posting that say both things. Will a computer tell you if a wheel sensor is bad? I used the peak and it didn't give me any codes at all?
Reply With Quote
  #12  
Old 07-16-2012, 08:50 AM
E46_Ci E46_Ci is offline
Officially Welcomed to the 'Fest
Location: Portland, OR
 
Join Date: May 2010
Posts: 741
Mein Auto: 2005 325Ci + ZPP/ZSP/ZCW
My car did this after it sat for 6 days without being driven... and was on a 6 year old battery... had battery replaced and never happened again... car has sat for 10 days without driving and no errors given.
__________________

Alpinweiß 2005 325Ci
Spacegrau 2007 X5 3.0Si

Reply With Quote
  #13  
Old 07-16-2012, 09:48 AM
crowz's Avatar
crowz crowz is online now
Officially Welcomed to the 'Fest
Location: Alabama
 
Join Date: Oct 2006
Posts: 4,253
Mein Auto: 2000 323i, 97 528i
Mine did that after sitting for 4 years and a bad battery. To make the lights go out I just drove the car 1 mile after putting a new battery in.
Reply With Quote
  #14  
Old 07-16-2012, 09:53 AM
Brobby87's Avatar
Brobby87 Brobby87 is offline
The Arch Bishop
Location: Cedar Rapids, IA
 
Join Date: Nov 2011
Posts: 168
Mein Auto: 2003 325i, 1986 535i
Did any of your guy's batteries still show 'Green' on the indicator yet it was still bad? Or was the indicator 'Yellow' and thats how you knew it was bad? Reason im asking is im pretty sure my battery is old yet it still shows the 'Green' indicator and I'm have this same problem.
Reply With Quote
  #15  
Old 07-16-2012, 10:02 AM
crowz's Avatar
crowz crowz is online now
Officially Welcomed to the 'Fest
Location: Alabama
 
Join Date: Oct 2006
Posts: 4,253
Mein Auto: 2000 323i, 97 528i
My battery light had looong since stopped glowing any color at all

4 years dead does that it seems.....
Reply With Quote
  #16  
Old 07-16-2012, 10:56 AM
Cotwell Cotwell is offline
Registered User
Location: Niagara falls NY
 
Join Date: Mar 2012
Posts: 35
Mein Auto: 2002 330ci
With my situation (if anyone cares) both lights turned off the next day. So my alignment was the problem.
Reply With Quote
  #17  
Old 07-16-2012, 11:37 AM
smolck's Avatar
smolck smolck is online now
ROLL TIDE!
Location: Birmingham, AL
 
Join Date: Jul 2007
Posts: 22,336
Mein Auto: 2004 ZHP Sedan
Quote:
Originally Posted by Cotwell View Post
With my situation (if anyone cares) both lights turned off the next day. So my alignment was the problem.
I'd hold off on that judgement. When I had some bad wheel sensors and when I had a bad ABS pump, my car would sometimes show the lights, sometimes it worked fine.
__________________

Check out my YouTube Channel for DIY's and other fun stuff HERE
Check out my BMWBLOG!
Quote:
Originally Posted by Fast Bob View Post
now, go burn your Man Card, and buy yourself a Camry....
Reply With Quote
  #18  
Old 07-16-2012, 06:00 PM
Brobby87's Avatar
Brobby87 Brobby87 is offline
The Arch Bishop
Location: Cedar Rapids, IA
 
Join Date: Nov 2011
Posts: 168
Mein Auto: 2003 325i, 1986 535i
My BRAKE and DSC lights have come on and been on since about December last year. I really need to refresh my control arms and bushings. I plan on doing that and having an alignment done. If that doesn't help things then i know for sure ill have to start testing the module for bad sensors or look into my battery (even though it still has the green indicator).
Reply With Quote
  #19  
Old 11-30-2012, 07:47 AM
JBW2BF JBW2BF is offline
Registered User
Location: U.S.A.
 
Join Date: Aug 2012
Posts: 8
Mein Auto: 330i
Hopefully, it will be helpful to someone. Like Cotwell, it was alignment for me too. After I replaced the Control Arms and Bushings, both the DSC and Brake yellow lights came on. Did the four wheels alignment and drove for 15 to 20 miles. The next time I started the car, both DSC and Brake yellow lights were off.
Reply With Quote
  #20  
Old 11-30-2012, 10:03 AM
scarede46er scarede46er is offline
Officially Welcomed to the 'Fest
Location: Clemson, SC
 
Join Date: Aug 2012
Posts: 161
Mein Auto: 2001 BMW 325i ZSP
I think you should def have your codes read, Brobby. A 30 buck BMW scanner of Ebay will pinpoint exactly where the fault lies.
Reply With Quote
  #21  
Old 11-30-2012, 10:10 AM
Fast Bob's Avatar
Fast Bob Fast Bob is offline
Keeping it surreal
Location: Here, there, everywhere....
 
Join Date: Jun 2004
Posts: 34,061
Mein Auto: 2004 330Ci ZHP 3 pedals
Quote:
Originally Posted by scarede46er View Post
I think you should def have your codes read, Brobby. A 30 buck BMW scanner of Ebay will pinpoint exactly where the fault lies.
You`re 5 months late to the party....
__________________
The road goes ever onward....
(R.I.P. Jever)

*Please support the Wounded Warrior Project*

When faced with choosing between two evils, always go with the one you`ve never tried before....
Reply With Quote
  #22  
Old 11-30-2012, 10:11 AM
scarede46er scarede46er is offline
Officially Welcomed to the 'Fest
Location: Clemson, SC
 
Join Date: Aug 2012
Posts: 161
Mein Auto: 2001 BMW 325i ZSP
damn nigga.. should check the dates ha ha.. it popped up as a new post.
Reply With Quote
Reply

Bookmarks

Tags
dsc abs


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms