Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 07-15-2012, 07:14 PM
aturkinside aturkinside is offline
Registered User
Location: New Jersey
 
Join Date: Mar 2008
Posts: 20
Mein Auto: 2004 BMW 330I ZHP
clunk between 1st and second

I have an '04 X3 3.0 automatic and at 1/5 throttle at around 10mph (1800 rpms) i get this clunking/shudder from underneath the car. I can't pinpoint exactly where but have to say it's more towards the front. I had the flex disc replaced with a genuine BMW one and it hasn't changed anything. The center bearing also looked fine. It's more noticeable in traffic because it only happens between first and second. If I go a little faster it's not as noticeable but happens quicker. It also doesn't happen when the car is cold.

I've been having a ton of acceleration issues with regards to pinging and hesitation so I have changed the plugs and the coilpacks, replaced my valve cover, reprogrammed at the dealer, cleaned the throttle body, cleaned the maf, checked intake boot for cracks, changed all four o2 sensors, and just put in some Lucas fuel conditioner but haven't completely solved the hesitation. These are the things I have done but my main issue is the clunk between first and second. Could this be related to the pinging hesitation? The pinging happens between 2500-4000 rpms. I'm suspecting the fuel injectors.
Reply With Quote
Advertisement
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:19 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms