Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 07-18-2012, 10:15 AM
TexasBMW's Avatar
TexasBMW TexasBMW is offline
Officially Welcomed to the 'Fest
Location: Austin and Midland, Texas
 
Join Date: Mar 2007
Posts: 380
Mein Auto: 08 X54.8 04X54.4 00E46CiC
Anyone Replaced a Coil Pack?

Hi, I'm having a rough idle and Service Engine Light illuminating after a few minutes each time I start the 2004 X5 4.4i. I think it's probably the coil pack. I haven't done an OBDII on it, yet.

Anyone had theirs replaced, and what was the cost?
Thanks!
__________________
2008 X5 4.8 Space Gray/Tan/Dark Burl - Delivered 01.30.08
2004 X5 4.4 Silver. Acquired 02.12
2000 E46 Vert
2001 X5 4.4, Ret.
Reply With Quote
Ads by Google
  #2  
Old 07-18-2012, 10:50 AM
Mudnyrey Mudnyrey is offline
Registered User
Location: Beaverton, OR
 
Join Date: Jul 2012
Posts: 93
Mein Auto: X5 3.0i
I would suggest getting your codes read first.

Replacing the coil packs and plugs isn't a difficult job and is really easy to get to with a few tools.
By removing the top cover and two screws you can get to your coil packs and spark plugs. I've replaced the spark plugs in which you have to remove the coil packs, the coil packs aren't too costly at what I found of $35ea.


There are many possibilities that can cause rough idles such as; MAF, CPS, Adjuster Unit, O2 sensor to name a few and possibly a coil pack to, but distinguishing which one is key and could save you $$ guessing.
I am currently going through the same thing. I bought some MAF cleaner and removed my Mass Air Flow Sensor and cleaned it, however the result hasn't changed. Still could be my MAF but there are two, throttle body and secondary. Front and Rear O2's, CPS = Intake and Exhaust and so on.
I pulled these codes yesterday on my vehicle (04 X5 3.0L) PO171 & PO174 which indicate the following;

PO171 = Fuel trim bank one condition; 1) Oxygen sensor defective 2) Ignition misfire-repair 3) Fuel injector problem
PO174 = Fuel trim bank two condition; 1) Ignition misfire condition 2) Fuel injector problem 3) Engine mechanical condition

After some research and removing and cleaning the Throttle body MAF, I found that the DISA unit on the intake or better known as the "Adjuster Unit" is a known problem of going bad. However, I am uncertain to find that this could cause rough idle conditions? I am still looking into the similar issue of "Rough Idle". It could be an Idle control valve issue, which is located under the intake manifold. However, I've decided to change the DISA unit anyway and will have my vehicle placed on a computer to help diagnose my issue futher just in case.
I removed the DISA unit yesterday and found it in bad condition, and from what I read about some of it's stories of the pin in this until, i'd feel safer just changing it anyway

I will repost my findings later this evening as my APPT isn't until 3pm. (PST) to better diagnose any further issues.

Mud~

Last edited by Mudnyrey; 07-18-2012 at 11:03 AM.
Reply With Quote
  #3  
Old 07-19-2012, 10:29 AM
tmvE39/E53/Z32's Avatar
tmvE39/E53/Z32 tmvE39/E53/Z32 is offline
Officially Welcomed to the 'Fest
Location: Seattle --> Atlanta
 
Join Date: Dec 2010
Posts: 1,880
Mein Auto: 03 540, 06 E53 4.8, Z32TT
^2nd on reading the code(s) Dont just replace random part(s) and hope that the problem will be fixed.
__________________

FS 2001 ///M5
http://www.bimmerfest.com/forums/sho...d.php?t=791509
2000 Dinan S1 //M5 (my DD) 06 DINAN E53 4.8iS (wife's DD), 90 Straman Z32TT (my pride & joy ride)

Gone, but not forgotten: 01 E53 3.0i, 01 525i Sport, 03 DINAN 540i MSport and 91 Z32TwinTurbo
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms