Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E46 M3 (2001-2006)

E46 M3 (2001-2006)

Reply
 
Thread Tools Display Modes
  #1  
Old 12-29-2010, 06:17 AM
pcgem1 pcgem1 is offline
Registered User
Location: Cary, NC
 
Join Date: Oct 2010
Posts: 5
Mein Auto: 2004 M3 Convertible
SMG won't shift (solved)

I ran into the problem where my SMG transmission would not shift. I know there are many threads on this topic but what I found was that it took me a few hours of sifting through them to find enough info to do something about my issue other than becoming a 'favorite payer' to the dealer. The many threads I read always left out part of what I needed.

Having said all that, I'm posting everything I learned here in one post....which by the way saved me thousands of dollars so I hope this post will help you too. I'm also including pics of what I'm talking about so you can confidently find the items I discuss on your car.

-----------------------------------------------

As the weather got cold, I noticed my SMG transmission wasn't shifting into neutral as easily which prevented the car from starting until after several attempts. Then one day after coming out of work, I couldn't get it to shift at all and had to leave the car in the parking lot overnight. The posts I read where people took their car to the dealer to get this problem fixed said in all cases, the dealer replaced the SMG relay and the hydraulic pump/pressure accumulator (yeah, check out the really scary price here: item #1 http://realoem.com/bmw/showparts.do?...=21&fg=10&hl=1). Seriously, my family would have gone without Christmas this year if I had to pay for this.

My 2004 M3 only has 40K miles on it so I seriously doubted the hydraulics would be having issues. The faint noise you're supposed to hear (sounds like a small electric motor running from under the car) when you unlock the car or open the door is the pressure accumulator building pressure in the hydraulic system so it can operate the SMG transmission, put it into neutral so you can start the car. Sometimes I heard this, sometimes I didn't hear it at all....which is definitely a problem. I found that when relay switches start going bad, they can really be affected by cold temperatures so I decided to start by replacing the relay and to great relief found that was the problem. I picked up the relay at Carquest for $8.20 including tax and it is virtually the same part. Typically I go to great lengths to get authentic parts but in this case, it really was the same. It took me all of 4 minutes to change it in the parking lot too. If you are having SMG issues, I highly recommend changing this out just to see if it's the problem because it's only an $8 risk but could save tons of money....even if you are not good at working on cars, this is really easy and here is what you need to know.

SMG relay, part number: 12631742690
Typically between $7-$9
You can get it at most autoparts stores, online, dealer, etc.
The first attached picture to this post is a pic of the one I installed


Here is a link for closeup pic and purchase info:
http://www.bmwpartsweb.com/BMW-Parts...D-31C9277.aspx

Where this is located in the car: In the engine compartment right in front of the driver in the fuse box/wiring hub. The second attached picture is the location with the cover on.

Using a 1/4" star head screw driver (also known as Hexalobular), remove the 4 screws holding the cover, pull the cover off and you'll see what is shown in the third attached picture. (be careful not to drop the screws...this is easy to do)

The "Salmon" color Red relay is the device of interest. To remove it, you can try wiggling it from side to side while pulling up. Be sure to take note of the small tabs on the side, you may need to gently pry back the plastic pieces holding them to free the relay. I used a small flathead screwdriver to pry up on the relay because my hands were too cold to really get a grip on it. It popped right off, there are no screws holding the relay in place.
Since this was the first time I had seen this relay, I was careful to note the pin layout so I was sure to put the new one in the same way. Usually though, these only fit one way so there is no way to make a mistake when putting the new one in.

Once you've pushed the new one in place and screwed the cover back on, see if the shifting issue went away. I had two alarm lights on my dash still on. The lamp that looks like a gear was yellow and my check engine light was on (or was it service engine??....can't remember). I didn't have time to look up the procedure for resetting these lamps so I figured I would get to it the next day or two. The next day, the gear shaped lamp went out by itself and about 3 days later the check engine lamp went out. I have not had any dash alarms light up since and the car has performed/shifted with no issues what-so-ever.
Attached Thumbnails
Click image for larger version

Name:	PC090104.jpg
Views:	1191
Size:	237.0 KB
ID:	260116   Click image for larger version

Name:	PC090101.jpg
Views:	1442
Size:	157.8 KB
ID:	260117   Click image for larger version

Name:	PC090102.jpg
Views:	2168
Size:	138.1 KB
ID:	260118  

Last edited by pcgem1; 12-29-2010 at 06:37 AM.
Reply With Quote
Ads by Google
  #2  
Old 01-07-2011, 01:09 AM
DarkSide DarkSide is offline
Future BMW *****
Location: Marina Del Rey, CaLi
 
Join Date: Jun 2005
Posts: 74
Send a message via AIM to DarkSide Send a message via MSN to DarkSide Send a message via Skype™ to DarkSide
Mein Auto: 04 TSX
awesome post, thanks for the info
__________________
If it bleeds, we can kill it!
Reply With Quote
  #3  
Old 02-19-2012, 01:59 PM
wnrobinson wnrobinson is offline
Registered User
Location: Cypress, California
 
Join Date: Feb 2012
Posts: 1
Mein Auto: 2004 M3
PCgem1 It works!!!! Thank you.
Reply With Quote
  #4  
Old 03-30-2012, 10:26 AM
Knightmare007 Knightmare007 is offline
Registered User
Location: Syracuse, NY
 
Join Date: Jul 2011
Posts: 1
Mein Auto: 2005 BMW M3 Convert
Worked for me today, 2005 M3...life saver! TY SIR!
Reply With Quote
  #5  
Old 08-11-2012, 09:41 AM
manuelfdo manuelfdo is offline
Registered User
Location: WAXHAW
 
Join Date: Feb 2010
Posts: 2
Mein Auto: M3 AND X5
Worked for me today, after three days waiting on the dealer to give me a better deal on a new SMG pump. I went there open the hood, pop the new relay bought at Pepboys p/n R6284 and its running like champ again! Thank you for the post . 2004 M3 Conv 80K miles on.
Reply With Quote
  #6  
Old 08-22-2012, 08:49 AM
silverbimmer3's Avatar
silverbimmer3 silverbimmer3 is offline
Officially Welcomed to the 'Fest
Location: New York
 
Join Date: May 2006
Posts: 680
Mein Auto: '05 M3 ZCP; '06 530 XIT
Really great info. I will keep an eye this coming winter.

Appreciated.
Reply With Quote
  #7  
Old 03-19-2014, 11:49 PM
Buloy07 Buloy07 is offline
Registered User
Location: Hawaii
 
Join Date: Mar 2014
Posts: 2
Mein Auto: Z4
I got 2004 Z4 SMG and I had the same problem....I changed my RELAY SWITCH with the same part # and I replaced the old one then start the car....won't shift any gear and in neutral gear. I installed the old RELAY and the car is still in neutral and won't shift to any gear.....I need help! Please somebody help me on how to solve this issue...
Reply With Quote
  #8  
Old 03-20-2014, 02:23 PM
BMC-M3 BMC-M3 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: Oct 2013
Posts: 101
Mein Auto: E46 M3
I found this thread from a sister site it has a multiple issues regarding SMG. The thread stated back in Oct. of 2008.

Good luck

http://www.m3forum.net/m3forum/showthread.php?t=231113
__________________
Reply With Quote
  #9  
Old 03-27-2014, 04:56 PM
lweekley lweekley is offline
Registered User
Location: Seattle
 
Join Date: Mar 2014
Posts: 1
Mein Auto: M3
Thank you thank you thank you

Thanks so much for this post. Had the same problem that came up at a bad time financially. Issue is going. Thanks again!!
Reply With Quote
  #10  
Old 04-16-2014, 09:13 AM
baabish baabish is offline
Registered User
Location: hayward, ca
 
Join Date: Apr 2014
Posts: 2
Mein Auto: 2006 bmw m3 smg cov
Hi, i have a 2006 m3 smg cov will the above part numbers for the replay gonna be same or different. if it is different where can i get the part number so i can go down to any part shop and buy one of these.
Reply With Quote
  #11  
Old 04-16-2014, 10:18 AM
BMC-M3 BMC-M3 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: Oct 2013
Posts: 101
Mein Auto: E46 M3
I am not sure but all should be the same. Look at the relay in your car it should have the number on it. I have not check mine yet. My car is 2005 vert.
__________________
Reply With Quote
  #12  
Old 04-16-2014, 11:45 AM
baabish baabish is offline
Registered User
Location: hayward, ca
 
Join Date: Apr 2014
Posts: 2
Mein Auto: 2006 bmw m3 smg cov
thank you!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E46 M3 (2001-2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms