Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 06-04-2012, 03:33 AM
SFLe34 SFLe34 is offline
Registered User
Location: Florida
 
Join Date: Jul 2011
Posts: 1
Mein Auto: 94 530i/5
E34 electrical problems

Hey everyone!

I have a 1994 530i and as of the last few weeks I have had strange electrical problems occurring...

First problem that started happening is the door locks lock and unlock randomly. It happens while driving and even while the car is parked and turned off. It is rather troublesome since when I lock my car, I have to go back a little while later to make sure that it hasn't opened back up.

The second problem I have going on now started yesterday and is quite the pain in the butt. While at work I saw my cars high beams and the amber signal lights flashing erratically like some kind of alarm was set off. My aftermarket alarm was not triggered. I found out that I could stop the flashing by opening the trunk but as soon as I close the trunklid the flashing resumed. I have already tried pulling the battery to stop this problem but it did not work.

One thing to be noted is that i do have a weather seal problem. Whenever it rains I get some rain water in the driver side footwell. I do air out the car and vacuum out as much of the water as i can but I don't always get to it immediately. Is it possible that there may be some kind of short that happened under the carpet from the water there?



Sent from my PG86100 using Bimmer App
Reply With Quote
Advertisement
  #2  
Old 06-05-2012, 05:52 PM
BuckNaked BuckNaked is offline
Registered amUser
Location: North Tonawanda, NY
 
Join Date: Feb 2007
Posts: 13
Mein Auto: '95 540i 6-speed
Water in the driver side footwell may have to do with a clogged drain. I am not sure if it is from the sunroof, but there is a drain that when it gets clogged with debris it leaks into the drivers footwell. I have read about this issue in several forums.
The door locking and lights flashing may be associated. Check the battery. Mine was doing some wonky things as you descibed. I replaced the batteries in my remotes and the battery in the car. I haven't had any issue since. I did notice that my passenger front door lock would stay up when the other locks engaged. Immediately the rest of the locks would reset. When I was replacing my door handle gaskets (thanks Shogun) I shot a dose of teflon spray liberally around the lock mechanism. I couldn't guess to say which repair did the trick.
Reply With Quote
  #3  
Old 08-12-2012, 12:25 PM
captainryan captainryan is offline
Registered User
Location: Minnesota
 
Join Date: Aug 2012
Posts: 2
Mein Auto: 89 535i
where is the foot well exactly can you get at the drain?
Reply With Quote
  #4  
Old 08-21-2012, 10:37 PM
paperplane94 paperplane94 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: Jan 2012
Posts: 933
Mein Auto: 1989 525i M20B25
SEarch for "e34 sunroof drain clog"

The lights and hazards flashing erratically is the crash control module malfunctioning. It may also explain the door locks.

Open the fusebox in the engine compartment and look for this:
N17- Crash Control Module


It looks like a tall brown relay. You need to replace it.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms