New Fuel Pump - Bimmerfest - BMW Forums



Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 08-25-2012, 08:22 AM
CarDriver's Avatar
CarDriver CarDriver is offline
Officially Welcomed to the 'Fest
Location: Saint Albans, New York
 
Join Date: Apr 2008
Posts: 2,422
Mein Auto: 1992 525it /2004 ML350
New Fuel Pump

My baby needs a fuel pump. not too bad for 100 beans.

I will through it in Sunday morning...
Attached Thumbnails
Click image for larger version

Name:	IMG_20120824_163601_174.jpg
Views:	93
Size:	167.3 KB
ID:	338678  
__________________
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 08-26-2012, 07:25 PM
goosefoot33's Avatar
goosefoot33 goosefoot33 is offline
Manualaholic
Location: Hudson, MA
 
Join Date: Mar 2008
Posts: 1,855
Mein Auto: 01 330Ci/02 525iT
Not bad indeed! Where did you pick that up for $100? How did you know it was the fuel pump? Did you put in a new fuel filter as well?
__________________
BMWCCA Member# 451235
(Summer) 2001 330Ci - ZSP
(Winter) 1994 530i "Greenie" - PARTING OUT! (PM for details)

(Grocery Getter) 2002 525iT
Reply With Quote
  #3  
Old 08-27-2012, 04:37 AM
CarDriver's Avatar
CarDriver CarDriver is offline
Officially Welcomed to the 'Fest
Location: Saint Albans, New York
 
Join Date: Apr 2008
Posts: 2,422
Mein Auto: 1992 525it /2004 ML350
I got it from amazon. the car was having hard starts and was becoming sluggish on the highway at higher rpm. I put in the new pump Sunday morning. She starts and runs well now.
__________________
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 08-27-2012, 04:58 AM
Costa's Avatar
Costa Costa is offline
Officially Welcomed to the 'Fest
Location: Vancouver, Canada
 
Join Date: May 2011
Posts: 887
Mein Auto: Supercharged E34 540i6
Before you swapped them, did you have a hesitant throttle response - mainly when cold? That's what I have now, along with a sorta hard start.
__________________
Reply With Quote
  #5  
Old 08-27-2012, 01:43 PM
CarDriver's Avatar
CarDriver CarDriver is offline
Officially Welcomed to the 'Fest
Location: Saint Albans, New York
 
Join Date: Apr 2008
Posts: 2,422
Mein Auto: 1992 525it /2004 ML350
Not sure if I noticed a slow response when cold. I usually went easy on her till she was up to full temp.
__________________
Reply With Quote
  #6  
Old 08-27-2012, 03:36 PM
Bugsie Bugsie is offline
Officially Welcomed to the 'Fest
Location: Portugal
 
Join Date: Nov 2011
Posts: 275
Mein Auto: BMW E34 M50 2.5
Hi all.

The same problem Costa. And with anew fuel pump. Maybe something else.

If any news on this I'll report back.

Best regards
Reply With Quote
Reply

See More Related BMW Stories


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:54 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
© 2001- VerticalScope Inc. All rights reserved.