Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-05-2012, 03:59 PM
dbaze540's Avatar
dbaze540 dbaze540 is offline
Officially Welcomed to the 'Fest
Location: Charlotte, NC
 
Join Date: Sep 2011
Posts: 165
Mein Auto: 1997 540iA
Interior Lighting Headache

Just purchased LED lights for the interior of my car. I did alot of research and was really excited about them coming. Should have known better. First of all I was under the impression that all the festoon bulbs were the same size. That is not the case. The puddle lights on each door, the 2 trunk lights and the glove box are all 36mm. The 4 mirror lights (two for each side), the front dome light, and the 2 rear (non-map) lights are 42mm.
So that's 7x36mm and 7x42mm festoons. Now for the map lights.
I posted a thread earlier asking about the map lights and didn't get any helpful responses. I was able to figure out that they are BA9S sockets, so I bought 4 4x3528 bulbs. Well when I went to install these lights I started up front. Replaced one map light, it didn't work. Tried it on the other side. Nothing. Tried all 4 bulbs in each socket up front. Nothing. Put the halogen lights back in and voila, light. So I moved on to the map lights in the back seat which work perfectly (same bulbs). Since I didn't have the right size festoon bulbs, I put the halogens back in the back seat as well.

So I went back today and installed all the bulbs that I could, the 4 doors and the trunk (we'll get to that too). I decided to try the front map lights again. Still nothing there, except for the fact that when I replaced them with the halogen lights, they stopped working too. So now I have to figure out why that happened. In addition, something similar happened in the trunk. For some reason, the light that goes in the actual trunk lid has no wires. I took the carpeted molding off and found the connection in the harness, but no wires from the harness to the light. After noticing that one of the door lights wasn't working, I popped it out and took it to the trunk to test (easiest to access). I realized I had the bulb in the wrong way, so I turned it around, plugged it back in and it worked. I took that one back to the door and when I reconnected the trunk light it wouldn't work. I tried opening and closing the trunk, locking and unlocking the doors, but nothing worked. I tried a new bulb, nothing. So now I have no front map lights and no trunk light.

Wow. That's alot. Let's summarize.

-If you're replacing your interior lights, you need 7x36mm festoons, 7x42mm festoons, 4xBA9S bulbs.

-Why do the BA9S bulbs work in the back seat but not in the front? Do i need resistors or something? And if I need resistors for the map lights will I need them for the dome lights?

-What are some possible causes for a light socket to stop working in between changing bulbs? This happened to me with the front map lights and the trunk light. I've read that most of the lights are one the same wire to the GM, so I'm not really sure why one would stop working but the others wouldn't if the bulbs are all brand new.


Any help is appreciated.


EDIT:
Went back outside on a hunch and checked the lights again. The trunk light and the map lights work now. I have no idea why, but if it's one less thing to deal with I'm not complaining. So now my only question is why don't the BA9S bulbs work in the front?
__________________

Last edited by dbaze540; 09-05-2012 at 04:25 PM.
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms