Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 08-30-2012, 04:16 PM
alfwill alfwill is offline
Registered User
Location: INDIANAPOLIS,INDIANA
 
Join Date: Aug 2012
Posts: 8
Mein Auto: BMW 750LI
Logic 7 Amp

Does anyone know where I can get a Logic 7 Amplifier, or have mine repaired?
Reply With Quote
Ads by Google
  #2  
Old 08-30-2012, 05:22 PM
***CCCP***'s Avatar
***CCCP*** ***CCCP*** is offline
Major
Location: Canada Calgary
 
Join Date: Aug 2010
Posts: 2,323
Mein Auto: 745 li
If u use search ull find all the info with all the details. Im sure there is instructions on how to repair. U can get used on ebay or new from dealer
__________________
Reply With Quote
  #3  
Old 08-30-2012, 09:08 PM
PAPER's Avatar
PAPER PAPER is offline
CRISP & CLEAN
Location: CALIFORNIA L.A.
 
Join Date: Jul 2009
Posts: 2,888
Mein Auto: 745LI
There is a member here that repairs the l7 amp
( you will have to search some topics for his
email , sorry i don't know it off the top of my head )
or you can try & repair it yourself . There is a topic
in the diy section .
__________________

If you need a Custom 2014 DVD Navigation Map
East or West for your E65 E66 PM me for price .
Or if you Need an AUX Plug for your car hit me up
Reply With Quote
  #4  
Old 08-31-2012, 07:19 AM
bayerisheteknik bayerisheteknik is offline
Officially Welcomed to the 'Fest
Location: naples,fl
 
Join Date: Aug 2012
Posts: 535
Mein Auto: ...
my ask is going out so will have to send it to him....rookie2008 gave me his info/email

Last edited by PAPER; 07-02-2013 at 08:59 PM.
Reply With Quote
  #5  
Old 08-31-2012, 08:18 AM
pepe65's Avatar
pepe65 pepe65 is offline
750li 745i
Location: Greencastle Pennsylvania.
 
Join Date: Jul 2010
Posts: 519
Mein Auto: 745.750.x5.350z.ram1500v8
i sent i week ago and no response
__________________

Last edited by PAPER; 07-02-2013 at 08:59 PM.
Reply With Quote
  #6  
Old 08-31-2012, 08:38 AM
bayerisheteknik bayerisheteknik is offline
Officially Welcomed to the 'Fest
Location: naples,fl
 
Join Date: Aug 2012
Posts: 535
Mein Auto: ...
Maybe he is too busy...
He replied to my email right away
Reply With Quote
  #7  
Old 09-02-2012, 08:30 AM
peefunk12 peefunk12 is offline
Registered User
Location: Falls Church VA
 
Join Date: Jul 2012
Posts: 34
Mein Auto: 2006 760Li
I'm in DC area, I shipped my L7 amp (06 750Li)to him(Cali) and he fixed it, bass and all sounds great! Just got it back yesterday.

Sent from my SGH-T959 using Bimmer App
__________________
Reply With Quote
  #8  
Old 09-02-2012, 10:48 AM
7Figurez's Avatar
7Figurez 7Figurez is offline
Officially Welcomed to the 'Fest
Location: Virginia
 
Join Date: Mar 2008
Posts: 258
Mein Auto: 2005 745I
Quote:
Originally Posted by peefunk12 View Post
I'm in DC area, I shipped my L7 amp (06 750Li)to him(Cali) and he fixed it, bass and all sounds great! Just got it back yesterday.

Sent from my SGH-T959 using Bimmer App
What was the cost for repair?
Reply With Quote
  #9  
Old 09-02-2012, 01:29 PM
DriftGirl DriftGirl is offline
SideShow activist
Location: SEATTLE
 
Join Date: Apr 2012
Posts: 365
Mein Auto: 745Li
Quote:
Originally Posted by peefunk12 View Post
I'm in DC area, I shipped my L7 amp (06 750Li)to him(Cali) and he fixed it, bass and all sounds great! Just got it back yesterday.

Sent from my SGH-T959 using Bimmer App

How long did it take? Pics of the repaired board?
__________________


Current Lineup:
BMW E31: Air suspension,19x10 / 19x11 Trafficstar
BMWE38:Air suspension,20x10 / 20x12 Forgiato
BMWE65: 22x10 / 22x11 Asanti ELT
Lexus SC400: Single turbo, 19" SRR wheels
Lexus GS300: VIP , Air Suspension,19" WORK wheels
S13 Silvia: WideBody, JDM conversion,SR20det,15" WORK wheels
Lexus LS430 UL:Air Suspension, 20"MAYA DLS

Reply With Quote
  #10  
Old 09-02-2012, 02:42 PM
Rookie2008's Avatar
Rookie2008 Rookie2008 is offline
Officially Welcomed to the 'Fest
Location: NYC 4 Eva! Current California
 
Join Date: Feb 2011
Posts: 2,215
Mein Auto: BMW 745LI/ F02
It only takes him a few hours to do the actually repair from what I understand. As for price it all depends on what wrong I do believe, but I can assure you your amp will work again an be more powerful than stock.
__________________
Sittin on 24's now with floating center caps
Reply With Quote
  #11  
Old 09-02-2012, 06:51 PM
peefunk12 peefunk12 is offline
Registered User
Location: Falls Church VA
 
Join Date: Jul 2012
Posts: 34
Mein Auto: 2006 760Li
He fixed it the day he received it and sent it back the next day. He said it takes him one to two days. Just let him know what's wrong with it. As for pics. I'm no electric wiz so I will probably mess something up of I take it apart. He gave me a warranty as well. As rookie2008 said, it works way better than before.

Sent from my SGH-T959 using Bimmer App
__________________
Reply With Quote
  #12  
Old 09-02-2012, 08:38 PM
Mr.750 Mr.750 is offline
A BMW, 7 Series of course
Location: Mt. Auburn, IA
 
Join Date: Jul 2012
Posts: 501
Mein Auto: LS460
What is it causing a weird popping noise coming out of my right drivers side speaker? It makes popping noises quite often except when very silent or extremely loud. Would this be what I need to do to fix that? Or are my speakers blown?
Reply With Quote
  #13  
Old 09-07-2012, 10:17 AM
PRBMW7ser05's Avatar
PRBMW7ser05 PRBMW7ser05 is offline
745i Blk-Blk
Location: Weschester, CA
 
Join Date: Mar 2012
Posts: 414
Mein Auto: 2005 745i s
I just started hearing that popping sound too. It started about 2 months ago. Today I just lost my Sub/base sound. I'm going to check my speakers, but I think it's my L7 amp...
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms