Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-18-2011, 06:34 PM
kpugh kpugh is offline
Registered User
Location: georgia
 
Join Date: Feb 2011
Posts: 7
Mein Auto: bmw 745li
Exclamation iDRIVE

ok so i got an aftermarket radio put into my 745Li and now my idrive does not work at all i could still go through all the menus on the screen but when i try to select something nothing happens. Like i cant even set the time. My steering wheel buttons dont work either I really have no clue what could have happened? Is there any way to get iDrive back??
Reply With Quote
Ads by Google
  #2  
Old 02-19-2011, 09:02 PM
DFEL750I's Avatar
DFEL750I DFEL750I is online now
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Apr 2010
Posts: 1,845
Mein Auto: 750I
Quote:
Originally Posted by kpugh View Post
ok so i got an aftermarket radio put into my 745Li and now my idrive does not work at all i could still go through all the menus on the screen but when i try to select something nothing happens. Like i cant even set the time. My steering wheel buttons dont work either I really have no clue what could have happened? Is there any way to get iDrive back??
Who installed an aftermarket stereo for you? Whoever did that has never worked on 7s before.....I hope you didn't do this yourself. Your cd player that you just replaced also know as the ASK unit is part of you MOST fiber ring.....you have just broken the ring quick means nothing else that is part of that ring will work....so that means no nav, voice control etc.

You will have to put the factory CD player back in or try looping the fiber connection with a fiber loop... You can't by it at the dealership..its typically used when you want to bypass a bad module on the fiber network
__________________
Reply With Quote
  #3  
Old 02-19-2011, 11:11 PM
Seven11's Avatar
Seven11 Seven11 is offline
President
Location: San Francisco
 
Join Date: Mar 2008
Posts: 7,930
Mein Auto: BMW
Quote:
Originally Posted by kpugh View Post
ok so i got an aftermarket radio put into my 745Li and now my idrive does not work at all i could still go through all the menus on the screen but when i try to select something nothing happens. Like i cant even set the time. My steering wheel buttons dont work either I really have no clue what could have happened? Is there any way to get iDrive back??
post pictures of the aftermarket radio
__________________

'03 745i - modded - GONE -
Reply With Quote
  #4  
Old 02-20-2011, 01:43 AM
trip7 trip7 is offline
im the boss
Location: riverside, ca
 
Join Date: Jan 2011
Posts: 262
Send a message via AIM to trip7 Send a message via Skype™ to trip7
Mein Auto: geo metro
kinda like this?? lol jk

__________________

WORLD SERIES OF POKER 2011
e66 project in progress:
Reply With Quote
  #5  
Old 02-20-2011, 02:01 AM
Seven11's Avatar
Seven11 Seven11 is offline
President
Location: San Francisco
 
Join Date: Mar 2008
Posts: 7,930
Mein Auto: BMW
Quote:
Originally Posted by trip7 View Post
kinda like this?? lol jk

i have a feeling its gonna look close to that
__________________

'03 745i - modded - GONE -
Reply With Quote
  #6  
Old 02-20-2011, 03:27 AM
***CCCP***'s Avatar
***CCCP*** ***CCCP*** is offline
Major
Location: Canada Calgary
 
Join Date: Aug 2010
Posts: 2,323
Mein Auto: 745 li
Quote:
Originally Posted by trip7 View Post
kinda like this?? lol jk

Hahahaha sorry can't stop laughing
__________________
Reply With Quote
  #7  
Old 02-20-2011, 12:01 PM
kpugh kpugh is offline
Registered User
Location: georgia
 
Join Date: Feb 2011
Posts: 7
Mein Auto: bmw 745li
lol thats funny but this is the aftermarket radio
http://www.bimmerfest.com/forums/att...1&d=1298231973


http://www.bimmerfest.com/forums/att...1&d=1298231973
Attached Thumbnails
Click image for larger version

Name:	IMG_0821.jpg
Views:	595
Size:	116.0 KB
ID:	267129   Click image for larger version

Name:	IMG_0823.jpg
Views:	476
Size:	122.2 KB
ID:	267130  
Reply With Quote
  #8  
Old 02-20-2011, 12:14 PM
SEVEN _4_NICKLE SEVEN _4_NICKLE is offline
Registered User
Location: DALLAS,TEXAS_214
 
Join Date: Sep 2010
Posts: 89
Mein Auto: 745I
WHY THE AFTERMARKET RADIO ???? DONT LOOK SO GOOD. WELL MY OPINON
Reply With Quote
  #9  
Old 02-20-2011, 12:28 PM
trip7 trip7 is offline
im the boss
Location: riverside, ca
 
Join Date: Jan 2011
Posts: 262
Send a message via AIM to trip7 Send a message via Skype™ to trip7
Mein Auto: geo metro
definitely a first from what i've seen in a 7. personally i feel like it took away from a natural elegance. i don't feel like it really flows with a luxury interior. but if you like it thats all that matters. that aux input must be a lot easier to work with. hopefully you figure out your idrive situation.
__________________

WORLD SERIES OF POKER 2011
e66 project in progress:
Reply With Quote
  #10  
Old 02-20-2011, 12:32 PM
SEVEN _4_NICKLE SEVEN _4_NICKLE is offline
Registered User
Location: DALLAS,TEXAS_214
 
Join Date: Sep 2010
Posts: 89
Mein Auto: 745I
Quote:
Originally Posted by trip7 View Post
definitely a first from what i've seen in a 7. Personally i feel like it took away from a natural elegance. I don't feel like it really flows with a luxury interior. But if you like it thats all that matters. That aux input must be a lot easier to work with. Hopefully you figure out your idrive situation.
i agree big time took the elegance away, i mean its not a chevy or a ford to put a jvc,pioneer, ect ect... On it, but thats your ride and your loot go for it mann and enjoy it and i hope you do figure out the idrive issuie.
Reply With Quote
  #11  
Old 02-20-2011, 01:07 PM
RTGrove RTGrove is offline
Officially Welcomed to the 'Fest
Location: Lake County, IL
 
Join Date: Sep 2010
Posts: 316
Mein Auto: 2006 750 Li
Well, that there is your problem. Aside from looking like a heaping pile of rhino dung (just my opinion) it looks like they replaced the ASK, which is an integral part of the MOST ring. MOST is the fiber optic network that all of the various stereo & I drive modules use to communicate (as I understand it anyways).
My guess is that your installer didnt put a lollipop in the place of the ask and as such broke the ring. Lollipop is about $20 from dealer, BUT im not sure if you can just bypass the ASK and still ahve everything else work...im sure others will chime in.
Reply With Quote
  #12  
Old 02-20-2011, 01:15 PM
kpugh kpugh is offline
Registered User
Location: georgia
 
Join Date: Feb 2011
Posts: 7
Mein Auto: bmw 745li
i put the aftermarket radio in because when i bought from dealer the regular radio didnt work it would play for like 10-15 secs skip then cut right back off they said they would fix the problem but they never did so i just decided to put this radio in and now one of my bros just bought a 750 and seeing how that idrive is i am jealous and am trying to get mines fixed the way it should be..i no big mistake buying with it not working correctly.. i am just wondering now if it is still possible for idrivve to work?
Reply With Quote
  #13  
Old 02-20-2011, 03:46 PM
RTGrove RTGrove is offline
Officially Welcomed to the 'Fest
Location: Lake County, IL
 
Join Date: Sep 2010
Posts: 316
Mein Auto: 2006 750 Li
Probably can get it to work with the lollipop. hopefully someone else can chime in to confirm. On a side note, how did they wire it to even get sound out? Did they bypass the stock amp? Does the new stereo work?
FYI - the original problem MAY have been a faulty ASK (can get used for a few hundred $$) or Logic 7 Amp (frequent item, search here for diagnosis and cost). If they havent hacked up the dash too much, you may consider finding the real problem, and get parts on ebay or similar and put it back to stock. just a thought.
Reply With Quote
  #14  
Old 02-20-2011, 03:49 PM
RTGrove RTGrove is offline
Officially Welcomed to the 'Fest
Location: Lake County, IL
 
Join Date: Sep 2010
Posts: 316
Mein Auto: 2006 750 Li
Start by looking through here for info on the lollipop and how MOST works:

http://www.bimmerfest.com/forums/arc.../t-451068.html
Reply With Quote
  #15  
Old 02-20-2011, 03:53 PM
klob25 klob25 is offline
Officially Welcomed to the 'Fest
Location: Melbourne
 
Join Date: Sep 2010
Posts: 150
Mein Auto: 735i
Quote:
Originally Posted by kpugh View Post
i put the aftermarket radio in because when i bought from dealer the regular radio didnt work it would play for like 10-15 secs skip then cut right back off they said they would fix the problem but they never did so i just decided to put this radio in and now one of my bros just bought a 750 and seeing how that idrive is i am jealous and am trying to get mines fixed the way it should be..i no big mistake buying with it not working correctly.. i am just wondering now if it is still possible for idrivve to work?

hmmm getting it to work with the i dirve, you have to play around with the elec and the module that controls the Idrive. It not a back yard job in my option.

with your new radio do you have the two wires that are meant for the steering wheel volume ?

Here are some module a friend of a friend used.

http://www.incarelectrics.co.uk/Vehi...108-1335-1336/

hope this helps.

Last edited by klob25; 02-20-2011 at 03:55 PM.
Reply With Quote
  #16  
Old 02-20-2011, 04:56 PM
745Japan 745Japan is offline
Officially Welcomed to the 'Fest
Location: Japan
 
Join Date: Sep 2010
Posts: 710
Mein Auto: 2005 745i
RTGrove hit the nail on the head. I would revert back to the stock head unit and Logic 7 amp. The stock HU is actually pretty good, and competes with most HU's on the market. If the installer didn't hack up the wires I would buy an ASK unit, you can even find new on ebay and fix it. Other than that you need to close the MOST fiber ring, which should give you the idrive back. Picture a circle around that circle, is the NAVI, Idrive, Phone, Radio, etc. If you remove one of those items from the circle you now have an open or blank space. You need to fill that space to complete the circle again, this is in short why your Idrive system isn't working. Ebay finds:

http://shop.ebay.com/?_from=R40&_trk...All-Categories
Reply With Quote
  #17  
Old 02-20-2011, 06:40 PM
kpugh kpugh is offline
Registered User
Location: georgia
 
Join Date: Feb 2011
Posts: 7
Mein Auto: bmw 745li
appreciate all the input
Reply With Quote
  #18  
Old 02-20-2011, 07:01 PM
Seven11's Avatar
Seven11 Seven11 is offline
President
Location: San Francisco
 
Join Date: Mar 2008
Posts: 7,930
Mein Auto: BMW
remove that terrible headunit and put the stock cd player back in
__________________

'03 745i - modded - GONE -
Reply With Quote
  #19  
Old 02-21-2011, 03:47 AM
RTGrove RTGrove is offline
Officially Welcomed to the 'Fest
Location: Lake County, IL
 
Join Date: Sep 2010
Posts: 316
Mein Auto: 2006 750 Li
Please keep us posted on what you decide to do and the outcome...
__________________
2006 750 Li - His
2006 Volvo V70R - Hers
2002 Porsche 911 Cab - Her idea
1956 Ford Sunliner Convt - His idea
Reply With Quote
  #20  
Old 02-21-2011, 05:09 AM
csmeance's Avatar
csmeance csmeance is offline
Officially Welcomed to the 'Fest
Location: Daytona Beach
 
Join Date: Dec 2007
Posts: 4,185
Mein Auto: 760Li
Quote:
Originally Posted by kpugh View Post
appreciate all the input
with the radio install, the Fiber Optic light ring has been broken. You can buy the lollipop and reconnect it if the fiber-optics were not damaged.

Using the lollipop along with the aftermarket unit will give you a bit of the i-drive system back. Many of the audio features such as Park Distance Control, Voice Activation, Bluetooth, etc won't work.

If you want everything to work, get rid of that unit and buy a new ASK unit and just add an amplifier to that. The L7 is isn't bad at all. I just hope your installer didn't mess up the wood trim or the mounting locations to badly. That wood ain't cheap!
Reply With Quote
  #21  
Old 02-21-2011, 04:57 PM
Seven11's Avatar
Seven11 Seven11 is offline
President
Location: San Francisco
 
Join Date: Mar 2008
Posts: 7,930
Mein Auto: BMW
still cant belive you did that!

and the shop actually went along with it, but then again not a lot of people know how to work on these cars.

you know, the whole time i owed my 7 i have NEVER seen anybody do anything like that to a 7...

and i have seen people go ALL out with the 7s... SUBS, AMPS, ALL NEW SPEAKERS, TVs EVERYWHERE... 26s

but they still kept the stock headunit and just added stuff on to that

you literally lose the main part of this car without the ASK unit (CD player)

i say you find a totaled 7 and take out the ASK unit and go from there
__________________

'03 745i - modded - GONE -
Reply With Quote
  #22  
Old 02-21-2011, 05:34 PM
BobSC's Avatar
BobSC BobSC is offline
It's all about me!
Location: South Carolina
 
Join Date: May 2008
Posts: 1,442
Mein Auto: 07-750LI, 12-X3, 01-330Ci
Oh my........

Definitely get that thing out of the car.

If it isn't too damaged and by re-introducing all of the stock components you get it to work as designed....you will be thrilled with the outcome.
__________________

2007 750LI Barbera Red
2001 330Cic Orient Blue
2000 328i Jet Black(Sold)
2004 X3 Mystic Blue
2012 X3 Alpine White
Reply With Quote
  #23  
Old 09-07-2012, 03:51 PM
Vonda3 Vonda3 is offline
Registered User
Location: SC
 
Join Date: Aug 2012
Posts: 2
Mein Auto: "06" 750li
Hi guys can you tell me anything about the speaker my rear speakers have a lot of static I think it is the amp but I'm not sure... Any ideas
Reply With Quote
  #24  
Old 09-07-2012, 07:17 PM
rkruz rkruz is offline
Banned
Location: U.S.
 
Join Date: Jun 2012
Posts: 250
Mein Auto: 750i 2008
Quote:
Originally Posted by kpugh View Post
appreciate all the input
Sounds like installer didnt know what they were getting into. I think, as others have already stated, your best bet is to take the loss, remove the new radio and have old radio repaired/reinstalled.
Reply With Quote
Reply

Bookmarks

Tags
745li, idrive, radio, stereo


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms