Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 08-16-2012, 09:31 AM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
I guess I should of posted this here??

I posted in the DIY section but I was getting no response. Another member told me I should put it in here.

http://www.bimmerfest.com/forums/sho...d.php?t=634166

What do you guys think about my little starting problem?
Reply With Quote
Ads by Google
  #2  
Old 08-16-2012, 02:23 PM
supertech777's Avatar
supertech777 supertech777 is offline
Officially Welcomed to the 'Fest
Location: springfield , missouri
 
Join Date: May 2008
Posts: 755
Mein Auto: 1995 525i
What's the condition of your fuel filter ? Has it been replaced at all to your knowledge ?

Sent from my Desire HD using Bimmer App
Reply With Quote
  #3  
Old 08-17-2012, 04:26 PM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
Update...I replaced the CKS. No change...thrilled. As for the fuel filters I believe so. But now that I think about it I was pretty low on fuel when all my issues started happening but I quickly filled up thinking I was just running out of gas. Now if I let the car sit for a few minutes it will fire up and then die right away. Could a fuel filter cause this issue??
Reply With Quote
  #4  
Old 08-17-2012, 04:32 PM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
You need to check your fuel pump. Don't forget to check your fuel pump fuse also.
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #5  
Old 08-17-2012, 04:35 PM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
Checked the fuse it good. The car will fire up and run for a few seconds so I thought the fuel pump was ruled out?
Reply With Quote
  #6  
Old 08-17-2012, 06:06 PM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
Yeah, I see your point, but, sometimes that is the way a failing pump manifests itself. You need to check it per the Bentley manual. Jump terminals 30 and 87 of the fuel pump relay sockets. The pump should run when jumped.

It is obvoiusly fuel delivery related. Check the fuel pressure regulator as well.
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #7  
Old 08-18-2012, 01:11 PM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
Alright, so I have seen these nice pictures of 3 relays in a row and it indicates which is the fuel relay. BUT what if I dont have whats in the picture? My relays are under the big maxi fuse at the bottom and horrible to get to. I have no idea whats what or which one to replace or even run a fuel pump test. Oh and there are 4 relays under there not 3.
Reply With Quote
  #8  
Old 08-18-2012, 03:24 PM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
Nevermind I figured it out. Ill keep all interested parties in the loop.
Reply With Quote
  #9  
Old 08-21-2012, 07:32 AM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
Hmm..

Alrighty,

So I replaced the Crank Position Sensor, Fuel Pump Relay. Same symptoms, it will fire up then immediately stall . I am now setting my sights on the fuel pump. As far as I can tell its got to be the last possible thing. (in case any of you want me to do the stomp test, my car wont do it? not sure why.) What do you think? When I replace the fuel pump and fuel filters is there anything I should know before hand?

Thanks,

Destry
Reply With Quote
  #10  
Old 08-21-2012, 09:31 AM
supertech777's Avatar
supertech777 supertech777 is offline
Officially Welcomed to the 'Fest
Location: springfield , missouri
 
Join Date: May 2008
Posts: 755
Mein Auto: 1995 525i
I would replace the fuel filter , before anything else like I suggested early in your thread ...

Sent from my Desire HD using Bimmer App
Reply With Quote
  #11  
Old 08-21-2012, 09:33 AM
supertech777's Avatar
supertech777 supertech777 is offline
Officially Welcomed to the 'Fest
Location: springfield , missouri
 
Join Date: May 2008
Posts: 755
Mein Auto: 1995 525i
I always start with the #1 and cheapest suspect , in your case the fuel filter .

Sent from my Desire HD using Bimmer App
Reply With Quote
  #12  
Old 08-21-2012, 10:37 AM
goosefoot33's Avatar
goosefoot33 goosefoot33 is online now
Manualaholic
Location: Hudson, MA
 
Join Date: Mar 2008
Posts: 1,764
Mein Auto: 01 330Ci/94 530i
Have you tried unplugging your MAF while the car is running (if you can get it to run for a few minutes)?
Can you verify that the fuel filters are new? Three cheap things to do:

1) Clean MAF (after testing it to verify its operational)
2) Clean ICV
3) Replace fuel filters
BONUS: replace/clean air filter

Doing all this will be under $50, the most expensive are the filters @ $15 apiece. Carb cleaner is $5 a can.

Sent from my Droid Incredible
__________________
BMWCCA Member# 451235
(Summer) 2001 330Ci - ZSP
(Winter) 1994 530i "Greenie" - PARTING OUT! (PM for details)

(Grocery Getter) 2002 525iT
Reply With Quote
  #13  
Old 08-21-2012, 10:38 AM
goosefoot33's Avatar
goosefoot33 goosefoot33 is online now
Manualaholic
Location: Hudson, MA
 
Join Date: Mar 2008
Posts: 1,764
Mein Auto: 01 330Ci/94 530i
Quote:
Originally Posted by supertech777 View Post
I always start with the #1 and cheapest suspect , in your case the fuel filter .

Sent from my Desire HD using Bimmer App
+1
I reiterated your point in my post above. I think that is the most important thing to check.

Sent from my Droid Incredible
__________________
BMWCCA Member# 451235
(Summer) 2001 330Ci - ZSP
(Winter) 1994 530i "Greenie" - PARTING OUT! (PM for details)

(Grocery Getter) 2002 525iT
Reply With Quote
  #14  
Old 08-21-2012, 11:00 AM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
So far, I think I am the only one that suggested he check the parts (fuel pump, fuel pressure regulator). I haven't suggested replacement of anything yet. I agree with those above that it could be the fuel filters (inexpensive replacment), but he still needs to properly check the function of the fuel pump first. As we all know, it is a common fail item.

OP, keep us updated please. We hope you resolve it soon.
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #15  
Old 09-06-2012, 01:18 PM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
Alright fellas,

I replaced the fuel filters. The car fired up and ran for about 3 minuted. Then puttered and died. I am assuming the fuel pump is getting worn out. So when there is a bit of pressure in the lines it over heats and stops pumping fuel. Thoughts? I also think that rules out the maf and the fuel pressure regulator.
Reply With Quote
  #16  
Old 09-06-2012, 01:19 PM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
Oh and I already ordered a new fuel pump. Should be here soon.
Reply With Quote
  #17  
Old 09-06-2012, 06:14 PM
TemporarySanity's Avatar
TemporarySanity TemporarySanity is offline
Officially Welcomed to the 'Fest
Location: Linden,MI
 
Join Date: Mar 2007
Posts: 3,562
Mein Auto: 02 530, 02 540, 07 525
Sounds like the pump to me.
__________________

I discovered I scream the same way whether I'm about to be eaten by a great white shark or if a piece of seaweed touches my foot.
Reply With Quote
  #18  
Old 09-07-2012, 04:53 AM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
Pump arrived this morning, I will be putting it in within the next few hours. I will keep everybody posted...heck I am feeling ambitious...maybe ill post a few working pics as well. Good Morning BIMMERFEST!!
Reply With Quote
  #19  
Old 09-08-2012, 12:02 PM
gfsys530isrcute gfsys530isrcute is offline
Registered User
Location: Michigan
 
Join Date: Jul 2012
Posts: 35
Mein Auto: 1995 BMW 530i
Its Alive! Feels like its been forever. Changing the pump in this car was super easy. Thanks for everyone's help. Another DIY solved.
Reply With Quote
  #20  
Old 09-08-2012, 12:48 PM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
Quote:
Originally Posted by gfsys530isrcute View Post
Its Alive! Feels like its been forever. Changing the pump in this car was super easy. Thanks for everyone's help. Another DIY solved.
Glad you got it fixed
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms