Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-13-2012, 09:30 AM
Ionic202 Ionic202 is offline
Registered User
Location: CO
 
Join Date: Aug 2012
Posts: 40
Mein Auto: 2013 535i xDrive
HUD Turn Signals

I am trying to activate the HUD turn signal in my 2013 535ix.

1. HU_NET / HUD_TURNSIGNAL = aktiv
2. KOMBI/BLINKER_HUD_ENABLE = aktiv

There is no checkbox that shows up in the HUD settings. I have also found that the HUD_TURNSIGNAL is not in the 3000 HMI section as shown in the cheat sheet, but is in the 3001 EXBOX section on my car. Any ideas from the gurus?
__________________

2013 535i xDrive, Imperial Blue Metallic, Oyster and Black Nappa Leather, ZCW, ZDA, ZDH, ZLS, ZMP, ZPP, ZTP, 2TB, 323, 416, 4CE, 4U1, 5AC, 677, JB4 Tuner
Reply With Quote
Ads by Google
  #2  
Old 09-13-2012, 10:12 AM
bmguy bmguy is offline
Officially Welcomed to the 'Fest
Location: Alberta
 
Join Date: Nov 2011
Posts: 299
Mein Auto: 2012 Dinan 550xi
When I enabled it; you had to click on "display options" first, then it gave you alist of itmees you can check, and uncheck; the "display Options" (maybe exact text is different) looks like a title for that menu, but when you select it, it brings up a bunch of things you can show or hide on the HUD, turn signals will appear in that list if you did everything right
Reply With Quote
  #3  
Old 09-13-2012, 10:59 AM
Ionic202 Ionic202 is offline
Registered User
Location: CO
 
Join Date: Aug 2012
Posts: 40
Mein Auto: 2013 535i xDrive
The checkbox on the HUD display options is not coming up with the turn signal checkbox. I have checked the coding multiple times and it shows in the HU_NET and KOMBI that they are aktiv.
__________________

2013 535i xDrive, Imperial Blue Metallic, Oyster and Black Nappa Leather, ZCW, ZDA, ZDH, ZLS, ZMP, ZPP, ZTP, 2TB, 323, 416, 4CE, 4U1, 5AC, 677, JB4 Tuner
Reply With Quote
  #4  
Old 09-13-2012, 12:40 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Ionic202 View Post
The checkbox on the HUD display options is not coming up with the turn signal checkbox. I have checked the coding multiple times and it shows in the HU_NET and KOMBI that they are aktiv.
What are the CAFD File names for your HU_NBT and Kombi ECU's?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #5  
Old 09-13-2012, 01:02 PM
AutobahnCowboy AutobahnCowboy is offline
Registered User
Location: Germany
 
Join Date: Sep 2012
Posts: 33
Mein Auto: BMW
ive set today the KOMBI/BLINKER_HUD_ENABLE to aktiv but not the second one.
id no access to internet while coding so i could only watch some pdf´s i got

currently ive the checkbox for "Blinker" in settings but no Blinker in HUD while driving around

i try to set the other option to aktiv too and will report
Reply With Quote
  #6  
Old 09-13-2012, 01:56 PM
Ionic202 Ionic202 is offline
Registered User
Location: CO
 
Join Date: Aug 2012
Posts: 40
Mein Auto: 2013 535i xDrive
Quote:
Originally Posted by shawnsheridan View Post
what are the cafd file names for your hu_nbt and kombi ecu's?
hud_nbt - cafd_00000ded_001_019_008
kombi - cafd_00000069_009_000_042
__________________

2013 535i xDrive, Imperial Blue Metallic, Oyster and Black Nappa Leather, ZCW, ZDA, ZDH, ZLS, ZMP, ZPP, ZTP, 2TB, 323, 416, 4CE, 4U1, 5AC, 677, JB4 Tuner

Last edited by Ionic202; 09-13-2012 at 03:46 PM.
Reply With Quote
  #7  
Old 09-13-2012, 06:17 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Well, it could be different in 2013, but I highly doubt it. Just to make triple sure though, please check the following:

1) Code KOMBI / BLINKER_HUD_ENABLE = aktiv - This actually enables the feature.
2) Code HU_NBT / HUD_TURNSIGNAL = aktiv - This adds the iDrive Checkbox to toggle the feature on and off.
3) Go into iDrive HUD Settings, and enable checkbox for Hud Turn Signals as shown in attached picture.
Attached Thumbnails
Click image for larger version

Name:	vHXaf9.jpg
Views:	387
Size:	328.4 KB
ID:	341751  
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #8  
Old 09-13-2012, 06:45 PM
Ionic202 Ionic202 is offline
Registered User
Location: CO
 
Join Date: Aug 2012
Posts: 40
Mein Auto: 2013 535i xDrive
Quote:
Originally Posted by shawnsheridan View Post
Well, it could be different in 2013, but I highly doubt it. Just to make triple sure though, please check the following:

1) Code KOMBI / BLINKER_HUD_ENABLE = aktiv - This actually enables the feature.
2) Code HU_NBT / HUD_TURNSIGNAL = aktiv - This adds the iDrive Checkbox to toggle the feature on and off.
3) Go into iDrive HUD Settings, and enable checkbox for Hud Turn Signals as shown in attached picture.
1) yes
2) yes
3) no check box on settings screen.
__________________

2013 535i xDrive, Imperial Blue Metallic, Oyster and Black Nappa Leather, ZCW, ZDA, ZDH, ZLS, ZMP, ZPP, ZTP, 2TB, 323, 416, 4CE, 4U1, 5AC, 677, JB4 Tuner
Reply With Quote
  #9  
Old 09-13-2012, 06:53 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by bmguy View Post
When I enabled it; you had to click on "display options" first, then it gave you alist of itmees you can check, and uncheck; the "display Options" (maybe exact text is different) looks like a title for that menu, but when you select it, it brings up a bunch of things you can show or hide on the HUD, turn signals will appear in that list if you did everything right
Is your car a 2013 with the new HU_NBT, and can you confirm that your HUD Turn Signals are working?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #10  
Old 09-13-2012, 06:55 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Ionic202 View Post
1) yes
2) yes
3) no check box on settings screen.
What options are shown on your HUD Settings Screen? Can you post a picture of it?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #11  
Old 09-13-2012, 06:55 PM
bmguy bmguy is offline
Officially Welcomed to the 'Fest
Location: Alberta
 
Join Date: Nov 2011
Posts: 299
Mein Auto: 2012 Dinan 550xi
No Sorry - I'm a 2012 Nov15/2012 build...
Reply With Quote
  #12  
Old 09-13-2012, 07:02 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by bmguy View Post
No Sorry - I'm a 2012 Nov15/2012 build...
Ok. We need someone else with the new HU_NBT to see what is going on.

Paging @falcongeek ...
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #13  
Old 09-13-2012, 07:10 PM
falcongeek falcongeek is offline
Registered User
Location: Fort Worth, TX
 
Join Date: Aug 2012
Posts: 17
Mein Auto: 2013 535i
Quote:
Originally Posted by shawnsheridan View Post
Ok. We need someone else with the new HU_NBT to see what is going on.

Paging @falcongeek ...
I did try coding the HUD turn signals when I first started coding and was not able to get them working either. I set both KOMBI BLINKER_HUD_ENABLE and HU_NBT HUD_TURNSIGNAL as aktiv and also did not get a checkbox to show in the iDrive HUD settings.

I did some digging a while ago and couldn't find any additional settings that I though needed to be changed, but it is possible that I missed something.

Adam
Reply With Quote
  #14  
Old 09-13-2012, 07:16 PM
Ionic202 Ionic202 is offline
Registered User
Location: CO
 
Join Date: Aug 2012
Posts: 40
Mein Auto: 2013 535i xDrive
Quote:
Originally Posted by shawnsheridan View Post
What options are shown on your HUD Settings Screen? Can you post a picture of it?
It is the same as prior to coding.......
Attached Thumbnails
Click image for larger version

Name:	IMG_0295 (Small).JPG
Views:	368
Size:	86.5 KB
ID:	341756  
__________________

2013 535i xDrive, Imperial Blue Metallic, Oyster and Black Nappa Leather, ZCW, ZDA, ZDH, ZLS, ZMP, ZPP, ZTP, 2TB, 323, 416, 4CE, 4U1, 5AC, 677, JB4 Tuner
Reply With Quote
  #15  
Old 09-13-2012, 07:20 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by falcongeek View Post
I did try coding the HUD turn signals when I first started coding and was not able to get them working either. I set both KOMBI BLINKER_HUD_ENABLE and HU_NBT HUD_TURNSIGNAL as aktiv and also did not get a checkbox to show in the iDrive HUD settings.

I did some digging a while ago and couldn't find any additional settings that I though needed to be changed, but it is possible that I missed something.

Adam
Ok. Not good, but at least we know it is an HU_NBT issue. Thanks for confirming. So, we will need to keep digging.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #16  
Old 09-13-2012, 07:23 PM
Ionic202 Ionic202 is offline
Registered User
Location: CO
 
Join Date: Aug 2012
Posts: 40
Mein Auto: 2013 535i xDrive
Quote:
Originally Posted by falcongeek View Post
I did try coding the HUD turn signals when I first started coding and was not able to get them working either. I set both KOMBI BLINKER_HUD_ENABLE and HU_NBT HUD_TURNSIGNAL as aktiv and also did not get a checkbox to show in the iDrive HUD settings.

I did some digging a while ago and couldn't find any additional settings that I though needed to be changed, but it is possible that I missed something.

Adam
I have also been looking in other sections and CAFD files for anything that has turn or blinker. No luck so far. Does it being in the 3001 EXBOX instead of the 3000 HMI section maybe have something to do with it?
__________________

2013 535i xDrive, Imperial Blue Metallic, Oyster and Black Nappa Leather, ZCW, ZDA, ZDH, ZLS, ZMP, ZPP, ZTP, 2TB, 323, 416, 4CE, 4U1, 5AC, 677, JB4 Tuner
Reply With Quote
  #17  
Old 09-13-2012, 07:28 PM
falcongeek falcongeek is offline
Registered User
Location: Fort Worth, TX
 
Join Date: Aug 2012
Posts: 17
Mein Auto: 2013 535i
Quote:
Originally Posted by shawnsheridan View Post
Ok. Not good, but at least we know it is an HU_NBT issue. Thanks for confirming. So, we will need to keep digging.
I have 47.1, is it possible that this is "fixed" in 47.4?
Reply With Quote
  #18  
Old 09-13-2012, 07:34 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by falcongeek View Post
I have 47.1, is it possible that this is "fixed" in 47.4?
Maybe, but I think its an equal probability that if it will work it will work in 47.1 too and there is some other coding we need to find.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #19  
Old 09-13-2012, 07:43 PM
Ionic202 Ionic202 is offline
Registered User
Location: CO
 
Join Date: Aug 2012
Posts: 40
Mein Auto: 2013 535i xDrive
Quote:
Originally Posted by shawnsheridan View Post
Maybe, but I think its an equal probability that if it will work it will work in 47.1 too and there is some other coding we need to find.
I am in 47.4.......
__________________

2013 535i xDrive, Imperial Blue Metallic, Oyster and Black Nappa Leather, ZCW, ZDA, ZDH, ZLS, ZMP, ZPP, ZTP, 2TB, 323, 416, 4CE, 4U1, 5AC, 677, JB4 Tuner
Reply With Quote
  #20  
Old 09-13-2012, 08:32 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Ionic202 View Post
I am in 47.4.......
Well, that confirms that. It is likely that the HU_NBT firmware went unchanged from 47.1 to 47.4, so the ECU is the same. So, it is find some other missing coding, or hope a future firmware corrects the issue.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #21  
Old 09-14-2012, 06:24 AM
AutobahnCowboy AutobahnCowboy is offline
Registered User
Location: Germany
 
Join Date: Sep 2012
Posts: 33
Mein Auto: BMW
i cant get it work on my F30

1. HU_CIC / HUD_TURNSIGNAL = aktiv
2. KOMBI/BLINKER_HUD_ENABLE = aktiv

Checkbox is there and choosen

but no lights in HUD

Reply With Quote
  #22  
Old 09-14-2012, 06:43 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by AutobahnCowboy View Post
i cant get it work on my F30

1. HU_CIC / HUD_TURNSIGNAL = aktiv
2. KOMBI/BLINKER_HUD_ENABLE = aktiv

Checkbox is there and choosen

but no lights in HUD

I have never coded HUD Turn signals on an F30, so I can't say for sure whether it should work.

Has anyone coded an F30 and got it to work?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #23  
Old 09-17-2012, 11:19 AM
digital digital is offline
Registered User
Location: Toronto, ON
 
Join Date: Jan 2008
Posts: 5
Mein Auto: 2013 535i xDrive M-Sport
Hey guys, I had the same issue with my 2013 535i as well. I figured it out eventually. You need to set one of the PIA options to aktiv (I don't remember the name). I will post it here once I get home.

Last edited by digital; 09-17-2012 at 11:20 AM.
Reply With Quote
  #24  
Old 09-17-2012, 11:24 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by digital View Post
Hey guys, I had the same issue with my 2013 535i as well. I figured it out eventually. You need to set one of the PIA options to aktiv (I don't remember the name). I will post it here once I get home.
This will be good to know, although I hope it does not turn out to be a PIA setting that exists in F30 only and not F10 like this one:

Pia_Default_Tippblinken

http://www.bimmerfest.com/forums/sho...182&highlight=
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #25  
Old 09-17-2012, 11:26 AM
digital digital is offline
Registered User
Location: Toronto, ON
 
Join Date: Jan 2008
Posts: 5
Mein Auto: 2013 535i xDrive M-Sport
Mine is F10 2013 with the new Nav. I'll keep you posted.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms