Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > The Detail Department

The Detail Department
Detailing tips, tricks to keep your bimmer in showroom condition.

Reply
 
Thread Tools Display Modes
  #1  
Old 08-06-2012, 07:19 PM
Ilovemycar Ilovemycar is offline
wooohooo
Location: CA
 
Join Date: Feb 2010
Posts: 2,570
Mein Auto: '08 335i coupe 6MT sport
Dramm shut-off valve issue

I bought this after the wholehearted recommendation from the good folks here, and it's been a great thing the whole time, but now after maybe 9 months or so . . . It's not sealing off right, and I'm getting an unwanted little spray shooting out sideway from it, I believe right next to the hose. There might even be more than one spray coming from it, don't quite recall.

I never inspected the innards before, but now I see there is the silver ball valve, sandwiched on either side by a white plastic ring. Does anyone know if there was supposed to be some sort of rubber washer in there perhaps? I'm just trying to figure out what went wrong before I possibly order a new one (or just go back to turning the water on/off repeatedly).

Also, the valve's on/off lever seems to now move way too easily now. I'm pretty sure there was more resistance to its turning on/off, if that might help you help me diagnose my issue.

My two Gilmour quick release connects are still fine of course, and when I looked up the old thread where I was given the Dramm rec, I see that it's because it allows full flow (whereas Gilmour's version is restrictive). Well anyway, thanks for any tips!
Reply With Quote
Ads by Google
  #2  
Old 09-22-2012, 08:14 PM
Revelation19 Revelation19 is offline
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: Nov 2011
Posts: 122
Mein Auto: BMW 528i
I've used my Dramm a lot, and have not had a similar experience. The only issue I've had is that the screw which holds the shut-off handle became loose, but I re-tightend the screw and all is good.

Oh, my Dramm was not sealing right one time. I discovered that the connection to the hose's quick release was loose. Took some pliers and tightend the connection, all good now too.

Hope this helps.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > The Detail Department
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms