Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-25-2012, 10:17 AM
brunooo brunooo is offline
Registered User
Location: DUBAI
 
Join Date: Sep 2012
Posts: 11
Mein Auto: 05 X5 4.8is
Classic DSC/ABS/Brake lights on problem / 2 DSC pumps already changed

Hi Guys,

I have a problem on my 2005 X5 4.8is

Two months ago, I happened to have the DSC/Brake/ABS lights on on my dash, and went to the workshop. The problem was due to the DSC pump failing, which is not so common (was suspecting a sensor at first). First time, I replaced the pump by a used one, it worked fine for 1 month, and the lights appeared again.

I changed the pump for a new one, and the lights came off for two weeks, but they appeared again yesterday.

I suspect the pump is faulty again. I am investigating on what should these pumps to fail. A new pump should not fail after 2 weeks...

I noticed that one small black wire next the to the positive cable for the battery has been cut and wrapped in duck tape (previous owner way to solve problems? IBS cable?) Maybe this is causing a problem with the pump with stray current....

Will keep you posted on that.

If any of you encountered the same thing and found a solution, just let me know.

Thanks

Bruno
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms