Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 09-26-2012, 03:34 PM
X3Dave X3Dave is offline
Registered User
Location: Minnesota
 
Join Date: Oct 2010
Posts: 13
Mein Auto: 2010 X3
New Battery or Battery Tender?

I have a 2010 X3. Recently I've been having problems with the battery. At first it wouldn't start in cold weather. Now it won't start sometimes in warm weather.

I typically drive it two or three times a week totaling about an hour a day (1/2 hour to work 1/2 hour back without stops). I also take it on longer trips once or twice a month averaging 130 miles a day.

During the last warranty service check in May and the technician said the battery and everything else was fine. Looked at the battery and it has a 720 CCA battery.

One day I was listening to the radio for about 15 minutes and then vehicle wouldn't start. Fortunately, I was a my buddy's house and was able to charge the battery.

The most recent incident I don't have an explanation for. The battery went dead for some reason. I jumped it with my other vehicle and then charged the battery.

I don't seem to have problems when I drive the vehicle long distances. It has started fine in cold weather after its been driven a long distance. Is a characteristic of this vehicle if you have to drive it to keep the battery charged?

Last winter I put it on a battery charger as a precautionary measure so it would start in the morning. (It sometimes stays outside). I live in Minnesota so a good battery is mandatory. However, I'm not going to buy a new battery if it isn't necessary.
Reply With Quote
Advertisement
  #2  
Old 09-26-2012, 05:50 PM
al_macaroni al_macaroni is offline
Officially Welcomed to the 'Fest
Location: DE
 
Join Date: Jul 2009
Posts: 320
Mein Auto: BMW X3
It sounds like you are driving enough and for a long enough duration to keep the battery properly charged. You should not be having battery problems with a two year old car. You may have a problem with your charging system or something electrical is not properly shutting down when the car is turned off and it is draining the battery. The blue tooth module on older model X3s sometimes have this problem.

If you are under warranty, I would take it to the dealership to get it checked out.
__________________
2013 535i - ED, Oct 2012 | Cashmere Silver | Oyster/Black Nappa Anthracite | ZCW | Sirius | Air Blue 80
2008 X3 | Monaco | Sand/Black Light Poplar | ZAP | ZPP | ZCW | Xenon | Rear Fog
1988 Grand Wagoneer | Burgundy | Ghost Flames | 360 ci | Holley carb

BMW CCA #422951

Reply With Quote
  #3  
Old 09-27-2012, 05:36 AM
x3brian x3brian is offline
Officially Welcomed to the 'Fest
Location: Sacramento CA
 
Join Date: Jan 2011
Posts: 989
Mein Auto: X3
+1 above. I have an 09 with almost 100k miles and never a start or battery issue. If under warranty I would have the problem investigated at the dealer.
Reply With Quote
  #4  
Old 09-27-2012, 08:05 AM
john@eac john@eac is offline
Past Sponsor
Location: Ohio
 
Join Date: Jul 2012
Posts: 207
Mein Auto: Many
It almost sounds like a battery issue. However I agree with al macaroni there might be a charging system issue or a draw on the system.
Reply With Quote
  #5  
Old 09-27-2012, 08:44 AM
bowang bowang is offline
Banned
Location: OH
 
Join Date: Sep 2012
Posts: 21
Mein Auto: 2007 X3
Sounds like you need a new battery

I installed a new battery (AutoCraft H8-AGM) from Advance Auto Parts on 09/15/2012. So far everything works great. It's only $125.99 after using a link my friend sent to me. The link saved me $35 instantly. The battery can be used on X3, X5, X6, 3 Series and 5 Series. I got free installation at local Advance Auto Parts store. My local BMW dealer confirmed that there is no need to register a battery on a 07 X3.

Here is the link (up to 40% on everything): http://advanceautoparts.**************************

H8-AGM Spes:
Acid Included: Yes
Battery Type: AGM
Battery Usage: Auto/Truck
BCI Group Size: H8
Cold Cranking Amps: 900
Cranking Amps: 1000
Deep Cycle/Starting: Dual Purpose
Maintenance Free: Yes
Reserve Capacity: 160
Terminal Type: SAE
Weight: 59.45
Length: 13.94
Width: 6.938
Height: 7.5

Warranty:
7 Year Warranty (3 Year FREE Replacement)
Reply With Quote
  #6  
Old 10-15-2012, 09:48 PM
Jafega Jafega is offline
Registered User
Location: NM
 
Join Date: Oct 2012
Posts: 3
Mein Auto: 2007 BMW, X3
Quote:
Originally Posted by bowang View Post
I installed a new battery (AutoCraft H8-AGM) from Advance Auto Parts on 09/15/2012. So far everything works great. It's only $125.99 after using a link my friend sent to me. The link saved me $35 instantly. The battery can be used on X3, X5, X6, 3 Series and 5 Series. I got free installation at local Advance Auto Parts store. My local BMW dealer confirmed that there is no need to register a battery on a 07 X3.

Here is the link (up to 40% on everything): http://advanceautoparts.**************************

H8-AGM Spes:
Acid Included: Yes
Battery Type: AGM
Battery Usage: Auto/Truck
BCI Group Size: H8
Cold Cranking Amps: 900
Cranking Amps: 1000
Deep Cycle/Starting: Dual Purpose
Maintenance Free: Yes
Reserve Capacity: 160
Terminal Type: SAE
Weight: 59.45
Length: 13.94
Width: 6.938
Height: 7.5

Warranty:
7 Year Warranty (3 Year FREE Replacement)
Thanks for the link bowang! My total came to $113.99 (free shipping) and will be ready for pick up in (2) days for my new battery. This is much easier to digest than the $600 I was quoted...yuck.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms