Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-28-2012, 06:17 AM
soudafirechief soudafirechief is offline
soudafirechief
Location: Martin, GA
 
Join Date: Sep 2012
Posts: 1
Mein Auto: 1991 BMW 318i
318i Convertible

My 1991 318i has developed a stumble (almost like someone turned the ignition off for a second) during acceleration once the engine is at normal temp. I can also feel the same thing on deceleration (something like a miss). Sometimes the engine will continue to stumble and pump fuel into the system causing the catalytic converter to overheat. I have changed the injectors, wires, fuel filter and the fuel pump was installed last year.
Reply With Quote
Ads by Google
  #2  
Old 09-29-2012, 02:03 AM
Billwill Billwill is offline
Officially Welcomed to the 'Fest
Location: South Africa
 
Join Date: Oct 2009
Posts: 480
Mein Auto: BMW E30 318i 1991
Quote:
Originally Posted by soudafirechief View Post
My 1991 318i has developed a stumble (almost like someone turned the ignition off for a second) during acceleration once the engine is at normal temp. I can also feel the same thing on deceleration (something like a miss). Sometimes the engine will continue to stumble and pump fuel into the system causing the catalytic converter to overheat. I have changed the injectors, wires, fuel filter and the fuel pump was installed last year.
If you are only having the problem at normal operating temperature and not when cold then possibly the Blue temperature sensor is faulty.

This sensor senses engine temperature...not the Brown sensor which activates the temperature gauge.

This sensor....a Thermistor which changes resistance with heat...indicates to the ECU what the engine temp is so that the ECU can vary the fuel mixture accordingly.

It is best to check this sensors' resistance right at the ECU connector....should read about 3,000 Ohms when cold and about 300 Ohms when hot.

You probably have the M42 engine....I think the sensor is located under the intake manifold.


Otherwise check your plugs, plug leads, distributor and coils.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms