Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > The Detail Department

The Detail Department
Detailing tips, tricks to keep your bimmer in showroom condition.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 09-29-2012, 08:38 AM
Jen4BMW Jen4BMW is offline
Jen4BMW
Location: Minneapolis
 
Join Date: May 2012
Posts: 71
Mein Auto: 2013 X3 35i M Sport
X3 Paint Question

I have a nagging question for all you detail guys out there that is driving me crazy. I have a brand new 2013 Alpine White X3 Msport and have sealed the paint with Wolfgang Deep Gloss Paint Sealant.

What I've noticed, actually felt, is from day one, even before sealing, the paint feels "gritty" almost metalic like all over. Is this normal with Alpine White BMW X3 paint? I am actually wondering if BMW had a bad batch of clear coat or something. Does this happen? The Wolfgang sealant gives me a nice shine but what's perplexing is how rough paint feels to the hand. It's like rubbing your hand over micro fine sandpaper.

The car felt this way straight out of production and so far hasn't improved after 3 sealant jobs. Does this sound like defective paint? Is this typical with sealants? Would switching to wax help? I'll clay it in the Spring but I don't this isn't the culprit. The car is brand new with only 4000 miles on it. I also have 2 tiny rock chips on the middle of the hood of all odd places so not even a direct hit. Cheap paint! What does a dealer normally charge Per chip?

Thanks for the input! Can't wait to hear what you guys diagnose and order up for a fix.
Jen
__________________
2013 X3 35i M Sport / PREMIUM / DHP / TECH / COLD 1 & 11 / AW / OYSTER

Last edited by Jen4BMW; 09-29-2012 at 08:42 AM.
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > The Detail Department
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms