Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10-02-2012, 07:41 PM
josemedeiros007 josemedeiros007 is offline
Officially Welcomed to the 'Fest
Location: San Jose, California
 
Join Date: Sep 2012
Posts: 115
Mein Auto: 1998 528i 4Dr
528 engine sensor connector wiring guide.

Greetings,

Does anyone have a wiring diagram available that shows which connectors connect to which sensors?

My name is Jose F. Medeiros. I grew up in San Jose, California and have lived there since 1972. I am new to the list, and own a 1998 BMW 528 that I bought used with 180,000 miles on it from a friend. This is my second BMW, my first was a 1999 323is that I bought new from Allison BMW in Mountain View, California.

Does anyone have a wiring diagram available that shows which connectors connect to which sensors?

My 1998 BMW overheated a few months back, due to a broken water neck off the BEHR radiator while I was driving. After replacing the Radiator, with a Nissen, I started experiencing coolant loss, and white smoke out the tail pipe, I tried both K&W head gasket sealer, and Blue Devil, both temporary fixes, but helped for a short time.

My motor had 265,000 so it was decided to replace it a few weeks ago with a used motor with 110,000 miles, as the labor was not to be much more then replacing the cylinder head, but after the install, several codes are now popping up using my Peak Research code reader. This forum has been very helpful in helping to identify the issue's. Part of the problem was that the mechanic had plugged in the wrong connecter to the wrong sensor, so I took a chance and reversed them, and eliminated two of the codes OC and the ASC light on the dash not turning off, not to mention the engine runs much better and no longer hesitates. I am still getting a code for OE - Intake Air Temp Sensor and 44 - Evap Systems Purge Control Valve, which I feel is probably the sensor connectors reversed, which I am trying to locate.

Thank you each in advance for your help.

Jose F. Medeiros
http://www.linkedin.com/in/josemedeiros
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms