Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10-03-2012, 09:19 AM
idriveE60 idriveE60 is offline
Registered User
Location: califorina
 
Join Date: Oct 2012
Posts: 13
Mein Auto: 2004 e60
Increased emissions

as a result of increased emissions in my case it was the secondary air valve and pump failure,SES ON , and system running lean according to OBDII codes, so i did some research and found out how to check the secondary air system ,turns out by visual inspection i found the hose that comes from the pump to the valve was pinched right before the valve, not a durable hose kinda thin for being that close to the motor ,i order the hose and valve (pump was good) from bavauto.com about thirty dollars online ,for the time being i installed a stent in the hose to keep it from collapsing and stopping air from passing though,i reset the SEL light fault codes and its been good no SES of for like a week ,untill i ran into some more issues with another increased emissions fault with a engine malfunction reduced power error message on idrive system,so what now i said to myself ,ran a code search on OBII turns out im running lean again and random miss-fire misfire on cylinders 1,2,4 bank 1 bank 2 on o2 sensors ,rough idle like crazy the tack was bouncing and it was making a weird noise from the intake ,flapping rattle sound ,checked out online and found out it was my disa valve (air intake mixture valve) have it on order now ,soon as its replaced i am going to reset the codes and see whats next ,
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms