Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #26  
Old 09-17-2012, 11:30 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,163
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by digital View Post
Mine is F10 2013 with the new Nav. I'll keep you posted.
Good deal. Thanks.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #27  
Old 09-17-2012, 05:24 PM
digital digital is offline
Registered User
Location: Toronto, ON
 
Join Date: Jan 2008
Posts: 5
Mein Auto: 2013 535i xDrive M-Sport
Here it is:

1- Code KOMBI / HUD_PIA_BLINKER = aktiv
2- Code KOMBI / BLINKER_HUD_ENABLE = aktiv
3- Code HU_NBT / HUD_TURNSIGNAL = aktiv

The iDrive check box will not show up, but it works. (I couldn't figure out the check box issue)
__________________
2013 535i xDrive M-Sport Graphite
2011 X3 35i White
2004 325i Silver Grey
1978 518
Reply With Quote
  #28  
Old 09-17-2012, 05:26 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,163
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by digital View Post
Here it is:

1- Code KOMBI / HUD_PIA_BLINKER = aktiv
2- Code KOMBI / BLINKER_HUD_ENABLE = aktiv
3- Code HU_NBT / HUD_TURNSIGNAL = aktiv

The iDrive check box will not show up, but it works. (I couldn't figure out the check box issue)
Sweet! Maybe you can kind the missing Pia_Default_Tippblinken or equivalent too?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #29  
Old 09-17-2012, 06:12 PM
digital digital is offline
Registered User
Location: Toronto, ON
 
Join Date: Jan 2008
Posts: 5
Mein Auto: 2013 535i xDrive M-Sport
Quote:
Originally Posted by shawnsheridan View Post
Sweet! Maybe you can kind the missing Pia_Default_Tippblinken or equivalent too?
I'll work on it
__________________
2013 535i xDrive M-Sport Graphite
2011 X3 35i White
2004 325i Silver Grey
1978 518
Reply With Quote
  #30  
Old 09-18-2012, 06:10 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,163
Mein Auto: 2011 535i M-Sport
Paging @marcosg:

Can you check and tell me if your HUD Turnsignals work with just:

KOMBI / BLINKER_HUD_ENABLE = aktiv
HU_CIC / HUD_TURNSIGNAL = aktiv

Or, if you also have to enable:

KOMBI / HUD_PIA_BLINKER = aktiv

Also, tell me if you have the "Turn indicator" Checkbox in Settings=>Heads-Up Display.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #31  
Old 09-18-2012, 06:17 AM
marcosg marcosg is offline
Registered User
Location: Sydney Australia
 
Join Date: Oct 2007
Posts: 57
Mein Auto: 2011 BMW F10 528i M Sport
Quote:
Originally Posted by shawnsheridan View Post
Paging @marcosg:

Can you check and tell me if your HUD Turnsignals work with just:

KOMBI / BLINKER_HUD_ENABLE = aktiv
HU_CIC / HUD_TURNSIGNAL = aktiv

Or, if you also have to enable:

KOMBI / HUD_PIA_BLINKER = aktiv

Also, tell me if you have the "Turn indicator" Checkbox in Settings=>Heads-Up Display.
Yes, HUD Turnsignals work with just

KOMBI / BLINKER_HUD_ENABLE = aktiv
HU_CIC / HUD_TURNSIGNAL = aktiv

I did not code KOMBI / HUD_PIA_BLINKER. It is currently set to inaktiv

Yes, I do have "Turn indicator" Checkbox in Settings=>Heads-Up Display.
__________________
2011 BMW F10 528i M Sport

Last edited by marcosg; 09-18-2012 at 06:20 AM.
Reply With Quote
  #32  
Old 09-18-2012, 06:30 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,163
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by marcosg View Post
Yes, HUD Turnsignals work with just

KOMBI / BLINKER_HUD_ENABLE = aktiv
HU_CIC / HUD_TURNSIGNAL = aktiv

I did not code KOMBI / HUD_PIA_BLINKER. It is currently set to inaktiv

Yes, I do have "Turn indicator" Checkbox in Settings=>Heads-Up Display.
Ok. Interesting. So, a car with HU_CIC updated with 47.x acts the same as it always has, yet cars with HU_NBT apparently need KOMBI / HUD_PIA_BLINKER also enabled to get HUD turn signals, and for some reason, the "Turn indicator" Checkbox does not show up with HU_CIC / HUD_TURNSIGNAL = aktiv.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #33  
Old 09-20-2012, 06:01 PM
preeble preeble is offline
Registered User
Location: PA
 
Join Date: Aug 2012
Posts: 56
Mein Auto: Cars
I couldn't get my 2013 F10 to work either, but will try it with these new settings and will report back.
Reply With Quote
  #34  
Old 09-21-2012, 07:19 PM
falcongeek falcongeek is offline
Registered User
Location: Fort Worth, TX
 
Join Date: Aug 2012
Posts: 17
Mein Auto: 2013 535i
Quote:
Originally Posted by digital View Post
Here it is:

1- Code KOMBI / HUD_PIA_BLINKER = aktiv
2- Code KOMBI / BLINKER_HUD_ENABLE = aktiv
3- Code HU_NBT / HUD_TURNSIGNAL = aktiv

The iDrive check box will not show up, but it works. (I couldn't figure out the check box issue)
I was able to get the HUD Turnsignals working on my 2013 F10 also using the KOMBI / HUD_PIA_BLINKER = aktiv setting. I also found that they continue to work even with HU_NBT / HUD_TURNSIGNAL = inaktiv. It looks like the checkbox function maybe similar to the Entertainment/Telephone List where the checkbox just won't work but the HUD still displays them properly?

Adam
Reply With Quote
  #35  
Old 09-21-2012, 07:39 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,163
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by falcongeek View Post
I was able to get the HUD Turnsignals working on my 2013 F10 also using the KOMBI / HUD_PIA_BLINKER = aktiv setting. I also found that they continue to work even with HU_NBT / HUD_TURNSIGNAL = inaktiv. It looks like the checkbox function maybe similar to the Entertainment/Telephone List where the checkbox just won't work but the HUD still displays them properly?

Adam
Your check box shows up though, its just nonfunctional?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #36  
Old 09-24-2012, 09:34 PM
FrogmanF30's Avatar
FrogmanF30 FrogmanF30 is online now
Officially Welcomed to the 'Fest
Location: Southern California
 
Join Date: Mar 2012
Posts: 407
Mein Auto: 2012 328i
Quote:
Originally Posted by shawnsheridan View Post
I have never coded HUD Turn signals on an F30, so I can't say for sure whether it should work.

Has anyone coded an F30 and got it to work?
I just tried this on my 2012 F30 328i (April build); no joy.

I set:

HU_CIC / 3000 / HUD_TURNSIGNAL to aktiv (Wete=01)
KOMBI / 3003 / HUD_BLINKER_ENABLE to aktiv (Werte=01) F30 function is named this, there is no BLINKER_HUD_ENABLE in KOMBI)
KOMBI / 3008 / HUD_PIA_BLINKER to aktiv (Werte=01)

I get the iDrive turn signal option in the HUD section and I can select it and it's checked, but no HUD signals show up.

I also wanted to code the one-touch from 3 blinks to 5, so I also changed:

FEM / 3064 / PIA_DEFAULT_TIPPBLINKEN to Mehrfachblinken (Werte=01)
FEM / 3060 / BLINKZYKLEN_ANZAHL_TIPP to Werte=04 (value name changes to UNKNOWN)

I now get 5 blinks for one-touch, but still no HUD signals. Any ideas?

It may be one of those settings that takes a while to "take", so I'll see if it works tomorrow...


I-Step is F020-12-07-532

CAFD versions:
HU_CIC is 0F9_007_003_007
KOMBI is 9C8_005_000_030
FEM is 794_004_122_077
Reply With Quote
  #37  
Old 10-03-2012, 01:31 PM
legaleye3000 legaleye3000 is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Sep 2012
Posts: 101
Mein Auto: F30 328i Sedan
If anyone figures out HUD turn signals for F30 2012, please post. Thanks.
Reply With Quote
  #38  
Old 10-03-2012, 02:30 PM
332701 332701 is offline
Registered User
Location: Switzerland
 
Join Date: Sep 2012
Posts: 34
Mein Auto: 535xd
Quote:
Originally Posted by legaleye3000 View Post
If anyone figures out HUD turn signals for F30 2012, please post. Thanks.
don't you have the same menu structure as the F10/11?
__________________
535xd with 20'' Wheel style 434 M in Sophistogrey II Brillant Metallic

Reply With Quote
  #39  
Old 10-03-2012, 02:36 PM
FrogmanF30's Avatar
FrogmanF30 FrogmanF30 is online now
Officially Welcomed to the 'Fest
Location: Southern California
 
Join Date: Mar 2012
Posts: 407
Mein Auto: 2012 328i
Quote:
Originally Posted by 332701 View Post
don't you have the same menu structure as the F10/11?
It's almost the same.

HU_CIC / 3000 / HUD_TURNSIGNAL to aktiv (Wete=01)
KOMBI / 3003 / HUD_BLINKER_ENABLE to aktiv (Werte=01) F30 function is named this, there is no BLINKER_HUD_ENABLE in KOMBI)
KOMBI / 3008 / HUD_PIA_BLINKER to aktiv (Werte=01)


I've set all three and get the option in the iDrive HUD list and I can and do select it, but no turn signals show up in the HUD.
Reply With Quote
  #40  
Old 10-03-2012, 02:36 PM
legaleye3000 legaleye3000 is offline
Officially Welcomed to the 'Fest
Location: South FL
 
Join Date: Sep 2012
Posts: 101
Mein Auto: F30 328i Sedan
I'm not sure, but a couple posts above, he said he was unable to do it.
Reply With Quote
  #41  
Old 10-03-2012, 03:49 PM
wdimagineer's Avatar
wdimagineer wdimagineer is offline
Officially Welcomed to the 'Fest
Location: San Francisco, CA
 
Join Date: Dec 2011
Posts: 665
Mein Auto: 2013 M5
Quote:
Originally Posted by falcongeek View Post
I was able to get the HUD Turnsignals working on my 2013 F10 also using the KOMBI / HUD_PIA_BLINKER = aktiv setting. I also found that they continue to work even with HU_NBT / HUD_TURNSIGNAL = inaktiv. It looks like the checkbox function maybe similar to the Entertainment/Telephone List where the checkbox just won't work but the HUD still displays them properly?

Adam
Interesting. Do you get a checkbox? I don't. But they DO work.
__________________
Current: 2014 X5 xDrive50i ZMM - Alpine White/Mocha (Mods In Progress!)
Past: 2014 Jeep SRT - 2013 Tesla Model S P85+ - Bimmerpost Featured 2013 F10 M5 - 2012 550 xDrive - 2011 M3 ZCP
Reply With Quote
  #42  
Old 10-03-2012, 04:16 PM
FrogmanF30's Avatar
FrogmanF30 FrogmanF30 is online now
Officially Welcomed to the 'Fest
Location: Southern California
 
Join Date: Mar 2012
Posts: 407
Mein Auto: 2012 328i
Quote:
Originally Posted by wdimagineer View Post
Interesting. Do you get a checkbox? I don't. But they DO work.
On my F30 (with CIC not NBT) I get the checkbox and it's enabled (I can check and uncheck it), but no turn signals show up in the HUD when checked.

Did you only change the KOMBI / HUD_PIA_BLINKER = aktiv and nothing else to get yours to work? I have not tried that yet. I've also always set HUD_BLINKER_ENABLE to aktiv too.

When I just reset HU_CIC / 3000 / HUD_TURNSIGNAL back to inaktiv (leaving the other 2 changes intact), the check box goes away and no signals in the HUD.

I think the HU_CIC change just enables the checkbox on the screen and the KOMBI change(s) actually enable the function.
Reply With Quote
  #43  
Old 10-03-2012, 08:03 PM
wdimagineer's Avatar
wdimagineer wdimagineer is offline
Officially Welcomed to the 'Fest
Location: San Francisco, CA
 
Join Date: Dec 2011
Posts: 665
Mein Auto: 2013 M5
Quote:
Originally Posted by FrogmanF30 View Post
On my F30 (with CIC not NBT) I get the checkbox and it's enabled (I can check and uncheck it), but no turn signals show up in the HUD when checked.

Did you only change the KOMBI / HUD_PIA_BLINKER = aktiv and nothing else to get yours to work? I have not tried that yet. I've also always set HUD_BLINKER_ENABLE to aktiv too.

When I just reset HU_CIC / 3000 / HUD_TURNSIGNAL back to inaktiv (leaving the other 2 changes intact), the check box goes away and no signals in the HUD.

I think the HU_CIC change just enables the checkbox on the screen and the KOMBI change(s) actually enable the function.
I checked everything, including in HU_NBT. I get no checkbox, but I do get turn signals in my HUD.
__________________
Current: 2014 X5 xDrive50i ZMM - Alpine White/Mocha (Mods In Progress!)
Past: 2014 Jeep SRT - 2013 Tesla Model S P85+ - Bimmerpost Featured 2013 F10 M5 - 2012 550 xDrive - 2011 M3 ZCP
Reply With Quote
  #44  
Old 10-08-2012, 03:18 AM
soupratt soupratt is offline
Registered User
Location: Melbourne
 
Join Date: Sep 2012
Posts: 8
Mein Auto: 520d
This works perfectly well in a 2011 Australian M-spec 520d.... Nice to use as the turn signal sound is quite soft and can be muffled by music.
Reply With Quote
  #45  
Old 10-27-2012, 05:24 AM
f01driver f01driver is offline
Officially Welcomed to the 'Fest
Location: Canada
 
Join Date: Jun 2012
Posts: 750
Mein Auto: 11' 750i, 14' Bentley GTC
Has anyone tried this on the f01?
__________________
2011 750i

Reply With Quote
  #46  
Old 11-07-2012, 01:53 AM
f01driver f01driver is offline
Officially Welcomed to the 'Fest
Location: Canada
 
Join Date: Jun 2012
Posts: 750
Mein Auto: 11' 750i, 14' Bentley GTC
Coded the signals on my f01;

__________________
2011 750i

Reply With Quote
  #47  
Old 11-10-2012, 12:04 PM
AutobahnCowboy AutobahnCowboy is offline
Registered User
Location: Germany
 
Join Date: Sep 2012
Posts: 33
Mein Auto: BMW
shows the hud only both sides together or right/right and left/left ?

in my tested F30 i cant get it work

got the Checkbox too but take no effect in hud
Reply With Quote
  #48  
Old 11-21-2012, 03:46 PM
csnyder335i csnyder335i is offline
Registered User
Location: Arizona
 
Join Date: Sep 2012
Posts: 17
Mein Auto: 335i
Any luck on this. Have an 2013 F30 checkbox shows up but no blinkers in HUD. Have all 3 settings enabled.
Reply With Quote
  #49  
Old 11-21-2012, 04:33 PM
f01driver f01driver is offline
Officially Welcomed to the 'Fest
Location: Canada
 
Join Date: Jun 2012
Posts: 750
Mein Auto: 11' 750i, 14' Bentley GTC
Quote:
Originally Posted by AutobahnCowboy View Post
shows the hud only both sides together or right/right and left/left ?

in my tested F30 i cant get it work

got the Checkbox too but take no effect in hud

Signals are shown to together.
__________________
2011 750i

Reply With Quote
  #50  
Old 11-21-2012, 08:00 PM
FrogmanF30's Avatar
FrogmanF30 FrogmanF30 is online now
Officially Welcomed to the 'Fest
Location: Southern California
 
Join Date: Mar 2012
Posts: 407
Mein Auto: 2012 328i
Quote:
Originally Posted by csnyder335i View Post
Any luck on this. Have an 2013 F30 checkbox shows up but no blinkers in HUD. Have all 3 settings enabled.
No joy on getting this to work on an F30 yet.

I also have all 3 settings activated on my 2012 328i and the check box is operational, just no blinkers in the HUD.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms