Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)

E36 (1991 - 1999)
The E36 chassis 3-Series BMW was a huge hit among driving enthusiasts from the first moment the car hit the pavement. The E36 won numerous awards over the years it was produced and is still a favorite of many BMW enthusiasts to this day! -- View the E36 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 10-07-2012, 03:22 PM
C Sean Watts C Sean Watts is offline
That'll buff right out
Location: NC
 
Join Date: Sep 2008
Posts: 436
Mein Auto: '97 328is, etc.
CAN bus time out - code d9

I had to remove then replace the DME (and other control unit with it) and now I have a d9 code - CAN bus time out.

NO- check engine light or ABS light

YES- ASC light will not turn off and transmission warning light is now on. I KNOW the trans is good.


ANY IDEAS if this can be reset with a Peak tool?
__________________
If you anagram Julian Assange you get "Alien Anus Jags."
Reply With Quote
Advertisement
  #2  
Old 10-07-2012, 04:04 PM
dc_wright's Avatar
dc_wright dc_wright is online now
bimmerfest Supporting Member
Location: Orlando, Florida
 
Join Date: Nov 2007
Posts: 7,005
Send a message via ICQ to dc_wright
Mein Auto: '96 328iC, '04 325Ci
Try disconnecting and reseating the connector on the DME and the "other module" . Those connectors can be difficult to get fully seated and locked down. When you have them disconnected look carefully at the connector pins on both connectors and make certain you don't have a bent pin(s).
__________________
2006 Z4 3.0si Sport Package (But I'll still hang with my "homies" in the E36 forum)
Reply With Quote
  #3  
Old 10-07-2012, 05:31 PM
C Sean Watts C Sean Watts is offline
That'll buff right out
Location: NC
 
Join Date: Sep 2008
Posts: 436
Mein Auto: '97 328is, etc.
Quote:
Originally Posted by dc_wright View Post
Try disconnecting and reseating the connector on the DME and the "other module" . Those connectors can be difficult to get fully seated and locked down. When you have them disconnected look carefully at the connector pins on both connectors and make certain you don't have a bent pin(s).
It's dark now but I'll give it a try tomorrow.

OH- Is there a minimum time I should leave the battery disconnected BEFORE touching the computers?
__________________
If you anagram Julian Assange you get "Alien Anus Jags."
Reply With Quote
  #4  
Old 10-08-2012, 12:11 PM
C Sean Watts C Sean Watts is offline
That'll buff right out
Location: NC
 
Join Date: Sep 2008
Posts: 436
Mein Auto: '97 328is, etc.
DC had it...

Update and BACK date:

I posted a year or so ago about a 'coil failure, cyl. no. 1" failure. I kept getting mil. light and pulled the code with a Peak -- "11 1d EE" I swapped out coils among cylinders - code came back. Changed the coils when Bav Auto had them on sale - code came back after two weeks. I had the injectors cleaned and tested OFF the car and they were a bit lean but not totally out of spec. - code came back after a month or so. I changed the PCV ducts, oil separator, etc. AND changed spark plugs - code came back after a few days.

Fast forward...nothing indicated bad valves or rod AND once in a while the 'check engine' light will go OFF, on a warm, dry day.....HMMM. I'm onto something. SO I found and opened the computer compartment. FULL of 14 years of road dust, leaf powder and bug wings. Whatever tiny hole the crap came through let plenty in! I EVEN FOUND CRAP INSIDE THE TRANS COMPUTER CONNECTOR!!!

I had some CRC electronic cleaner and Deoxit - and plenty of patience....I sprayed, tooth brushed gently and used the deoxit, then let it soak and blew it all clean with a can of air. Plugged in and started - GOOD NEWS...no lights. I have not test driven (raining and I'm cleaning up) AND only time will tell but so far so good after ~10 of running.
__________________
If you anagram Julian Assange you get "Alien Anus Jags."
Reply With Quote
  #5  
Old 10-08-2012, 12:25 PM
TheFinanceGuy's Avatar
TheFinanceGuy TheFinanceGuy is offline
still learnin'
Location: Boston Metro West (BMW)
 
Join Date: Aug 2011
Posts: 4,957
Mein Auto: 1998 328i / 99 540iA
Yahoo! I hope you took some pictures? That might be one for the photo album.
__________________
Patrick ///04 330i ZHP///BMWCCA#465139



99 540i TiAg
98 328i hellrot (sold)
96 318iC black (sold)
Reply With Quote
  #6  
Old 10-08-2012, 03:05 PM
C Sean Watts C Sean Watts is offline
That'll buff right out
Location: NC
 
Join Date: Sep 2008
Posts: 436
Mein Auto: '97 328is, etc.
Quote:
Originally Posted by TheFinanceGuy View Post
Yahoo! I hope you took some pictures? That might be one for the photo album.
NO, unfortunately, BUT I can get some of the foam cover in front of the computer compartment when it stops raining. There really wasn't much to it other than the dust in there.
__________________
If you anagram Julian Assange you get "Alien Anus Jags."
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E36 (1991 - 1999)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms