Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 10-07-2012, 11:55 PM
GLOK1132 GLOK1132 is offline
Officially Welcomed to the 'Fest
Location: Texas
 
Join Date: Aug 2011
Posts: 176
Mein Auto: 2002 325i
Question Advanced Lean code question

I have searched plenty and read more on this site than any books ever so please no search Nazis. Lean code only comes up When it is Cold outside (Sub 50 degrees), didn't come on all summer, only during idling after driving around for a couple of minutes, such as red lights and drive throughs.

New fuel filter, new spark plugs, MAF seems to be in perfect working order, DISA valve is good, checked for cracks in intake hose, Cleaned ICV recently, and still the light remains.

What I am thinking is the seal on the DISA could be replaced because the light only comes on when idling, and I belive the DISA closes during idle and the pressure mixed with a cold, old seal could cause a slight leek. Or the ICV needs to be replaced, I cleaned it pretty good and everything is fine in warm weather but maybe something inside the ICV is bad.

I don't have rough idle, only lean codes, no O2 sensor codes, so I think the O2's are good. I was hoping someone here on this great site could help me out so I don't spend Hundreds by going on a witch hunt and replacing everything.

Any help is appreciated and any advice leading to the direct solution of my problem will be rewarded with a cookie.

Last edited by GLOK1132; 10-09-2012 at 02:43 AM.
Reply With Quote
Ads by Google
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms