Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 10-08-2012, 01:51 PM
steve3402 steve3402 is offline
Registered User
Location: NY, USA
 
Join Date: Oct 2012
Posts: 4
Mein Auto: 2004 X3
Post Windshield Wipers Problem

Hi all, yesterday I was driving through some medium to heavy rain. My wipers were on "intermittent" and were operating at maximum level. All of a sudden, they seemed to crash against the windshield, made a very loud noise and then resumed their normal operation. This happened 3 times over a 20 minutes period. Must admit, it really startled us. Has anyone ever experienced this and, if so, any explanations. Thanks, in advance.
Reply With Quote
Advertisement
  #2  
Old 10-09-2012, 01:11 PM
al_macaroni al_macaroni is offline
Officially Welcomed to the 'Fest
Location: DE
 
Join Date: Jul 2009
Posts: 330
Mein Auto: BMW X3
Is your problem anything like the one in this thread?

http://www.bimmerfest.com/forums/sho...light=x3+wiper
__________________
2013 535i - ED, Oct 2012 | Cashmere Silver | Oyster/Black Nappa Anthracite | ZCW | Sirius | Air Blue 80
2008 X3 | Monaco | Sand/Black Light Poplar | ZAP | ZPP | ZCW | Xenon | Rear Fog
1988 Grand Wagoneer | Burgundy | Ghost Flames | 360 ci | Holley carb

BMW CCA #422951

Reply With Quote
  #3  
Old 10-09-2012, 04:54 PM
steve3402 steve3402 is offline
Registered User
Location: NY, USA
 
Join Date: Oct 2012
Posts: 4
Mein Auto: 2004 X3
Windshield Wipers Problem

Thank you for this link. It seems that "chattering" is a constant noise. What I experienced was a one time flapping, and then normal operation. If it occurs again, I'll change the wiper blades. Interestingly, there seems to be several options as to which type to install. Looks as if the Bosch Icons have the most positive reviews. Thanks again.
Reply With Quote
  #4  
Old 10-10-2012, 04:25 AM
ncord ncord is offline
Officially Welcomed to the 'Fest
Location: ontario canada
 
Join Date: Nov 2009
Posts: 177
Mein Auto: 2006 X3
The Michelins are good to. Purchased mine at Walmart
Reply With Quote
  #5  
Old 10-10-2012, 10:23 AM
Supercourse Supercourse is offline
Officially Welcomed to the 'Fest
Location: British Columbia, Canada
 
Join Date: Feb 2008
Posts: 3,207
Mein Auto: 2004 X3 2.5i
Quote:
Originally Posted by steve3402 View Post
Has anyone ever experienced this and, if so, any explanations.
Are they the original wiper blades? That is, have replacement inserts always been used instead of replacing the entire blade?

Not exactly heard of this before. Aftermarket blades of plastic construction can crack and cause the sort of intermittent collapse you describe.

Hope that wouldn't happen with factory metal blades or the windshield would get scratched.

With other cars, I have heard of aftermarket blades loosening at the point of attachment, because some use adapters for universal fit.

If you do still have the factory blades, the only other thing I can think of is the insert has come out of its guides on one of the blades.

Time for a close inspection and visual check when parked?
Reply With Quote
  #6  
Old 10-19-2012, 10:27 AM
X3emist's Avatar
X3emist X3emist is offline
Officially Welcomed to the 'Fest
Location: NW Georgia USA
 
Join Date: Nov 2009
Posts: 1,324
Mein Auto: 06 X3 Sport
Here is what you need

Avaialble on Amazon

Rear- http://www.amazon.com/gp/product/B00...ls_o02_s00_i01

Front- http://www.amazon.com/gp/product/B00...ls_o00_s00_i00
http://www.amazon.com/gp/product/B00...ls_o00_s00_i01
__________________
2006 X3 Silver Grey/Black Lthr/Alum Trim/Sport Prem Pkg/Xenons/Servotronic/Prem Sound/Satellite Radio/Heated Seats/Carbon Fiber Pillars/Blue Tooth/Aux In/Cargo Net/Aluminum Pedals/V1 Hardwired
[SIGPIC]
Reply With Quote
  #7  
Old 10-19-2012, 11:04 AM
murderland murderland is offline
Officially Welcomed to the 'Fest
Location: s/s
 
Join Date: Jan 2011
Posts: 129
Mein Auto: x3
maybe your windshield wipers aren't installed properly. I had the dealership (bmw of silver spring) change my windshield wipers for me and a couple days later the wiper arm started to sound like it was hitting the windshield and then soon after it flung off.

scared the crap out of me, this was when it was on intermittent and it went into max.
Reply With Quote
  #8  
Old 10-19-2012, 11:33 AM
madurodave's Avatar
madurodave madurodave is offline
BMW Enthusiast!
Location: NH
 
Join Date: Oct 2008
Posts: 5,577
Mein Auto: 2007 Z4+X3, 2006 530Xi
Quote:
Originally Posted by steve3402 View Post
Looks as if the Bosch Icons have the most positive reviews. Thanks again.
I had Bosch Icons and now PIAA. I like the PIAA better - coats windshield which helps with keeping view clear and they are quiet. Airfoil on both driver and passenger side as well.
__________________
Madurodave

My garage: 2007 BMW Z4 3.0si Manual, 2007 BMW X3, 2006 BMW 530xi

Retired: 1998 BMW Z3

Member of BMWCCA!
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms