Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10-10-2012, 07:15 AM
Bengal2 Bengal2 is offline
Registered User
Location: MN
 
Join Date: Oct 2012
Posts: 13
Mein Auto: BMW X3
X3 ticking sound/CPO

I bought my 2007 X3 used while it was still under the original warranty and now I am under the last phase of my CPO with it expiring 11/21/12, a little over a month away.

Nine months after I purchased my X3 I took it in to the dealer for the SO irritating ticking noise. According to my invoice from the dealer they noted this condition I described in SIB 11 09 07. They checked the cylinder head casting number (755255004) and determined the issue was the exhaust lifters as the cause of the noise. They removed the engine valve cover, exhaust vanos unit and exhaust camshaft. They replaced all lifters using updated parts, installed camshaft and vanos unit, ensured proper valve timing and used new gaskets when installing the valve cover. The ticking went away for a while but reappeared when the weather got cold again but I didn't do anything about it. The ticking went away in the warm months but now that it is getting cold out again the ticking noise is back.

I am considering taking my X3 in before the CPO expires to look at this issue again but wondered if this issue is even covered under my CPO warranty. I just called the dealer and they said they couldn't tell me without looking a the vehicle and me paying the $50 deductible if this is covered under my CPO. Has anyone dealt with this issue under CPO and was it covered? Since this is a well known issue with BMW's and a recurring one with this vehicle I would hope it would be.

I would love to hear any suggestions and advice so I may get this taken care of before my CPO runs out.

Thank you-
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms