Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 10-10-2012, 06:35 AM
dale9n dale9n is offline
Registered User
Location: hanover, virginia, usa
 
Join Date: Apr 2011
Posts: 33
Mein Auto: 2000 bmw 328i sedan
EML code problems

So, I looked through the old posts on eml light being on. Didn't find what I needed. This is a 2000 328i that just started this problem. The eml light and the yellow triangle icon will light up and it will not run over 40 mph before surging and losing power. The check engine light also comes on. That has happened before due to the gas cap being old. However there are new codes now. Here they are with the info. But the first one I could not find info for.
P1250
P1624 - injection pump ( I guess this may be failing causing some of the rest )
P0441 - gas cap
P0601 __ internal control module memory check sum malfunction

If anyone can direct me to solve the part that causes the loss of power, I could be a hero to my wife on this one. Thanks, Dale in Va.
Reply With Quote
Advertisement
  #2  
Old 10-10-2012, 08:04 AM
smolck's Avatar
smolck smolck is offline
ROLL TIDE!
Location: Birmingham, AL
 
Join Date: Jul 2007
Posts: 22,348
Mein Auto: 2004 ZHP Sedan
Your throttle body is likely bad. Do you have a DBW or cable operated unit? They switched mid way through 2000.
__________________

Check out my YouTube Channel for DIY's and other fun stuff HERE
Check out my BMWBLOG!
Quote:
Originally Posted by Fast Bob View Post
now, go burn your Man Card, and buy yourself a Camry....
Reply With Quote
  #3  
Old 10-10-2012, 08:24 AM
dale9n dale9n is offline
Registered User
Location: hanover, virginia, usa
 
Join Date: Apr 2011
Posts: 33
Mein Auto: 2000 bmw 328i sedan
Thanks, not sure how to tell. Will I be able to tell by getting a clear look? Or do they know based on ser. #'s ?
Reply With Quote
  #4  
Old 10-10-2012, 09:02 AM
smolck's Avatar
smolck smolck is offline
ROLL TIDE!
Location: Birmingham, AL
 
Join Date: Jul 2007
Posts: 22,348
Mein Auto: 2004 ZHP Sedan
Quote:
Originally Posted by dale9n View Post
Thanks, not sure how to tell. Will I be able to tell by getting a clear look? Or do they know based on ser. #'s ?
Yea, if you have a drive by cable you will see it going through the firewall.
__________________

Check out my YouTube Channel for DIY's and other fun stuff HERE
Check out my BMWBLOG!
Quote:
Originally Posted by Fast Bob View Post
now, go burn your Man Card, and buy yourself a Camry....
Reply With Quote
  #5  
Old 10-10-2012, 09:23 AM
dale9n dale9n is offline
Registered User
Location: hanover, virginia, usa
 
Join Date: Apr 2011
Posts: 33
Mein Auto: 2000 bmw 328i sedan
Wow....found a price of 569.00. can these be repaired or rebuilt? dratts and double dratts.
Reply With Quote
  #6  
Old 10-10-2012, 09:32 AM
smolck's Avatar
smolck smolck is offline
ROLL TIDE!
Location: Birmingham, AL
 
Join Date: Jul 2007
Posts: 22,348
Mein Auto: 2004 ZHP Sedan
Quote:
Originally Posted by dale9n View Post
Wow....found a price of 569.00. can these be repaired or rebuilt? dratts and double dratts.
I get em used all day for $125-$150
__________________

Check out my YouTube Channel for DIY's and other fun stuff HERE
Check out my BMWBLOG!
Quote:
Originally Posted by Fast Bob View Post
now, go burn your Man Card, and buy yourself a Camry....
Reply With Quote
  #7  
Old 10-10-2012, 02:13 PM
dale9n dale9n is offline
Registered User
Location: hanover, virginia, usa
 
Join Date: Apr 2011
Posts: 33
Mein Auto: 2000 bmw 328i sedan
Oh..Now she tells me it stopped doing it for part of the day...When it happened again this afternoon, she turned it off and restarted...It then it ran fine all the way home...Do we have a bad connection, or is that what these throttle bodies do? thanks.
Reply With Quote
  #8  
Old 10-10-2012, 02:51 PM
smolck's Avatar
smolck smolck is offline
ROLL TIDE!
Location: Birmingham, AL
 
Join Date: Jul 2007
Posts: 22,348
Mein Auto: 2004 ZHP Sedan
Quote:
Originally Posted by dale9n View Post
Oh..Now she tells me it stopped doing it for part of the day...When it happened again this afternoon, she turned it off and restarted...It then it ran fine all the way home...Do we have a bad connection, or is that what these throttle bodies do? thanks.
Thats what they do. My old 323i ate 3 of em. Had the same codes and same symptoms.
__________________

Check out my YouTube Channel for DIY's and other fun stuff HERE
Check out my BMWBLOG!
Quote:
Originally Posted by Fast Bob View Post
now, go burn your Man Card, and buy yourself a Camry....
Reply With Quote
  #9  
Old 10-17-2012, 06:06 AM
dale9n dale9n is offline
Registered User
Location: hanover, virginia, usa
 
Join Date: Apr 2011
Posts: 33
Mein Auto: 2000 bmw 328i sedan
Hey Smolck, When you had this happen to you, did you figure out why the thing will run just fine one day, then screw up the next. Is there an electrical part of it that sends improper fuel mixture to the ignition or something? Gonna replace it next week when I'm off. Just wondering about the odd way it fails. Plus it is a cable TB. Do you have a connection for a good used one I could count on?
Thanks for the info too. dale in va.

Last edited by dale9n; 10-17-2012 at 06:47 AM.
Reply With Quote
  #10  
Old 10-26-2012, 01:51 AM
danfey danfey is offline
Registered User
Location: canada
 
Join Date: Apr 2012
Posts: 16
Mein Auto: 2000 bmw 328ci
Quote:
Originally Posted by dale9n View Post
So, I looked through the old posts on eml light being on. Didn't find what I needed. This is a 2000 328i that just started this problem. The eml light and the yellow triangle icon will light up and it will not run over 40 mph before surging and losing power. The check engine light also comes on. That has happened before due to the gas cap being old. However there are new codes now. Here they are with the info. But the first one I could not find info for.
P1250
P1624 - injection pump ( I guess this may be failing causing some of the rest )
P0441 - gas cap
P0601 __ internal control module memory check sum malfunction

If anyone can direct me to solve the part that causes the loss of power, I could be a hero to my wife on this one. Thanks, Dale in Va.
i think that is vanos problem.
Reply With Quote
  #11  
Old 10-26-2012, 07:28 PM
dale9n dale9n is offline
Registered User
Location: hanover, virginia, usa
 
Join Date: Apr 2011
Posts: 33
Mein Auto: 2000 bmw 328i sedan
i already bought a throttle body. installing it tuesday. i hope you are wrong. we will see soon enough. thanks dale.
Reply With Quote
Reply

Bookmarks

Tags
check engine light, eml, loss of power


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms