Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10-10-2012, 10:20 PM
JinxyJ08 JinxyJ08 is offline
Registered User
Location: Dublin, Ohio
 
Join Date: Aug 2011
Posts: 55
Mein Auto: '02 540i
How to re-wire the main engine wiring harness??

Well i haven't been on in a while as I have been contemplating selling my 540. I do really like it so i may fix it if i can figure out how to rewire part of the wiring harness from the ECM to the engine. I would also need to get a reprogrammed ECM which i beleive I have found as well. I have already replaced a good bit of parts on the car and the whole secondary air system minus the pump (all valves, hoses, "egr" gaskets intake rear manifold gasket, etc.)

About 5 months ago my car had a ton of issues (Here is the old thread title with allll of the information - '02 540i keeps dying? **UPDATED WITH CODES**) mainly with the car losing power at normal speeds and dying. Wouldnt stay running, sounded weird as hell, and overall just sucking at life.

Well i finally broke down and took it to Auto Assets which is a europeon only repair facility who has deemed the issue is a contstant 12 volts going to the EGR control valve. So the issue is the car has a constant vacuum leak with this valve open. They have said the car has a burnt ECM and the wires are burnt as well. I haven't pulled it all apart to inspect myself which i am going to do this weekend, but taking their word, i need to rewire the main engine wiring harness wires. Can someone tell me how to do this? My other option is to purchase a full wiiring harness from BMW since i cant find it anywhere else and spend tons of time replacing that thing which i REALLY dont want to do.

So if someone can help me figure out how to rewire this harness i would be greatful as can be as im sure it will need re-pinned at the connector.

Last edited by JinxyJ08; 10-10-2012 at 10:22 PM.
Reply With Quote
Advertisement
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms