Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10-20-2012, 08:18 PM
jim jam jim jam is offline
Registered User
Location: london england
 
Join Date: Oct 2012
Posts: 7
Mein Auto: 2001 x5 3.0 sport auto
crazy week with my 3.0 x5 auto

frst things first. hi every body. my names jamie i own a 2001 bmw x5 3.0i auto..........little story for you.... i love my car to bit,s and so fair it has been a dream to own. intill this week.. . right first thing was. i was about to take my grandad home he was looking like it was a bit hard for him to open the door from the out side, so i lent over to open the door from inside, and we both pulled at same time and broke the handle. now the door will only open from inside..then that night we had heavy rain. and i was out crashing about through the water. and youll never gess but, the trans failsafe mode come up on the dash. mpg went from 18 mpg to 12mpg and auto box was banging when changeing gear. soooo the next day i go to a friends garage. plug in to the computer and up comes fulty airmass sensor and cam sharft sensor....it get.s better so i dont think that could be makeing the auto box play up. but had been told to do a volt test as this is common fault, so we did that and was showing over 17v. so i went and got a new altonator. this changed nothing. we tested the volt tester and found that to be f..ked. so no need to change the alt. big wast of money and time. i have since found out that the airmass could infact be why the auto box is playing up. iv changed the cam sensor today and will have a new airmass sensor monday. hope that it will sort it out all in one week.....well that,s a HELLO if ever iv seen one

Last edited by jim jam; 10-21-2012 at 03:16 PM.
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms