Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)

E36 /7 Z3 (1996-2002)
E36/7 Z3 roadster and coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-21-2012, 04:30 PM
cabbit56 cabbit56 is offline
Registered User
Location: SF
 
Join Date: Oct 2012
Posts: 4
Mein Auto: 2000 Z3
2000 Z3 exhaust camshaft sensor

EDIT: originally it was a question thread. No one answered my questions and I got it fixed, so I'll just post what I did here.

Mine is a 2000 Z3, need to do a smog check but an engine light was on so I can't pass. The code is P1397, and the smog check shop told me it's the exhaust camshaft B. So after many google searches I kind of know what I have to do. Many people say it's a 10-15 minutes job so it sounds easy enough that I want to try to do it myself. I bought the part from Bavauto - the camshaft sensor, an o-ring, and a screw (they came together).


Took me quite a long time to find where it actually is under the hood.


I couldn't find it until I stuck my camera down and took a picture, then I saw a familiar shape.

I believe the thing I circled in red is the sensor. But how do I get it out?

Do I squeeze the place I circled in green (same squeezing place on the opposite side)? and pull it out? I tried but it didn't move a bit, but I didn't squeeze too hard as I wasn't sure if I was doing the right thing. (EDIT: yes, in order to take the connector out you need to squeeze that place and wiggle it out.)

Actually it was my luck that my engine light was off this morning when I started my car, so I seized the chance and drove to the smog check place. Had to let my car idle for 30 minutes because there were 3 cars before me, and I knew if I turned off my car and turned it back on, the engine light will also be on. When it's my turn, I kept my fingers crossed and hoped it'll pass, and it passed! But then I still got to fix the engine light, so I asked the technician if I should squeeze the connector and pull. After some explaining he said he could change that part for me, I was like "of course I wouldn't mind, thanks!" It took him less than 10 minutes, and he said I don't need to reset the light because it will turn off by itself. So I ran some more errands later today and after 2-3 starts, the light was gone, and did not come back on in the subsequent 2-3 starts. So I think it's fixed! Yay!

Last edited by cabbit56; 11-03-2012 at 09:53 PM.
Reply With Quote
Ads by Google
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms