Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 10-25-2012, 03:33 PM
Hemorrhage Hemorrhage is offline
Officially Welcomed to the 'Fest
Location: Pennsylvania
 
Join Date: May 2012
Posts: 277
Mein Auto: BMW 335xi
An Intricate Misfire.

Hello,

I'm hoping someone can help me with my problem.
I have a pretty intricate misfire going on. It's very random.

This is something that has been happening with my car for quite a few months now.
At first, it was very, very subtle. Now, it happens almost every time I accelerate heavily.
Half the time I can get it to do it on command. Other times, it doesn't feel like doing it.

So, here's when it occurs...
We'll say we're riding in 4th gear. If you ease into the throttle by pushing the pedal down gradually to the point where it wants to shift (but doesn't just yet), the car will start jerking back and forth. It does it pretty badly if you hold the throttle to the point right below where it wants to shift. However, it also just...acts up when it wants to anyway.

Like I said -- it happens sporadically.
Another thing to note...only 1/100 times will it throw the SES light.


I was on my way to school one day. It was acting up pretty bad to begin with. Usually when it starts acting up, I just get off of the throttle and then get right back on it. Well, I wanted the car to throw a code so I could find out if it actually was a misfire.
So, I held it at the shift point. It was riding like hell, and then it finally threw on the SES light. After that light came on, all hell broke loose and it felt like I was driving with one cylinder.

So, I got to school and put the scanner on it. Said cyl6 misfire.

Not so sure I'm convinced that it's an injector or coil.
If you want to see my reasoning on that, you can read this: http://www.bimmerfest.com/forums/sho...d.php?t=631854
But, there's always the chance that I'm wrong.


Any input is much appreciated.
Reply With Quote
Ads by Google
  #2  
Old 10-25-2012, 03:44 PM
Orient330iNYC's Avatar
Orient330iNYC Orient330iNYC is offline
Flying monkey herder
Location: Wall St
 
Join Date: Jul 2002
Posts: 7,072
Mein Auto: Daihatsu Terrios
have the intake valves been cleaned?
__________________
Past: 2001 330i ZSP/ZPP/Step
Past: 2004 S60R 6MT Sport
Past: 2007 335i 6MT ZSP/ZCW/322/655
Past: 2010 335xi ZMP/ZCW/ZPP/PPK/PE
Present: 2013 335i 6MT ZMM/ZDH/ZTP/3AG/494/508
Current Homeland Threat Level:
Reply With Quote
  #3  
Old 10-25-2012, 03:49 PM
TXFred TXFred is offline
Officially Welcomed to the 'Fest
Location: Austin, TX
 
Join Date: Apr 2012
Posts: 236
Mein Auto: 2008 335i Convertible
Injector or coil is the most likely cause. I had the exact symptoms you described on mine, and it was the coil.

The car ran fine, but would misfire under boost, then operate roughly and with reduced power until I shut it off and restarted it. I have I-Drive, so the screen would tell me which cylinder was misfiring.

The simple test is to move the coil to another cylinder, make it throw a code again, and see if the misfire is on the new cylinder.

Frederic
Reply With Quote
  #4  
Old 10-25-2012, 03:52 PM
Braumin Braumin is offline
Registered User
Location: SK, Canada
 
Join Date: Oct 2012
Posts: 41
Mein Auto: 2009 335i xDrive Sedan
Misfires under load like this are almost always the secondary ignition. My first guess would be a bad spark plug, and is the cheapest to test out.

If you change your plugs and are still having the issue, you can try swapping the coil on #6 with the one on #1 and see if the misfire moves to #1.
Reply With Quote
  #5  
Old 10-25-2012, 03:53 PM
Hemorrhage Hemorrhage is offline
Officially Welcomed to the 'Fest
Location: Pennsylvania
 
Join Date: May 2012
Posts: 277
Mein Auto: BMW 335xi
Quote:
Originally Posted by Orient330iNYC View Post
have the intake valves been cleaned?
Not that I know of.
Why would they need to be?

@TXFred I played that little swap game 500 times (refer to the link I posted).
The misfire has no pattern.


Quote:
Originally Posted by Braumin View Post
Misfires under load like this are almost always the secondary ignition. My first guess would be a bad spark plug, and is the cheapest to test out.

If you change your plugs and are still having the issue, you can try swapping the coil on #6 with the one on #1 and see if the misfire moves to #1.

I have new plugs in it. NGK Platinums or something. The car has 71.5k miles on it now. I believe I put the plugs in at 69k.

Last edited by Hemorrhage; 10-25-2012 at 03:54 PM.
Reply With Quote
  #6  
Old 10-25-2012, 04:06 PM
Braumin Braumin is offline
Registered User
Location: SK, Canada
 
Join Date: Oct 2012
Posts: 41
Mein Auto: 2009 335i xDrive Sedan
New plugs doesn't mean one isn't bad.

What do you mean by "the misfire has no pattern"

Do you mean the cylinder that misfires isn't always 6?
Reply With Quote
  #7  
Old 10-25-2012, 04:15 PM
Hemorrhage Hemorrhage is offline
Officially Welcomed to the 'Fest
Location: Pennsylvania
 
Join Date: May 2012
Posts: 277
Mein Auto: BMW 335xi
Quote:
Originally Posted by Braumin View Post
New plugs doesn't mean one isn't bad.

What do you mean by "the misfire has no pattern"

Do you mean the cylinder that misfires isn't always 6?
In the past several months this has been happening, I've only gotten it to throw one code...and that was cyl6.

Back when I had the tune in my car (in the link I posted), the misfire just had no pattern.
For example...
I'd swap the coils. The misfire would follow. Then I'd swap that coil with another, and the whole problem would go away. A couple drives later, a misfire would happen at a completely random cylinder.
So, instead of swapping this time, I'd just buy a new coil. Replaced it, and the misfire stayed with that cylinder. Swapped the new coil with another cylinder's coil, and the problem would go away.
A couple drives later, it would come back and be another random cylinder.
Reply With Quote
  #8  
Old 10-25-2012, 04:48 PM
Orient330iNYC's Avatar
Orient330iNYC Orient330iNYC is offline
Flying monkey herder
Location: Wall St
 
Join Date: Jul 2002
Posts: 7,072
Mein Auto: Daihatsu Terrios
the N54 is prone to carbon building on the intake valves, this leads to generally bad performance.
i suspect that at your mileage, this may be a factor in your misfires and stumbling
unfortunately, a walnut shell blasting of the valves is not cheap- 5-600 dollars, but the only way to clean it if you have the buildup. its visible if you pull the intake manifold.
__________________
Past: 2001 330i ZSP/ZPP/Step
Past: 2004 S60R 6MT Sport
Past: 2007 335i 6MT ZSP/ZCW/322/655
Past: 2010 335xi ZMP/ZCW/ZPP/PPK/PE
Present: 2013 335i 6MT ZMM/ZDH/ZTP/3AG/494/508
Current Homeland Threat Level:
Reply With Quote
  #9  
Old 10-25-2012, 04:51 PM
Hemorrhage Hemorrhage is offline
Officially Welcomed to the 'Fest
Location: Pennsylvania
 
Join Date: May 2012
Posts: 277
Mein Auto: BMW 335xi
Quote:
Originally Posted by Orient330iNYC View Post
the N54 is prone to carbon building on the intake valves, this leads to generally bad performance.
i suspect that at your mileage, this may be a factor in your misfires and stumbling
unfortunately, a walnut shell blasting of the valves is not cheap- 5-600 dollars, but the only way to clean it if you have the buildup. its visible if you pull the intake manifold.
Before taking the X hours to do that...isn't there a faster way to check if that MIGHT be a possibility?

Would checking the tips of the spark plugs give any insight?
Reply With Quote
  #10  
Old 10-25-2012, 05:06 PM
Orient330iNYC's Avatar
Orient330iNYC Orient330iNYC is offline
Flying monkey herder
Location: Wall St
 
Join Date: Jul 2002
Posts: 7,072
Mein Auto: Daihatsu Terrios
Quote:
Originally Posted by Hemorrhage View Post
Before taking the X hours to do that...isn't there a faster way to check if that MIGHT be a possibility?

Would checking the tips of the spark plugs give any insight?
borescope can check it as well, you need to get the tip of the probe into where the valves are.

sparkplug, no
__________________
Past: 2001 330i ZSP/ZPP/Step
Past: 2004 S60R 6MT Sport
Past: 2007 335i 6MT ZSP/ZCW/322/655
Past: 2010 335xi ZMP/ZCW/ZPP/PPK/PE
Present: 2013 335i 6MT ZMM/ZDH/ZTP/3AG/494/508
Current Homeland Threat Level:
Reply With Quote
  #11  
Old 10-25-2012, 05:09 PM
Hemorrhage Hemorrhage is offline
Officially Welcomed to the 'Fest
Location: Pennsylvania
 
Join Date: May 2012
Posts: 277
Mein Auto: BMW 335xi
Quote:
Originally Posted by Orient330iNYC View Post
borescope can check it as well, you need to get the tip of the probe into where the valves are.

sparkplug, no
Instead of pulling the intake...
Couldn't you just spray seafoam or whatever into the throttle body?
Reply With Quote
  #12  
Old 10-25-2012, 05:27 PM
DSXMachina's Avatar
DSXMachina DSXMachina is offline
Non compos Mentos
Location: New Hampshire
 
Join Date: Dec 2007
Posts: 10,474
Mein Auto: 335i E92 TiAg 6MT ED
Hmmm. I love random misfires. They're tough but very satisfying to figure out. With your engine we have to start by agreeing that the misfire isn't the cause but the effect. Something is going bad and it results in different cylinders misfiring. Based on the symptoms I think we can assume that your compression is good, and that your mechanicals are all functioning properly.
That leaves the problem with spark or fuel. Either you are randomly not getting spark or not getting fuel. The fact that you are not always getting a CEL tells me a lot about what it isn't, not an answer, but we're making progress. If I had your car in a bay I would take a look at short term fuel trim to see if you are constantly running borderline lean, that would point to either a bad air/fuel ratio sensor (you call it an oxygen sensor), or a bad mass airflow sensor, or a bad throttle position sensor, or a bad intake air temperature sensor.
The whole key is that the engine is not immediately setting a code.
Why? Because the computer thinks the bad device is sending a good signal, in other words the signal may be bad but it's plausible! Example: You install a Super Duper oil soaked intake air filter. The oil vaporizes and condenses on the mass airflow sensor. It cokes up over time and insulates the sensor wire. At 50 mph when the sensor should report 42 grams per second of air it reports 35. The condenser then commands enough fuel for 35 grams of air which results in a very lean mix. The mix gets critical under stress conditions (like accelerating) and a cylinder -or many cylinders- run so lean they missfire. Then the A/F ratio sensor sees all those unburned hydrocarbons going down the exhaust and -guess what?- CUTS BACK on the gas because it assumes you are rich when in fact you are lean. Now your engine is shaking like the San Andreas Fault on a bad day. You let off the gas and things get a little sorted out for a while.
See? It gets complicated. I doubt we are going to be able to help you resolve this problem without good information and without a graphing scanner you can't give it to us.

Or your intake valves could look like the La Brea Tar Pit. Tip o' the hat to Orient. His record is good on this subject.
Reply With Quote
  #13  
Old 10-25-2012, 05:29 PM
DSXMachina's Avatar
DSXMachina DSXMachina is offline
Non compos Mentos
Location: New Hampshire
 
Join Date: Dec 2007
Posts: 10,474
Mein Auto: 335i E92 TiAg 6MT ED
Quote:
Originally Posted by Hemorrhage View Post
Instead of pulling the intake...
Couldn't you just spray seafoam or whatever into the throttle body?
Do not put Sea Foam into your engine no matter how many miracle cures you watch on YouTube. SeaFoam is the STP of the 21st Century.

Last edited by DSXMachina; 10-25-2012 at 05:31 PM.
Reply With Quote
  #14  
Old 10-25-2012, 05:33 PM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,009
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by DSXMachina View Post
Do not put Sea Foam into your engine no matter how many miracle cures you watch on YouTube. SeaFoam is the STP of the 21st Century.

Whoa! What's the harm?
Reply With Quote
  #15  
Old 10-25-2012, 05:40 PM
Hemorrhage Hemorrhage is offline
Officially Welcomed to the 'Fest
Location: Pennsylvania
 
Join Date: May 2012
Posts: 277
Mein Auto: BMW 335xi
Quote:
Originally Posted by DSXMachina View Post
Hmmm. I love random misfires. They're tough but very satisfying to figure out. With your engine we have to start by agreeing that the misfire isn't the cause but the effect. Something is going bad and it results in different cylinders misfiring. Based on the symptoms I think we can assume that your compression is good, and that your mechanicals are all functioning properly.
That leaves the problem with spark or fuel. Either you are randomly not getting spark or not getting fuel. The fact that you are not always getting a CEL tells me a lot about what it isn't, not an answer, but we're making progress. If I had your car in a bay I would take a look at short term fuel trim to see if you are constantly running borderline lean, that would point to either a bad air/fuel ratio sensor (you call it an oxygen sensor), or a bad mass airflow sensor, or a bad throttle position sensor, or a bad intake air temperature sensor.
The whole key is that the engine is not immediately setting a code.
Why? Because the computer thinks the bad device is sending a good signal, in other words the signal may be bad but it's plausible! Example: You install a Super Duper oil soaked intake air filter. The oil vaporizes and condenses on the mass airflow sensor. It cokes up over time and insulates the sensor wire. At 50 mph when the sensor should report 42 grams per second of air it reports 35. The condenser then commands enough fuel for 35 grams of air which results in a very lean mix. The mix gets critical under stress conditions (like accelerating) and a cylinder -or many cylinders- run so lean they missfire. Then the A/F ratio sensor sees all those unburned hydrocarbons going down the exhaust and -guess what?- CUTS BACK on the gas because it assumes you are rich when in fact you are lean. Now your engine is shaking like the San Andreas Fault on a bad day. You let off the gas and things get a little sorted out for a while.
See? It gets complicated. I doubt we are going to be able to help you resolve this problem without good information and without a graphing scanner you can't give it to us.

Or your intake valves could look like the La Brea Tar Pit. Tip o' the hat to Orient. His record is good on this subject.
After trying everything that I did...the only thing I could think of would be a bad O2 sensor.
That, and maybe a clogged cat. Does that sound plausible?

I don't know...I'm still an apprentice technician going through school.


The car is under warranty. I WOULD just take it to BMW, but the idiots won't give me a loaner because I'm not 21. I guess people under 21 shouldn't take their car in for repairs.
Reply With Quote
  #16  
Old 10-25-2012, 05:41 PM
DSXMachina's Avatar
DSXMachina DSXMachina is offline
Non compos Mentos
Location: New Hampshire
 
Join Date: Dec 2007
Posts: 10,474
Mein Auto: 335i E92 TiAg 6MT ED
Quote:
Originally Posted by CALWATERBOY View Post
Whoa! What's the harm?
LOL. Cal, if you dump $12 in dimes into your gas tank there will be no harm. There will be no help either.
Don't want to derail the thread so can save the subject for another day. Willing to discuss in OT if you want, or start a thread about Will Sea Foam Cure My 328's Snazzlefrazzle Problem? or whatever.
Reply With Quote
  #17  
Old 10-25-2012, 05:41 PM
CALWATERBOY's Avatar
CALWATERBOY CALWATERBOY is offline
Officially Welcomed to the 'Fest
Location: San Francisco
 
Join Date: Aug 2009
Posts: 10,009
Mein Auto: 2009 E93 N54
Quote:
Originally Posted by Hemorrhage View Post
Instead of pulling the intake...
Couldn't you just spray seafoam or whatever into the throttle body?
re: Coked intake valves - not effective, especially for just a few seconds.

Can DIY - do you want to?

Forums say: Coked valves often occur ~60,000 mi

Most say it's a PCV carryover problem - Google can fill you in.

What codes are thrown?
Reply With Quote
  #18  
Old 10-25-2012, 05:47 PM
DSXMachina's Avatar
DSXMachina DSXMachina is offline
Non compos Mentos
Location: New Hampshire
 
Join Date: Dec 2007
Posts: 10,474
Mein Auto: 335i E92 TiAg 6MT ED
Quote:
Originally Posted by Hemorrhage View Post
After trying everything that I did...the only thing I could think of would be a bad O2 sensor.
That, and maybe a clogged cat. Does that sound plausible?

I don't know...I'm still an apprentice technician going through school.


The car is under warranty. I WOULD just take it to BMW, but the idiots won't give me a loaner because I'm not 21. I guess people under 21 shouldn't take their car in for repairs.
Clogged cat is very unlikely, but could result from continued driving with a bad miss. There are ways for the computer to pick up on potential major damage and will throw an immediate blinking CEL. So far you're good.
You need to take it to BMW if it's on warranty. This could easily turn into a $500 to $1500 repair bill otherwise. And it's not going to be something you can handle on your own anyway. Sorry kid, the thing is just too complex and sometimes you gotta know when to fold 'em. These types of problems take an L1 diagnostician (the best of the best) and a whole lot of experience to figure out.
Reply With Quote
  #19  
Old 10-25-2012, 05:53 PM
Hemorrhage Hemorrhage is offline
Officially Welcomed to the 'Fest
Location: Pennsylvania
 
Join Date: May 2012
Posts: 277
Mein Auto: BMW 335xi
Quote:
Originally Posted by CALWATERBOY View Post
re: Coked intake valves - not effective, especially for just a few seconds.

Can DIY - do you want to?

Forums say: Coked valves often occur ~60,000 mi

Most say it's a PCV carryover problem - Google can fill you in.

What codes are thrown?
After taking the JB4 out of my car (this is assuming you read the thread I linked), I bought a Bavarian Tech cable. My car was kind of running like **** even with the JB4 out, so I eventually just checked every code that was stored.

I had codes coming out of every orifice...
Codes from the transfer case.
The transmission.
The engine.
Etc.

Thinking it would be like all of the other times (where I would just delete the misfire code and the car would run like normal), I just deleted them. The car ran like normal after that.

I bring this up, because maybe those codes play a roll in what's happening now.
I did take a picture of each code before I deleted them. However, those are on my old phone, which doesn't have a charger.


However, ever since then, the only code I've gotten was a cyl6 misfire.



Quote:
Originally Posted by DSXMachina View Post
Clogged cat is very unlikely, but could result from continued driving with a bad miss. There are ways for the computer to pick up on potential major damage and will throw an immediate blinking CEL. So far you're good.
You need to take it to BMW if it's on warranty. This could easily turn into a $500 to $1500 repair bill otherwise. And it's not going to be something you can handle on your own anyway. Sorry kid, the thing is just too complex and sometimes you gotta know when to fold 'em. These types of problems take an L1 diagnostician (the best of the best) and a whole lot of experience to figure out.


I want to take it to BMW. But, I can't go without a car.

Last edited by Hemorrhage; 10-25-2012 at 05:55 PM.
Reply With Quote
  #20  
Old 10-25-2012, 06:05 PM
DSXMachina's Avatar
DSXMachina DSXMachina is offline
Non compos Mentos
Location: New Hampshire
 
Join Date: Dec 2007
Posts: 10,474
Mein Auto: 335i E92 TiAg 6MT ED
Quote:
Originally Posted by Hemorrhage View Post
After taking the JB4 out of my car (this is assuming you read the thread I linked), I bought a Bavarian Tech cable. My car was kind of running like **** even with the JB4 out, so I eventually just checked every code that was stored.

I had codes coming out of every orifice...
Codes from the transfer case.
The transmission.
The engine.
Etc.

Thinking it would be like all of the other times (where I would just delete the misfire code and the car would run like normal), I just deleted them. The car ran like normal after that.



I bring this up, because maybe those codes play a roll in what's happening now.
I did take a picture of each code before I deleted them. However, those are on my old phone, which doesn't have a charger.


However, ever since then, the only code I've gotten was a cyl6 misfire.







I want to take it to BMW. But, I can't go without a car.
You had all those codes because your voltage dropped below about 10 volts at some point. That'll light up everything including the ABS/DTC/DSC Christmas tree.

You will be going without a car soon, one way or another.
Reply With Quote
  #21  
Old 10-25-2012, 06:07 PM
Hemorrhage Hemorrhage is offline
Officially Welcomed to the 'Fest
Location: Pennsylvania
 
Join Date: May 2012
Posts: 277
Mein Auto: BMW 335xi
Quote:
Originally Posted by DSXMachina View Post
You had all those codes because your voltage dropped below about 10 volts at some point. That'll light up everything including the ABS/DTC/DSC Christmas tree.

You will be going without a car soon, one way or another.
This problem could become something that serious?
Figured I'd just have to put up with a "shaky" engine until the end of time.
Reply With Quote
  #22  
Old 10-25-2012, 06:10 PM
Hemorrhage Hemorrhage is offline
Officially Welcomed to the 'Fest
Location: Pennsylvania
 
Join Date: May 2012
Posts: 277
Mein Auto: BMW 335xi
Another reason I'm skeptical about taking it to BMW is that they're idiots.
I asked, "Is this covered until my CPO warranty?"

She goes, "There are hundreds of things that could cause it. Once we diagnose it, we will tell you."

Meanwhile, a customer came to my shop because he had a misfire. BMW told him he needed a new computer.
Whereas, in reality, he just needed an injector...

So, I'm assuming they're going to do what they can to get money out of me.
Reply With Quote
  #23  
Old 10-25-2012, 06:18 PM
DSXMachina's Avatar
DSXMachina DSXMachina is offline
Non compos Mentos
Location: New Hampshire
 
Join Date: Dec 2007
Posts: 10,474
Mein Auto: 335i E92 TiAg 6MT ED
Quote:
Originally Posted by Hemorrhage View Post
Another reason I'm skeptical about taking it to BMW is that they're idiots.
I asked, "Is this covered until my CPO warranty?"

She goes, "There are hundreds of things that could cause it. Once we diagnose it, we will tell you."

Meanwhile, a customer came to my shop because he had a misfire. BMW told him he needed a new computer.
Whereas, in reality, he just needed an injector...

So, I'm assuming they're going to do what they can to get money out of me.
I read the July thread twice, and this one again as well. There's nothing I can do to help you because you can't be helped. There are many lessons to be learned when you're in college. Most of the good ones don't occur in the classroom.
Reply With Quote
  #24  
Old 10-25-2012, 06:37 PM
Hemorrhage Hemorrhage is offline
Officially Welcomed to the 'Fest
Location: Pennsylvania
 
Join Date: May 2012
Posts: 277
Mein Auto: BMW 335xi
Quote:
Originally Posted by DSXMachina View Post
I read the July thread twice, and this one again as well. There's nothing I can do to help you because you can't be helped. There are many lessons to be learned when you're in college. Most of the good ones don't occur in the classroom.
What do you mean by "you can't be helped"?
Reply With Quote
  #25  
Old 10-25-2012, 06:46 PM
DSXMachina's Avatar
DSXMachina DSXMachina is offline
Non compos Mentos
Location: New Hampshire
 
Join Date: Dec 2007
Posts: 10,474
Mein Auto: 335i E92 TiAg 6MT ED
Quote:
Originally Posted by Hemorrhage View Post
What do you mean by "you can't be helped"?
Because you gave us the history of the car, asked for advice, were given advice -the only practical advice, and you don't want to follow it.
Frankly, it would be easier to diagnose a brain aneurysm (if you had access to an MRI) than it will be to diagnose your problem. You've been dealing with this for three months and are not one bit closer to a diagnosis than you were in the beginning. So what more can be done?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms